Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 180958 - media-video/totem sandbox violation with system-wide mandatory gconf settings
Summary: media-video/totem sandbox violation with system-wide mandatory gconf settings
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-05 13:14 UTC by Thomas Koster
Modified: 2008-08-25 08:44 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Koster 2007-06-05 13:14:51 UTC
media-video/totem causes sandbox violations at pre-install when system-wide gconf settings are in use: the addpredict lines in src_compile only account for /root/gconf (which incidentally also causes problems for users with a non-standard location for root's home directory), whereas system-wide gconf settings are in /etc/gconf.

Reproducible: Always

Steps to Reproduce:
1. Set system-wide gconf settings in /etc/gconf
2. emerge media-video/totem
Actual Results:  
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-media-video_-_totem-2.16.5-xxxxx.log"

open_wr:   /etc/gconf/.../.../.testing.writeability
unlink:    /etc/gconf/.../.../.testing.writeability
--------------------------------------------------------------------------------


Expected Results:  
(successful emerge)
Comment 1 Norberto Bensa 2007-06-10 17:41:27 UTC
I did, emerge -1 gnome-doc-utils, and I got totem emerged. Don't ask me why... :-/
Comment 2 Gilles Dartiguelongue gentoo-dev 2007-08-04 15:20:04 UTC
so you can't actually reproduce the problem, do you ?
Comment 3 Mats Hellman 2007-08-30 09:33:53 UTC
I had the same problems. Access violations merging totem.
Re merging gnome-doc-utils fixes this. 
Comment 4 Willard Dawson 2007-08-30 13:17:15 UTC
Ditto on comment #3. Re-emerging gnome-doc-utils fixes this.
Comment 5 Sergiy Borodych 2007-09-09 09:25:45 UTC
Have the same problem for
[ebuild     U ] media-video/totem-2.18.3 [2.18.2] USE="a52 dvd ffmpeg flac gnome hal nsplugin ogg seamonkey vorbis xv -debug -lirc -mad -mpeg -nvtv -theora -xulrunner" 0 kB

...
make[1]: Leaving directory `/var/tmp/portage/media-video/totem-2.18.3/work/totem-2.18.3'
>>> Source compiled.
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-media-video_-_totem-2.18.3-28021.log"

unlink:    /usr/share/xml2po/docbook.pyc
open_wr:   /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
open_wr:   /usr/share/xml2po/docbook.pyc
--------------------------------------------------------------------------------


re-emerge gnome-doc-utils help me too
Comment 6 Gilles Dartiguelongue gentoo-dev 2007-09-09 22:08:32 UTC
guys, stop flooding this bug with gnome-doc-utils/python-2.5 migration sandbox violation and check bug #104088.

This bug is about different a different issue which appears with read-only settings in gconf.
Comment 7 Rémi Cardona gentoo-dev 2008-05-27 19:26:29 UTC
Is this still an issue with totem 2.22* ? Could you also explain what you mean by "Set system-wide gconf settings in /etc/gconf" exactly?

Thanks
Comment 8 Gilles Dartiguelongue gentoo-dev 2008-05-27 22:58:30 UTC
system wide mandatory settings as in /etc/gconf/gconf.xml.mandatory... for once I'm sure you have totem on your box, please test it by yourself before blindly closing a bug. Reopening 'till I see a report based on facts or check it myself.
Comment 9 Rémi Cardona gentoo-dev 2008-05-28 06:19:04 UTC
I know what system wide gconf means. I just wanted to know what Thomas implied by that. What gconf key did he modify ? Did he set it as mandatory or default? Hence the NEEDINFO, because I feel we "need more info"...

And no i'm not "closing" the bug, i'm just using the appropriate mechanisms provided by bugzilla. But fine I'll leave it open
Comment 10 skelter 2008-08-02 14:49:13 UTC
kind of frustrating.  I ran into this bug repeatedly and then prepared my emerge info, and re-ran emerge --update --newuse --deep world > emerge.log 2>&1 to be able to post it as an attachment, and then it worked.  Is it possible some sort of race condition is involved?  I'm not sure how much more info I could provide now that I cannot repro the bug.
Comment 11 Rémi Cardona gentoo-dev 2008-08-25 08:44:04 UTC
Closing NEEDINFO again.

@Thomas and Skelter,

If either of you can provide more information about the bug, for example a full build log, or even just the name of the keys which you guys have made mandatory so that we can try this, that'd be really cool.

Don't hesitate to reopen this bug with any additional information you can give us.

Thanks