Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 180678 - app-misc/mc - chmod fails due to hardcoded /usr/lib
Summary: app-misc/mc - chmod fails due to hardcoded /usr/lib
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-03 00:38 UTC by Sebastijan Vacun
Modified: 2009-08-05 11:36 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Diff to mc-4.6.1-r3.diff to use multilib and $(get_libdir) (mc-4.6.1-r3.diff,753 bytes, patch)
2007-06-03 01:29 UTC, Jorge Manuel B. S. Vicetto
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastijan Vacun 2007-06-03 00:38:48 UTC
At the end of installation:
chmod: cannot access `/var/tmp/portage/app-misc/mc-4.6.1-r3/image//usr/lib/mc/cons.saver': No such file or directory
 * Applying mc-4.6.0-ebuild-syntax.patch ...                                                                                                                                               [ ok ]
>>> Completed installing mc-4.6.1-r3 into /var/tmp/portage/app-misc/mc-4.6.1-r3/image/

Missing one space?

Reproducible: Always




app-misc/mc-4.6.1-r3
first install (not upgrade)

I think this is syntax error and happens every time, so no additional info is nedded
Comment 1 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2007-06-03 01:08:57 UTC
The problem seems to be caused by the following in src_install:

fperms u+s /usr/lib/mc/cons.saver
Comment 2 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2007-06-03 01:29:14 UTC
Created attachment 120997 [details, diff]
Diff to mc-4.6.1-r3.diff to use multilib and $(get_libdir)

This solved my error on amd64.
Comment 3 Wulf Krueger (RETIRED) gentoo-dev 2007-06-03 10:18:46 UTC
Fixed in CVS.