Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 180355 - "emerge -uDNav world" does not want to update everything that "emerge -uav world" does
Summary: "emerge -uDNav world" does not want to update everything that "emerge -uav wo...
Status: RESOLVED DUPLICATE of bug 1343
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Interface (emerge) (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-05-30 16:07 UTC by Timo Rothweiler
Modified: 2007-05-30 21:43 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timo Rothweiler 2007-05-30 16:07:01 UTC
Today I realized, when I used eix to look up app-emulation/vmware-modules, that I did not have the latest version of that package installed (which is from the vmware overlay, btw).
So I thought I'd run a new world update and emerge --sync'ed. After that, I ran "emerge -uDNav world" - which to my surprise told me that there's nothing to update. My first guess was that it might not be in my world file, so I checked - and it was there. When I tried to run "emerge -uav world", vmware-modules actually showed up to be updated.

Reproducible: Always

Steps to Reproduce:
1. emerge -uDNav world: Total: 0 packages, Size of downloads: 0 kB
2. emerge -uav world: [ebuild     U ] app-emulation/vmware-modules-1.0.0.16 [1.0.0.15-r1] 31,607 kB [1]


Expected Results:  
When I run "emerge -uDNav world", I expect that I have no less packages to be upgraded than when I'd run "emerge -uav world".

complete output of "emerge -uDNav world":
-----------------------------------------

timo ~ # emerge -uDNav world

These are the packages that would be merged, in order:

Calculating world dependencies... done!

Total: 0 packages, Size of downloads: 0 kB

Nothing to merge; would you like to auto-clean packages? [Yes/No] n

Quitting.


complete output of "emerge -uav world":
---------------------------------------

timo ~ # emerge -uav world

These are the packages that would be merged, in order:

Calculating world dependencies... done!
[ebuild     U ] app-emulation/vmware-modules-1.0.0.16 [1.0.0.15-r1] 31,607 kB [1]

Total: 1 package (1 upgrade), Size of downloads: 31,607 kB
Portage overlays:
 [1] /usr/portage/local/layman/vmware
 [2] /usr/portage/local/layman/xeffects

Would you like to merge these packages? [Yes/No] n

Quitting.


/var/lib/portage/world:
-----------------------
media-fonts/artwiz-fonts
net-misc/openvpn
x11-themes/audacious-themes
x11-themes/qtcurve
media-sound/alsa-utils
media-video/nvidia-settings
sys-fs/reiserfsprogs
x11-themes/gtk-engines-qtcurve
net-www/netscape-flash
media-fonts/freefonts
app-misc/screen
sys-apps/sdparm
media-sound/rip
net-irc/irssi
app-emulation/vmware-server
kde-misc/ksplash-engine-moodin
media-fonts/unifont
media-gfx/feh
app-office/openoffice
net-www/mplayerplug-in
x11-themes/gtk-engines-qt
media-fonts/terminus-font
media-sound/audacious
www-client/mozilla-firefox
media-video/mplayer
net-dns/bind-tools
sys-process/vixie-cron
media-video/dvdbackup
x11-base/xorg-x11
media-plugins/audacious-crossfade
media-fonts/dejavu
x11-misc/googleearth
sys-boot/grub
dev-util/subversion
net-www/nspluginwrapper
app-text/acroread
net-analyzer/netcat
media-fonts/ttf-bitstream-vera
sys-process/htop
media-gfx/gimp
kde-misc/taskbar-compiz
media-fonts/corefonts
app-arch/unrar
app-portage/layman
sys-kernel/gentoo-sources
kde-misc/dolphin
dev-util/cvs
media-plugins/alsa-plugins
sys-apps/lshw
media-sound/vorbis-tools
media-fonts/intlfonts
app-cdr/k3b
app-emulation/vmware-modules
sys-process/schedutils
media-fonts/sharefonts
net-fs/nfs-utils
www-client/opera
net-misc/dhcpcd
mail-client/mozilla-thunderbird
app-portage/eix
kde-misc/yakuake
x11-wm/beryl
kde-misc/kdmtheme
app-portage/gentoolkit
x11-drivers/nvidia-drivers
net-ftp/lftp
app-admin/pydf
net-misc/ntp
kde-base/kde-meta
app-admin/metalog
app-portage/genlop
app-portage/conf-update

emerge --info:
--------------
Portage 2.1.2.7 (default-linux/amd64/2007.0/desktop, gcc-4.2.0, glibc-2.5-r3, 2.6.21-gentoo-r2 x86_64)
=================================================================
System uname: 2.6.21-gentoo-r2 x86_64 Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
Gentoo Base System release 2.0.0_alpha3
Timestamp of tree: Wed, 30 May 2007 15:20:01 +0000
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.23b
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/home/distfiles"
FEATURES="buildpkg distlocks fixpackages metadata-transfer parallel-fetch sandbox sfperms strict userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://mirrors.sec.informatik.tu-darmstadt.de/gentoo http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LC_ALL="en_US.utf8"
MAKEOPTS="-j3"
PKGDIR="/home/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/vmware /usr/portage/local/layman/xeffects"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="amd64 kdeenablefinal xinerama" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nv nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Timo Rothweiler 2007-05-30 18:48:58 UTC
Well, I just found out that after I've upgraded vmware-modules, emerge -uav world now does want to do nothing, but emerge -uDNav world wants to downgrade vmware-modules again, as vmware-server seems to depend on a specific version.
So I now believe that this actually is not a portage bug, but still a slightly confusing behaviour.
I don't know how to mark this bug and don't know if this is the wanted behaviour of portage. So I'll just leave it as new for now, and leave it to dev-portage@gentoo.org to change its status.
Comment 2 Zac Medico gentoo-dev 2007-05-30 21:43:50 UTC
(In reply to comment #1).
> I don't know how to mark this bug and don't know if this is the wanted
> behaviour of portage. So I'll just leave it as new for now, and leave it to
> dev-portage@gentoo.org to change its status.

The -D behavior is correct.  Future versions of portage will behave correctly in any case.  You'll also be able to get a warning if something like vmware-server is  holding back an upgrade.

*** This bug has been marked as a duplicate of bug 1343 ***