Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 180236 - dev-util/rapidsvn-0.9.4 missing dep on apr{,-util} slot 0
Summary: dev-util/rapidsvn-0.9.4 missing dep on apr{,-util} slot 0
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Steve Arnold
Depends on:
Reported: 2007-05-29 16:17 UTC by Carsten Weidmann
Modified: 2007-06-26 05:41 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

/var/tmp/portage/dev-util/rapidsvn-0.9.4/work/rapidsvn-0.9.4/config.log (config.log,37.08 KB, text/plain)
2007-05-29 16:19 UTC, Carsten Weidmann
/var/tmp/portage/dev-util/rapidsvn-0.9.4/temp/build.log (build.log,9.19 KB, text/plain)
2007-05-29 16:20 UTC, Carsten Weidmann

Note You need to log in before you can comment on or make changes to this bug.
Description Carsten Weidmann 2007-05-29 16:17:03 UTC
rapidsvn-0.9.4 fails during econf due to missing APR util. dev-libs/apr-util-1.2.8 is installed. Even after reemerging apr-util, rapidsvn-0.9.4 still fails with the same error.

Reproducible: Always

Steps to Reproduce:
1. emerge rapidsvn

Actual Results:  
econf fails

Expected Results:  
successful emerge

emerge --info:

Portage (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.5-r3, 2.6.21-gentoo-r2 i686)
System uname: 2.6.21-gentoo-r2 i686 AMD Athlon(tm) XP 1800+
Gentoo Base System release 1.12.10
Timestamp of tree: Mon, 28 May 2007 16:00:01 +0000
dev-java/java-config: 1.3.7, 2.0.33
dev-lang/python:     2.3.6-r2, 2.4.4-r4
dev-python/pycrypto: 2.0.1-r5
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.23b
virtual/os-headers:  2.6.21
CFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
FEATURES="distlocks metadata-transfer sandbox sfperms strict"
LINGUAS="de en"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
USE="16bit 3dnow 3dnowext 7zip X X509 a52 aac aalib acl acpi aim aimextras alsa asm audiofile bash-completion bdf bitmap-fonts bl blender-game bzip2 c++ cairo cdparanoia cdr clamav cli cpudetection cracklib crypt css cups curl curlwrappers dbus deprecated devil dga discouraged divx divx4linux doc dri dv dvd dvdr dvdread dvi edl eds emboss encode epiphany evo evolution examples exif fam fbcon ffmpeg firefox flac fluidsynth fmod freetype gaim gdbm gif gimp glade glibc-omitfp glitz glut gmedia gnokii gnome gphoto2 gpm gs gsf gstreamer gtk gtkhtml guile gvim hal iconv icq idn ieee1394 imagemagick imap imlib ipv6 isdnlog jabber jack jack-tmpfs java jikes joystick jpeg jpeg2k kcal kdeenablefinal kdepim ladcca ladspa latex lcd lcms libg++ lirc live lzo lzw mad midi mikmod mime mjpeg mmx mng modplug moznocompose moznoirc moznomail mozsvg mp3 mpeg mpeg2 mpeg4 mplayer msn mudflap musicbrainz mysql nas nautilus ncurses nls nocd nptl nptlonly nsplugin ofx ogg openal openexr opengl openmp oscar pam pascal pcre pdf perl php png postgres povray ppds pppd python qemu-fast qt3 qt3support qt4 quicktime rar readline real realmedia reflection regex ruby scanner sdl seamonkey session silc slang sndfile softmmu sounds spamassassin speedo speex spell spl sql sqlite sqlite3 sse sse-filters ssl subtitles subversion svg svgz sysfs tcpd tetex tga theora threads thumbnailing tiff transcode truetype truetype-fonts type1 type1-fonts unicode usb v4l v4l2 valgrind vcd vcdimager videos vidix vim vim-pager vim-with-x visualization vorbis win32codecs wma wmf wmp x86 xanim xforms xfs xft xine xml xorg xpm xslt xv xvid xvmc yahoo yv12 zlib zvbi" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en" USERLAND="GNU" VIDEO_CARDS="radeon ati vesa fbdev nv nvidia"
Comment 1 Carsten Weidmann 2007-05-29 16:19:36 UTC
Created attachment 120623 [details]
Comment 2 Carsten Weidmann 2007-05-29 16:20:50 UTC
Created attachment 120624 [details]
Comment 3 Carsten Weidmann 2007-05-29 16:22:30 UTC
for the record:

#emerge -s apr
[ Results for search key : apr ]
[ Applications found : 11 ]
*  dev-libs/apr
      Latest version available: 1.2.8
      Latest version installed: 1.2.8
      Size of files: 1,081 kB
      Description:   Apache Portable Runtime Library
      License:       Apache-2.0

*  dev-libs/apr-util
      Latest version available: 1.2.8
      Latest version installed: 1.2.8
      Size of files: 631 kB
      Description:   Apache Portable Runtime Library
      License:       Apache-2.0
Comment 4 Steve Arnold archtester gentoo-dev 2007-06-02 18:33:36 UTC
I can't reproduce this, as it builds fine here on amd64 and x86.  Is there something amiss in your toolchain?   Have you cleaned out any eselect remnants?  You could also have something funky being pulled in by your ~x86; I would recommend using ACCEPT_KEYWORDS="x86" and only put the packages you need in package.keywords.

One thing you could try is modifying the ebuild to add the second config parameter, although it isn't needed here, it's about the only other thing I can think of...

Find the line in the ebuild with this parameter:


and add another one like so:


You can also add another dep for apr-util, but as it's already installed that shouldn't make any difference.  If you edit the one in /usr/portage it will get wiped by the next sync; if you want to keep it (and have it override the portage version) make sure you put your copy in /usr/local/portage (or wherever your overlay is).
Comment 5 Carsten Weidmann 2007-06-15 12:25:16 UTC
This is really weird. The --with-apu-config option didn't work either, neither as addon nor as replacement (always same error). 

I have a laptop (PIII) with pretty much the same setup (also ~x86) and there, rapidsvn-0.9.4 compiles without problems. First I thought it was due to the different profiles I used (2006.1 on the laptop, 2007.0 on the desktop), but no chance. Then I compared all use flags of apr, apr-util and rapidsvn. "berkdb" was set on the laptop but changing that on the desktop (and doing -uavDN world) didn't help either :( 

I'm about to do a complete and clean reinstall of this machine, maybe in course of the last 3 or 4 years that this setup has been running, something wrong got in there...

Does anybody have any other idea? Thanks a lot in advance!
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2007-06-17 15:36:30 UTC
Do you have =dev-libs/apr{-util}-0.9* installed? This depends on it.

emerge portage-utils; qlist -CIv /apr
Comment 7 Carsten Weidmann 2007-06-17 17:18:09 UTC
Thanks, that was the problem:

#qlist -CIv /apr

dev/libs/apr-util-0.9.12-r1 was missing (don't know how that got lost though). After emerging it, the emerge of rapidsvn-0.9.4 went fine :-)

Again, thanks a lot for your help!

p.s.: Should a dependency to apr-util-0.9* be added to the ebuild? Don't know, if that would have helped me?!
Comment 8 Ralph Hartley 2007-06-21 19:38:19 UTC
I see the same problem.

Rapidsvn needs =dev-libs/apr{-util}-0.9* but doesn't depend on it as it should. Instead it relies on subversion to depend on it.

But Subversion only asks for >=dev-libs/apr-util-9.7 so that's wrong.

I have dev-libs/apr-util-1.2.8 which satisfies subversion, but rapidsvn won't compile with it.

Adding the correct dependency should fix it.
Comment 9 Levi Figueira 2007-06-22 17:32:28 UTC
I could reproduce it and fix it using the above solution!

Thanks for the help!
Comment 10 Steve Arnold archtester gentoo-dev 2007-06-26 02:22:12 UTC
Okay, it turns out the newer libapr stuff works, however, it should match the one used by subversion and apache.  There's some info here in the subversion howto:

I've updated the rapidsvn ebuilds to match the latest subversion ebuilds, in terms of both DEPENDS and configure options for apr and apr-utils (only now we're using the options given by configure's --help output).  I've also fixed the desktop file in the 0.9.3 ebuild.  They should hit a mirror near you shortly...
Comment 11 Steve Arnold archtester gentoo-dev 2007-06-26 05:41:20 UTC
Fixed - please test, and we'll get 0.9.4 stablized if there are no more issues...