Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 179899 - media-libs/xine-lib does not tell a52dec to use djbfft
Summary: media-libs/xine-lib does not tell a52dec to use djbfft
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-05-26 15:46 UTC by Daniel Burr
Modified: 2007-12-29 22:08 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Add --enable-djbfft to xine-lib configure script (xine-lib-1.1.4-external-a52dec-with-djbfft.patch,1.55 KB, patch)
2007-05-26 15:48 UTC, Daniel Burr
Details | Diff
Add djbfft USE flag to xine-lib (xine-lib-1.1.4-r3.ebuild,5.50 KB, text/plain)
2007-05-26 15:48 UTC, Daniel Burr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Burr 2007-05-26 15:46:08 UTC
When a52dec is emerged with the djbfft USE flag then it is able to do optimised FFTs using the djbfft library.  This is activated by setting the MM_ACCEL_DJBFFT flag when calling a52_init.   The problem is that the internal version of a52dec in xine-lib is an older version which used the Solaris-specific mlib for FFT acceleration.  MM_ACCEL_DJBFFT and MM_ACCEL_MLIB are defined to be the same value (0x00000001).

The attached patch adds an --enable-djbfft flag to configure.ac which is only checked when xine-lib wants to use an external version of a52dec.  If set, then MM_ACCEL_MLIB is added to the flags which is equivalent to passing MM_ACCEL_DJBFFT to an external a52dec.  The attached ebuild adds support for the djbfft USE flag to xine-lib.

Reproducible: Always

Steps to Reproduce:
1. Add djbfft and a52 to USE flags
2. emerge a52dec with djbfft library
3. emerge xine-ui with external a52 library

Actual Results:  
xine-lib displays "No accelerated IMDCT transform found" when playing back DVDs with A/52 audio.

Expected Results:  
xine-lib displays "Using djbfft for IMDCT transform" when playing back DVDs with A/52 audio.
Comment 1 Daniel Burr 2007-05-26 15:48:11 UTC
Created attachment 120383 [details, diff]
Add --enable-djbfft to xine-lib configure script
Comment 2 Daniel Burr 2007-05-26 15:48:49 UTC
Created attachment 120384 [details]
Add djbfft USE flag to xine-lib
Comment 3 Samuli Suominen (RETIRED) gentoo-dev 2007-09-24 14:44:25 UTC
This needs to go upstream, have you reported it?
Comment 4 Diego Elio Pettenò (RETIRED) gentoo-dev 2007-12-21 15:33:07 UTC
Upstream rejects this patch, please find a different solution.
Comment 5 Daniel Burr 2007-12-21 17:27:18 UTC
Upstream doesn't want the fix so I see 3 options:

1.  Apply this patch as gentoo specific
2.  Remove support for external liba52 from the xine-lib ebuild
3.  Add a patch to the a52dec ebuild to always enable djbfft support if it was compiled in
Comment 6 Diego Elio Pettenò (RETIRED) gentoo-dev 2007-12-21 23:52:46 UTC
Option 1 and 2 are completely unacceptable.

But I've fixed this properly in Mercurial code of xine-lib, to be released in 1.1.9 (which should be soon enough, as it's due before KDE4 gets released).
Comment 7 Diego Elio Pettenò (RETIRED) gentoo-dev 2007-12-29 22:08:57 UTC
Marking this as UPSTREAM as the bug is resolved upstream.