Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 179289 - net-im/gaim-2.00*: runtime-only plugin packages pulled in via USE in *DEPEND
Summary: net-im/gaim-2.00*: runtime-only plugin packages pulled in via USE in *DEPEND
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: High enhancement (vote)
Assignee: Gentoo net-im Herd
URL: http://devmanual.gentoo.org/general-c...
Whiteboard:
Keywords:
Depends on:
Blocks: 187736
  Show dependency tree
 
Reported: 2007-05-21 03:07 UTC by Jeroen Roovers (RETIRED)
Modified: 2007-10-04 20:14 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
gaim-2.0.0.ebuild-bug-179289.diff (gaim-2.0.0.ebuild-bug-179289.diff,1.02 KB, patch)
2007-05-21 03:09 UTC, Jeroen Roovers (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Roovers (RETIRED) gentoo-dev 2007-05-21 03:07:15 UTC
The gaim-2.0.0_beta6.ebuild contains IUSE="... crypt ..." and a single use of that USE flag:

PDEPEND="crypt? ( >=x11-plugins/gaim-encryption-3.0_beta5 )"

The USE flag does not appear to have any other use in this ebuild, and gaim-1.5.0.ebuild doesn't have crypt in IUSE either. As x11-plugins/gaim-encryption is only pulled in after gaim is installed, the USE flag and PDEPEND have no use and should both be removed from the ebuild.
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2007-05-21 03:09:46 UTC
Created attachment 119861 [details, diff]
gaim-2.0.0.ebuild-bug-179289.diff
Comment 2 Dawid Węgliński (RETIRED) gentoo-dev 2007-05-21 06:47:30 UTC
This is just a plugin to encrypt conversation using RSA. You can load it in gaim plugins menu. Not a bug, imo.
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2007-05-21 15:48:15 UTC
It's not a bug as such, it's simply a misconception and an abuse of what USE and PDEPEND are intended for. If the only achievement of this superfluous construct is emerging a separate package, then enabling a USE flag for it is tantamount to emerging the package "manually". I.e. it gains the user/admin nothing and only serves to create false dependencies (which make arch devs cry).

CC'ing QA as this is probably something that needs to be clarified (better) at the URL I set.
Comment 4 SpanKY gentoo-dev 2007-05-21 19:45:56 UTC
i'd really disagree with that assessment ... i see no problem with packages pulling in additional plugins based on USE flags for such features

plus the mentioned URL implies this is valid:
This is sometimes used for plugins which have a dependency upon the package being merged.
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2007-05-21 22:29:17 UTC
(In reply to comment #4)
> i'd really disagree with that assessment ... i see no problem with packages
> pulling in additional plugins based on USE flags for such features

repoman sees problems. Suddenly, keywording a package for an arch is no longer enough - I find myself doing testing and keywording on packages that are only required by a single mechanism, namely the dependency set by the ebuild.

> plus the mentioned URL implies this is valid:
> This is sometimes used for plugins which have a dependency upon the package
> being merged.

This is why I think it needs clarification - setting USE=crypt globally does not imply you are a cryptography-conscious person who would want to use cryptography whenever possible, setting USE=crypt changes nothing in the package content generated by net-im/{gaim,pidgin} and instead simply emerges gaim-encryption after it. To me, setting a USE flag suggests that I thereby control the build of the package itself, not the (non-)emergence of an entirely different package.

I would say that if a dependent package requires certain changes in the package itself, then certainly using a USE flag for that is warranted. For a similar discussion, see bug #157879.

If you find that this should probably handled on gentoo-dev@ to get everyone else's opinion on this matter, then please make not of that and I will post some kind of proposal to that list.

Also note that for pidgin, the line with the PDEPEND is currently commented out, so for now (probably as long as the plugin has not been ported to pidgin) this bug is about gaim, not pidgin.
Comment 6 SpanKY gentoo-dev 2007-05-21 23:44:48 UTC
and ?  i dont see much of a problem forcing people to test a package and a set of plugins associated with it

you can also do per-package use.masking if you arent willing to test all of the plugins

USE=crypt globally actually does imply you want support for encryption where ever possible

gaim/pidgin do reflect the current policy ... namly, pulling in plugins via USE-flags is OK ... if you want to change that, you can certainly post a thread on gentoo-dev, but the current state of things is OK by me

the plugin has been ported and in portage so the PDEPEND can be fixed in pidgin
Comment 7 Bugs Bunny 2007-05-24 23:19:52 UTC
(In reply to comment #3)
> It's not a bug as such, it's simply a misconception and an abuse of what USE
> and PDEPEND are intended for. If the only achievement of this superfluous
> construct is emerging a separate package, then enabling a USE flag for it is
> tantamount to emerging the package "manually". I.e. it gains the user/admin
> nothing and only serves to create false dependencies (which make arch devs
> cry).
> 
> CC'ing QA as this is probably something that needs to be clarified (better) at
> the URL I set.
> 

What you are doing is completely wrong. It is proper technic if it is not thunderbird/firefox and many other ebuilds are in violation of such use of PDEPEND which make the admins job much easier instead of harder.

Comment 8 SpanKY gentoo-dev 2007-05-25 04:22:05 UTC
i really have no idea what you're trying to say
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2007-10-04 20:14:58 UTC
There's no PDEPEND in net-im/pidgin any more; gaim is dead, closing this pointless bug.