Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 179218 - sys-devel/gcc-4.2.0 does not work on ppc64
Summary: sys-devel/gcc-4.2.0 does not work on ppc64
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: ppc64 architecture team
Depends on:
Reported: 2007-05-20 13:20 UTC by Markus Rothe (RETIRED)
Modified: 2007-10-25 14:48 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

log for glibc merge (incl. segfault) (bootstrap-resumed-gcc42.txt,4.00 KB, text/plain)
2007-05-20 13:24 UTC, Markus Rothe (RETIRED)

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Rothe (RETIRED) gentoo-dev 2007-05-20 13:20:01 UTC
I tried to use gcc 4.2.0 in a chroot. Although it doesn't work too good.

First I used an existing chroot and updated from 4.1.1-r3 to 4.2. After compiling this and that paludis (one of the compiled packages) didn't work anymore. It only produced segmentation faults from then on.

As I was not able to recompile paludis without a working paludis I started from scratch.

I unpacked a stage1, unmasked gcc 4.2.0 and ran Now I got a segfault while compiling glibc.

What's this bug about? Please don't add ~ppc64 to gcc 4.2.0 unless those problems are sorted out.
Comment 1 Markus Rothe (RETIRED) gentoo-dev 2007-05-20 13:24:55 UTC
Created attachment 119787 [details]
log for glibc merge (incl. segfault)
Comment 2 SpanKY gentoo-dev 2007-05-20 16:52:28 UTC
ive been using gcc-4.2.0 on my quad without troubles, but that only extends so far to ppc64 ... and we've shown in the past that ppc64 tends to be much more unstable than ppc in the toolchain ...
Comment 3 Markus Rothe (RETIRED) gentoo-dev 2007-05-20 19:02:33 UTC
ok. so let's find out the differences between your and mine config. could you please send me your 'emerge --info' output?
Comment 4 SpanKY gentoo-dev 2007-05-20 23:08:50 UTC
when i said "ppc" i meant "ppc" :)

i havent tried ppc64, just ppc32
Comment 5 Markus Rothe (RETIRED) gentoo-dev 2007-05-21 05:31:13 UTC
(In reply to comment #4)
> when i said "ppc" i meant "ppc" :)
> i havent tried ppc64, just ppc32

Sorry, I think I don't understand that "ive been using gcc-4.2.0 on my quad without troubles, but that only extends so far to ppc64" then :-/

/me catches a dictionary..
Comment 6 Brent Baude (RETIRED) gentoo-dev 2007-05-21 13:52:01 UTC
I think he means he's using a 32bit userland corsair...
Comment 7 Markus Rothe (RETIRED) gentoo-dev 2007-05-21 19:19:19 UTC
ahh.. stupid /me. I didn't thought about that possibility. thanks..
Comment 8 SpanKY gentoo-dev 2007-05-21 19:43:46 UTC
yeah, the ppc64 userland is just too unstable for me to use as a desktop, so i have a 64bit kernel with a 32bit userland ... i need KDE/firefox actually functioning :)

sorry about that
Comment 9 Brent Baude (RETIRED) gentoo-dev 2007-05-21 20:36:52 UTC
fwiw, firefox and thunderbird work quite nicely on ppc64 64ul now thanks to some patches from the moz Gentoo team.  Sorry to derail the point of this bug...
Comment 10 SpanKY gentoo-dev 2007-05-21 20:45:10 UTC
unless anyone has crazy ideas as to the source of the troubles, i think the way to tackle this would be to take a stage3/gcc-4.1.2 system and install gcc-4.2.0 in parallel ...

then locate the simplest C-only package you can find and get it to bomb only when compiled with gcc-4.2 ...
Comment 11 Bugs Bunny 2007-05-28 13:58:06 UTC
Check for out of memory issues, There is a major regression on 64bit systems as far as gcc is concerned. More detail can be found here :

It does include a patch but needs to be updated in two locations to fix the ice it introduces on fortran.
Comment 12 Tom Gall (RETIRED) gentoo-dev 2007-10-14 06:18:38 UTC
going to close this bug ...  gcc 4.2.2 seems to be dramatically improved ... still under test .. but it's not dead yet. 4.2.0 has no chance of going stable and we ain't fixing it.

Comment 13 Tom Gall (RETIRED) gentoo-dev 2007-10-18 07:27:35 UTC
as this bug was referenced by external parties I will document this here. fixes this issue for gcc 4.2.x
Comment 14 Markus Rothe (RETIRED) gentoo-dev 2007-10-25 14:48:07 UTC
added ~ppc64 to gcc-4.2.2