Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 178644 - kdelibs-3.5.6-r8 & qt problem
Summary: kdelibs-3.5.6-r8 & qt problem
Status: RESOLVED DUPLICATE of bug 128069
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL: http://http://www.flamma.dyns.cx/stuff/
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-05-15 14:20 UTC by Jesse Karhu
Modified: 2007-05-15 14:37 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Karhu 2007-05-15 14:20:40 UTC
Problem appeared when I was updating whole system with "emerge --update --deep world". When emerging kdelibs-3.5.6-r8 I get:

checking for Qt... configure: error: Qt (>= Qt 3.3 and < 4.0) (library qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!

Full config.log here: http://www.flamma.dyns.cx/stuff/config.log

That doesn't tell me very much. I can see lot of variables without value. Well I also saved build.log, it's here:

http://www.flamma.dyns.cx/stuff/build.log

x11-libs/qt-4.3.0_rc1 re-emerges fine but when I try to re-emerge x11-libs/qt-3.3.8-r2 I get error. Build log here:

http://www.flamma.dyns.cx/stuff/build2.log

Kde won't start anymore once I shut it down.

Reproducible: Always
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-05-15 14:37:22 UTC
> libexpat.so.0, needed by /usr/lib/libfontconfig.so.1, not found

You failed to run revdep-rebuild as told to when upgrading expat.

*** This bug has been marked as a duplicate of bug 128069 ***