Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 178425 - media-gfx/blender hangs display when trying to rotate with middle mouse button
Summary: media-gfx/blender hangs display when trying to rotate with middle mouse button
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-05-13 20:18 UTC by Wojciech Potentas
Modified: 2009-07-28 15:54 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wojciech Potentas 2007-05-13 20:18:09 UTC
My configuration is: Athlon 64 on NVIDIA NForce 3 Ultra, Radeon 9100.
xorg-x11-7.2, open source radeon drivers, AiGLX. Beryl is present but not enabled, window manager is KWin. But error also occurs in fluxbox.
 Error is that blender hangs display when trying to rotate blenders visual when dragging it with middle mouse button. It rotates about 90 degrees and hangs the display, so I can't change tty or workspace nor kill X-Server with CTRL-ALT-Backspace.
 

Reproducible: Always

Steps to Reproduce:
1.start xorg-x11
2.start blender
3.try to rotate it's visual by middle mouse button

Actual Results:  
 Display hangs.

Expected Results:  
 Normal behaviour of blender.

Portage 2.1.2.7 (default-linux/amd64/2006.1/desktop, gcc-4.1.1, glibc-2.5-r0, 2.6.20-gentoo-r4 x86_64)
=================================================================
System uname: 2.6.20-gentoo-r4 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System version 1.12.6
Timestamp of tree: Sat, 12 May 2007 19:30:01 +0000
dev-java/java-config: 1.3.7, 2.0.32
dev-lang/python:     2.4.4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.23b
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O3 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=athlon64 -O3 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LINGUAS="pl"
MAKEOPTS=""
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow2 X aac aiglx alsa amd64 apache2 apm arts avi bcmath berkdb bitmap-fonts boundschecking cairo calendar cdr cli cracklib crypt cups dbus dri dvd dvdr dvdread eds emboss encode esd fam firefox flac fortran gdbm gif glut gnome gpm gstreamer gtk gtk2 hal iconv ipv6 isdnlog jabber java java2 javascript jpeg jpeg2 kde ldap lesstiff libg++ mad midi mikmod mmx2 mono mp3 mp4 mpeg mpeg4 mplayer ncurses neXt new-login nls nptl nptlonly obdc ogg opengl oss pam pcre pdf perl php plotutils png ppds pppd python qt3 qt4 quicktime readline reflection sdl session spell spl ssl tcpd truetype truetype-fonts type1-fonts unicode videos vorbis wmf wxwindows xml xorg xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pl" USERLAND="GNU" VIDEO_CARDS="radeon"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Wojciech Potentas 2007-05-13 20:25:52 UTC
It also hangs when Beryl is enabled.
Comment 2 Wojciech Potentas 2007-05-29 16:44:50 UTC
 The same thing is going when I'm trying to rotate workspace with new Emerald-0.2.1 enabled (I upgraded it) - computer hangs. Flight Gear Flight Simulator sometimes hangs too - but it depends on chosen aircraft. Maybe this is the same bug. What's interesting there is no background on other workspaces with old Emerald, as same with new Emerald turned on, but this is I think - another issue. I do not exclude hardware problem, and I'll try to check it on another graphic card as possible.
Comment 3 Luca Barbato gentoo-dev 2007-08-21 21:23:15 UTC
looks like a 3d driver issue..
Comment 4 Rémi Cardona gentoo-dev 2009-07-28 15:54:24 UTC
2 years into this. If you can still reproduce, please reopen this bug with updated information so we can try to help you out.

Thanks