Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 178419 - gnome-base/libgtop-1.14.6 locks during GNOME 2 GConf schemas install
Summary: gnome-base/libgtop-1.14.6 locks during GNOME 2 GConf schemas install
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-05-13 19:47 UTC by Rumen Yotov
Modified: 2008-09-06 08:16 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rumen Yotov 2007-05-13 19:47:10 UTC
Hi,
Have the same problem with libgnome-2.16.0 and libgnomecanvas-2.14.0 too.
Seems some issues with gnome2-utils.eclass,looked at it by with no success so far.
Part of the log:
--- !empty dir /usr
 * Updating desktop mime database ...
 * Updating shared mime info database ...
***
* Updating MIME database in //usr/share/mime...
Wrote 504 strings at 20 - 29c4
Wrote aliases at 29c4 - 2bb8
Wrote parents at 2bb8 - 35c4
Wrote literal globs at 35c4 - 3620
Wrote suffix globs at 3620 - 6ae8
Wrote full globs at 6ae8 - 6b0c
Wrote magic at 6b0c - c434
Wrote namespace list at c434 - c444
***
 * Updating icons cache ...                                                                                                              [ ok ]
 * Updating scrollkeeper database ...
>>> Regenerating /etc/ld.so.cache...
>>> Original instance of package unmerged safely.
 * Installing GNOME 2 GConf schemas
...END...
Locks here (ps auxf can't exit here too)
Thanks. Rumen

Reproducible: Always




emerge --info goes next (too long to include here)
Comment 1 Rumen Yotov 2007-05-13 19:48:46 UTC
emerge --info:
Portage 2.1.2.7 (default-linux/x86/2007.0/desktop, gcc-4.1.1, glibc-2.5-r2, 2.6.21-gentoo i686)
=================================================================
System uname: 2.6.21-gentoo i686 Intel(R) Celeron(TM) CPU                1300MHz
Gentoo Base System release 1.12.9
Timestamp of tree: Sun, 13 May 2007 18:00:01 +0000
ccache version 2.4 [enabled]
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r7
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="x86"
ALSA_CARDS="intel8x0"
ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol"
ARCH="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CCACHE_DIR="/var/tmp/ccache"
CCACHE_SIZE="512M"
CFLAGS="-Os -march=i686 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CLEAN_DELAY="5"
COLORTERM="Terminal"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CVS_RSH="ssh"
CXXFLAGS="-Os -march=i686 -pipe -fomit-frame-pointer"
DBUS_SESSION_BUS_ADDRESS="unix:abstract=/tmp/dbus-0F357cn0uH,guid=880a8cd3e872da7276bd0c004643a363"
DISPLAY=":0.0"
DISTDIR="/usr/portage/distfiles"
EDITOR="/bin/nano"
ELIBC="glibc"
EMERGE_DEFAULT_OPTS="--verbose --with-bdeps y"
EMERGE_WARNING_DELAY="10"
FEATURES="ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict userpriv usersandbox"
FETCHCOMMAND="/usr/bin/wget -t 3 -T 60 --passive-ftp ${URI} -P ${DISTDIR}"
GCC_SPECS=""
GDK_USE_XFT="1"
GENTOO_MIRRORS="http://mirrors.ludost.net/gentoo http://mirrors.tux-bg.net/gentoo http://mirror.datapipe.net/gentoo http://distfiles.gentoo.org"
GPG_AGENT_INFO="/tmp/gpg-hApSG4/S.gpg-agent:7286:1"
G_BROKEN_FILENAMES="1"
G_FILENAME_ENCODING="UTF-8"
HOME="/root"
HUSHLOGIN="FALSE"
INFOPATH="/usr/share/info:/usr/share/binutils-data/i686-pc-linux-gnu/2.17/info:/usr/share/gcc-data/i686-pc-linux-gnu/4.1.1/info:/usr/share/gcc-data/i686-pc-linux-gnu/4.1.1/info:/usr/share/info/emacs-21"
INPUT_DEVICES="keyboard mouse"
KDEDIRS="/usr:/usr/local:/usr/kde/3.5"
KERNEL="linux"
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text"
LC_ALL="en_US.UTF-8"
LESS="-R -M --shift 5"
LESSOPEN="|lesspipe.sh %s"
LINGUAS="en_GB bg"
LOGNAME="root"
LS_COLORS="no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:su=37;41:sg=30;43:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.pdf=00;32:*.ps=00;32:*.txt=00;32:*.patch=00;32:*.diff=00;32:*.log=00;32:*.tex=00;32:*.doc=00;32:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:"
MAKEOPTS="-j1"
MANPATH="/usr/local/share/man:/usr/share/man:/usr/share/binutils-data/i686-pc-linux-gnu/2.17/man:/usr/share/gcc-data/i686-pc-linux-gnu/4.1.1/man:/usr/share/gcc-data/i686-pc-linux-gnu/4.1.1/man:/usr/kde/3.5/share/man:/usr/qt/3/doc/man"
NOCOLOR="true"
OPENGL_PROFILE="xorg-x11"
PAGER="/usr/bin/less"
PATH="/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin"
PKGDIR="/usr/portage/packages"
PKG_CONFIG_PATH="/usr/qt/3/lib/pkgconfig"
PORTAGE_ARCHLIST="ppc s390 amd64 x86 ppc64 x86-fbsd m68k arm sparc sh mips ia64 alpha ppc-macos hppa sparc-fbsd"
PORTAGE_BINHOST_CHUNKSIZE="3000"
PORTAGE_BIN_PATH="/usr/lib/portage/bin"
PORTAGE_CONFIGROOT="/"
PORTAGE_DEBUG="0"
PORTAGE_DEPCACHEDIR="/var/cache/edb/dep"
PORTAGE_ELOG_CLASSES="info warn error log"
PORTAGE_ELOG_MAILFROM="portage"
PORTAGE_ELOG_MAILSUBJECT="[portage] ebuild log for ${PACKAGE} on ${HOST}"
PORTAGE_ELOG_MAILURI="root"
PORTAGE_ELOG_SYSTEM="save"
PORTAGE_GID="250"
PORTAGE_INST_GID="0"
PORTAGE_INST_UID="0"
PORTAGE_NICENESS="3"
PORTAGE_PYM_PATH="/usr/lib/portage/pym"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_RSYNC_RETRIES="3"
PORTAGE_TMPDIR="/var/tmp"
PORTAGE_TMPFS="/dev/shm"
PORTAGE_WORKDIR_MODE="0700"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise /usr/local/portage"
PORT_LOGDIR="/var/log/portage"
PWD="/root"
PYTHONPATH="/usr/lib/portage/pym"
QMAKESPEC="linux-g++"
QTDIR="/usr/qt/3"
RESUMECOMMAND="/usr/bin/wget -c -t 3 -T 60 --passive-ftp ${URI} -P ${DISTDIR}"
ROOT="/"
ROOTPATH="/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/4.1.1:/usr/kde/3.5/sbin:/usr/kde/3.5/bin:/usr/qt/3/bin"
RPMDIR="/usr/portage/rpm"
RSYNC="rsync://mirrors.ludost.net/gentoo-portage"
SESSION_MANAGER="local/rumen:/tmp/.ICE-unix/3189"
SHELL="/bin/bash"
SHLVL="7"
SSH_AGENT_PID="7224"
SSH_AUTH_SOCK="/tmp/ssh-cIscVJ7223/agent.7223"
STAGE1_USE="nptl nptlonly unicode"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
TERM="xterm"
USE="X acl acpi alsa apache2 bash-completion berkdb bitmap-fonts bluetooth browserplugin bzip2 cairo caps cdr cli cracklib crypt cups dbus dri dvd dvdr dvdread emboss esd ethereal evo fam fbcon firefox fortran gdbm gif gnutls gpm gstreamer gtk gtk2 hal iconv imap imlib isdnlog jpeg kdehiddenvisibility kdexdeltas kerberos ldap libg++ mad madwifi midi mikmod mmx mp3 ncurses nls nptl nptlonly ogg oggvorbis onoe opengl pam pcre pdf perl png ppds pppd python qt3 qt3support readline reflection samba sdl session skey spell spl sse ssl svg symlink tcpd truetype truetype-fonts type1-fonts unicode userlocales vhosts vorbis win32codecs x86 xml xorg xv zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB bg" USERLAND="GNU" VIDEO_CARDS="radeon vesa"
USER="root"
USERLAND="GNU"
USE_EXPAND="ALSA_CARDS ALSA_PCM_PLUGINS CAMERAS CROSSCOMPILE_OPTS DVB_CARDS ELIBC FCDSL_CARDS FOO2ZJS_DEVICES FRITZCAPI_CARDS INPUT_DEVICES KERNEL LCD_DEVICES LINGUAS LIRC_DEVICES MISDN_CARDS USERLAND VIDEO_CARDS"
USE_EXPAND_HIDDEN="CROSSCOMPILE_OPTS ELIBC KERNEL USERLAND"
USE_ORDER="env:pkg:conf:defaults:pkginternal"
VIDEO_CARDS="radeon vesa"
WINDOWID="20971572"
XARGS="xargs -r"
XAUTHORITY="/root/.xauth3mGOnK"
XDG_DATA_DIRS="/usr/share:/usr/kde/3.5/share:/usr/local/share:/usr/local/share:/usr/share"
_="/usr/bin/emerge"
Comment 2 Gilles Dartiguelongue gentoo-dev 2007-10-22 22:51:41 UTC
I've seen this once or twice maybe but I think it wasn't with libgtop but with gnome-games. Either way it's been really hard to reproduce so if you guys have a way to reproduce it 100%, that would help investigate the problem.
Comment 3 Gilles Dartiguelongue gentoo-dev 2008-09-06 08:16:57 UTC
guys, if you ever happen to see this again in a reproducible manner, please reopen this bug. Maybe this is a parallel build issue but I haven't seen it since last post.