Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 177622 - www-client/epiphany-2.18.1: Sandbox Access Violation
Summary: www-client/epiphany-2.18.1: Sandbox Access Violation
Status: RESOLVED DUPLICATE of bug 118699
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 192953 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-05-08 12:45 UTC by Samuli Suominen
Modified: 2007-09-18 18:04 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuli Suominen gentoo-dev 2007-05-08 12:45:53 UTC
Epiphany gets ACCESS VIOLATION from file /usr/share/xml2po/docbook.pyc,

www-client/epiphany-2.18.1  USE="python xulrunner -debug -doc -spell"
dev-lang/python-2.5.1  USE="berkdb gdbm ipv6 ncurses nptl readline ssl -bootstrap -build -doc -examples -nocxx -sqlite -tk -ucs2"

[..snip..]

Making all in help
make[2]: Entering directory `/var/tmp/portage/www-client/epiphany-2.18.1/work/epiphany-2.18.1/help'

[..snip..]

case "." in /*) sd=".";; *) sd="../.";; esac; \
        if [ -f "C/epiphany.xml" ]; then d="../"; else d="$sd/"; fi; \
        (cd el/ && \
          `which xml2po` -e -p \
            "${d}el/el.po" \
            "${d}C/epiphany.xml" > epiphany.xml.tmp && \
            cp epiphany.xml.tmp epiphany.xml && rm -f epiphany.xml.tmp)
ACCESS DENIED  unlink:    /usr/share/xml2po/docbook.pyc
ACCESS DENIED  unlink:    /usr/share/xml2po/docbook.pyc

[..snip..]

case "." in /*) sd=".";; *) sd="../.";; esac; \
        if [ -f "C/epiphany.xml" ]; then d="../"; else d="$sd/"; fi; \
        (cd es/ && \
          `which xml2po` -e -p \
            "${d}es/es.po" \
            "${d}C/epiphany.xml" > epiphany.xml.tmp && \
            cp epiphany.xml.tmp epiphany.xml && rm -f epiphany.xml.tmp)
ACCESS DENIED  unlink:    /usr/share/xml2po/docbook.pyc
ACCESS DENIED  unlink:    /usr/share/xml2po/docbook.pyc
if ! test -d eu/; then mkdir eu/; fi
if ! test -d fi/; then mkdir fi/; fi
case "." in /*) sd=".";; *) sd="../.";; esac; \
        if [ -f "C/epiphany.xml" ]; then d="../"; else d="$sd/"; fi; \
        (cd eu/ && \
          `which xml2po` -e -p \
            "${d}eu/eu.po" \
            "${d}C/epiphany.xml" > epiphany.xml.tmp && \
            cp epiphany.xml.tmp epiphany.xml && rm -f epiphany.xml.tmp)
case "." in /*) sd=".";; *) sd="../.";; esac; \
        if [ -f "C/epiphany.xml" ]; then d="../"; else d="$sd/"; fi; \
        (cd fi/ && \
          `which xml2po` -e -p \
            "${d}fi/fi.po" \
            "${d}C/epiphany.xml" > epiphany.xml.tmp && \
            cp epiphany.xml.tmp epiphany.xml && rm -f epiphany.xml.tmp)
ACCESS DENIED  unlink:    /usr/share/xml2po/docbook.pyc
ACCESS DENIED  unlink:    /usr/share/xml2po/docbook.pyc
xsltproc -o epiphany-C.omf --stringparam db2omf.basename epiphany --stringparam db2omf.format 'docbook' --stringparam db2omf.dtd "-//OASIS//DTD DocBook XML V4.1.2//EN" --stringparam db2omf.lang C --stringparam db2omf.omf_dir "/usr/share/omf" --stringparam db2omf.help_dir "/usr/share/gnome/help" --stringparam db2omf.omf_in "`pwd`/./epiphany.omf.in" `/usr/bin/pkg-config --variable db2omf gnome-doc-utils` C/epiphany.xml
xsltproc -o epiphany-bg.omf --stringparam db2omf.basename epiphany --stringparam db2omf.format 'docbook' --stringparam db2omf.dtd "-//OASIS//DTD DocBook XML V4.1.2//EN" --stringparam db2omf.lang bg --stringparam db2omf.omf_dir "/usr/share/omf" --stringparam db2omf.help_dir "/usr/share/gnome/help" --stringparam db2omf.omf_in "`pwd`/./epiphany.omf.in" `/usr/bin/pkg-config --variable db2omf gnome-doc-utils` bg/epiphany.xml
xsltproc -o epiphany-el.omf --stringparam db2omf.basename epiphany --stringparam db2omf.format 'docbook' --stringparam db2omf.dtd "-//OASIS//DTD DocBook XML V4.1.2//EN" --stringparam db2omf.lang el --stringparam db2omf.omf_dir "/usr/share/omf" --stringparam db2omf.help_dir "/usr/share/gnome/help" --stringparam db2omf.omf_in "`pwd`/./epiphany.omf.in" `/usr/bin/pkg-config --variable db2omf gnome-doc-utils` el/epiphany.xml

[..snip..]

es/epiphany.xml:333: parser error : Entity 'hellip' not defined
o, elija <menuchoice><guimenu>Archivo</guimenu><guimenuitem>Guardar como&hellip;
                                                                               ^
es/epiphany.xml:359: parser error : Entity 'hellip' not defined
�gina, elija <menuchoice><guimenu>Archivo</guimenu><guimenuitem>Imprimir&hellip;
                                                                               ^
es/epiphany.xml:367: parser error : Entity 'hellip' not defined
                                <para>Elija <menuchoice><guimenu>Editar</guimenu><guimenuitem>Buscar&hellip;
                                                                                                           ^
es/epiphany.xml:539: parser error : Entity 'hellip' not defined
a <menuchoice><guimenu>Marcadores</guimenu><guimenuitem>Añadir marcador&hellip;
                                                                               ^
es/epiphany.xml:542: parser error : Entity 'hellip' not defined
 contextual del enlace y elija <menuchoice><guimenuitem>Añadir marcador&hellip;
                                                                               ^
es/epiphany.xml:550: parser error : Entity 'hellip' not defined
lija <menuchoice><guimenu>Archivo</guimenu><guimenuitem>Añadir marcador&hellip;
                                                                               ^
es/epiphany.xml:550: parser error : Entity 'hellip' not defined
nuitem></menuchoice> Alternativamente, elija <guimenuitem>Añadir enlace&hellip;
                                                                               ^
es/epiphany.xml:661: parser error : Entity 'hellip' not defined
<para>Elija <menuchoice><guimenu>Archivo</guimenu><guimenuitem>Renombrar&hellip;
                                                                               ^
es/epiphany.xml:661: parser error : Entity 'hellip' not defined
uimenuitem></menuchoice>. Alternativamente, elija <guimenuitem>Renombrar&hellip;
                                                                               ^
es/epiphany.xml:892: parser error : Entity 'hellip' not defined
lija <menuchoice><guimenu>Archivo</guimenu><guimenuitem>Añadir marcador&hellip;
                                                                               ^
es/epiphany.xml:892: parser error : Entity 'hellip' not defined
tem></menuchoice>. Alternativamente, elija <guimenuitem>Añadir marcador&hellip;
                                                                               ^
es/epiphany.xml:1614: parser error : Entity 'ndash' not defined
                                  <keycap>&ndash;</keycap>

[..snip..]
                                                 ^
>>> Source compiled.
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-www-client_-_epiphany-2.18.1-16438.log"

unlink:    /usr/share/xml2po/docbook.pyc

[..snip..]
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-05-08 12:48:33 UTC

*** This bug has been marked as a duplicate of bug 118699 ***
Comment 2 Leonardo Boshell (RETIRED) gentoo-dev 2007-09-18 18:04:32 UTC
*** Bug 192953 has been marked as a duplicate of this bug. ***