Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 177292 - tvbrowser circular dependency; <dev-java/ant-1.7.0 (is blocking dev-java/ant-core-1.7.0)
Summary: tvbrowser circular dependency; <dev-java/ant-1.7.0 (is blocking dev-java/ant-...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Java (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Java team
Depends on:
Reported: 2007-05-06 09:40 UTC by Roman Gruber
Modified: 2007-05-06 10:32 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Roman Gruber 2007-05-06 09:40:10 UTC
I compile openoffice from source and therefore need dev-java/ant. I have had tvbrowser up and running for months. Now I have a circular dependency with dev-java/ant and ant-core.

Reproducible: Always

Steps to Reproduce:
1.emerge openoffice  => needs ant
2.emerge -av tvbrowser =>
get results: <dev-java/ant-1.7.0 (is blocking dev-java/ant-core-1.7.0)

Actual Results:  
notebook roman # emerge -av tvbrowser

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] dev-java/ant-core-1.7.0  USE="-doc -source" 0 kB 
[ebuild  N    ] media-tv/tvbrowser-2.5.2  USE="-doc -source -themes" 9,022 kB 
[blocks B     ] <dev-java/ant-1.7.0 (is blocking dev-java/ant-core-1.7.0)

Total: 2 packages (2 new, 1 block), Size of downloads: 9,022 kB

!!! Error: The above package list contains packages which cannot be installed
!!!        at the same time on the same system.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

notebook roman # 

Expected Results:  
emerge succeeded sucessfully for tvbrowser

I have tried to unmerge ant, ant-core, ... but I cant*t get over it. I used revdep-rebuild .....

I have first put it into the forms, Yes tw04l124, thats me!
I have waited for some time and synced today. Problems remains.
Comment 1 Roman Gruber 2007-05-06 09:41:39 UTC
notebook roman # emerge --info
Portage (default-linux/amd64/2007.0, gcc-4.1.1, glibc-2.5-r0, 2.6.20-gentoo-r7_34_Blue x86_64)
System uname: 2.6.20-gentoo-r7_34_Blue x86_64 AMD Turion(tm) 64 Mobile Technology MT-34
Gentoo Base System release 1.12.9
Timestamp of tree: Sun, 06 May 2007 08:00:11 +0000
dev-java/java-config: 1.3.7, 2.0.31-r5
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.15-r1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
CFLAGS="-march=athlon64 -O2 -msse3 -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=athlon64 -O2 -msse3 -pipe"
FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
LANG="en_GB en"
LINGUAS="en en_GB"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTDIR_OVERLAY="/usr/local/layman/xeffects /usr/local/layman/myownoverlay"
USE="3dnow 3dnowext 7zip X a52 aac ace acl acpi alsa amd amd64 amr apm arj audiofile avalon-logkit bash-completion bc bindist binfilter bitmap-fonts blender-game bzip2 cairo caps cddb cdparanoia cdr cdrom cpudetection cracklib crypt css cups curl dbus de_tvtoday dga dhcp dia directfb divx dmi dmx dnotify dri dts dvd dvdr dvdread eds emacs emerald enca encode esd evo exif expat fam fame fat fbcon ffmpeg firefox flac flood fortran fping ftp fuse gd ggi gif gimp glib glitz gmp gnome gnome-print gnutls gpm graphviz gs gstreamer gtk gtkhtml guile gzip h323 hal hdaps hddtemp html http ibam iconv id3 idea imagemagick imap imlib inkjar java jpeg jpeg2k lame lcd lcms ldap libcaca libg++ libgda libnotify libsamplerate libwww lite live log4j lzo macmenu mad matroska maya-shaderlibrary mbox md5sum metalink midi mikmod mime mjpeg mmx mmxext mng mod mods mono moznocompose moznoirc moznomail mp3 mp4 mp4live mpeg mpeg2 mplayer mule musepack musicbrainz nautilus ncurses neXt network new-login nls nntp no-htdocs no-old-linux nodrm nptl nptlonly nsplugin ntfs ogg openal opengl osc pam pango pcmcia pcre pdf perl physfs pmu png pop portaudio postscript ppds pppd prelude pwdb python qt3 qt3support qt4 quicktime rar readline realmedia recode roe rsvg sasl sdl sdl-image sdl-sound seamonkey servletapi session sndfile snmp sockets sox speex sse sse2 ssl stream subtitles svg tcl teamarena tga theora threads threadsafe threadsonly tiff tk transcode truetype-fonts type1-fonts unicode usb utempter v4l v4l2 vcd vorbis widescreen wifi wireshark wma wmf wmp wnck wordexp wxwindows x264 xanim xatrix xcomposite xext xine xinerama xml xorg xpm xrandr xv xvid xvmc xvnc yaepg yv12 zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="evdev mouse keyboard wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB" USERLAND="GNU" VIDEO_CARDS="fglrx v4l"

notebook roman # 
Comment 2 Petteri Räty (RETIRED) gentoo-dev 2007-05-06 09:42:31 UTC
Comment 3 Vlastimil Babka (Caster) (RETIRED) gentoo-dev 2007-05-06 09:49:45 UTC

you need to unmerge ant-tasks and ant for ant-core to update
you seem to be running stable, and ant 1.7.0 isn't stable on amd64 yet. Either you need to keyword ALL the ant packages in package.keywords or none. I'd suggest none , and wait for the stabilization. Neither openoffice nor tvbrowser requires 1.7.0 specifically.
Comment 4 Roman Gruber 2007-05-06 10:32:20 UTC
thank you very much, works now.

I don*T know why I put these packages in /etc/portage/package.keywords

thanks, roman gruber