Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 177102 - app-emulation/vice-1.21 missing USE flag for media-libs/resid
Summary: app-emulation/vice-1.21 missing USE flag for media-libs/resid
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Gentoo Games
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-05-04 23:19 UTC by groepaz
Modified: 2009-05-30 14:46 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description groepaz 2007-05-04 23:19:30 UTC
the new vice ebuild builds vice without support for the resid library (why?). the old libsidplay is very outdated and an insult to everyone who is into sidmusic (like me =)). *please* revert this change, or atleast introduce a "resid" use flag.

Reproducible: Always
Comment 1 Tristan Heaven (RETIRED) gentoo-dev 2007-05-10 14:40:56 UTC
amd64: Please keyword media-libs/resid or add resid to use.mask.

Thanks very muchly.
Comment 2 Christian Faulhammer (RETIRED) gentoo-dev 2007-05-20 07:36:40 UTC
added ~amd64 and closing
Comment 3 Tristan Heaven (RETIRED) gentoo-dev 2007-05-20 07:41:34 UTC
.
Comment 4 Tristan Heaven (RETIRED) gentoo-dev 2007-05-22 00:01:05 UTC
thanks
Comment 5 Samuli Suominen gentoo-dev 2009-05-30 11:00:39 UTC
Removed ~amd64 from old media-libs/resid because it was only building static archives. Added a new version, that also installs shared one.

0.16_p2 is the real version, i'll open a stable bug for it.
Comment 6 groepaz 2009-05-30 14:46:44 UTC
just fyi - vice doesnt depend on the external library, it contains its own local copy of resid (and residFP) which is statically compiled into the executables if vice is configured to use resid. the external library is only needed for 3rd party media players which have support for playing .sid files.

so, useflag for resid - yes. dependancy on media-libs/resid - no, pointless :)