Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 176837 - xf86-video-glint not loading using xorg
Summary: xf86-video-glint not loading using xorg
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal with 1 vote (vote)
Assignee: Gentoo X packagers
Depends on:
Reported: 2007-05-02 18:09 UTC by Aleksey Lazar
Modified: 2008-05-11 05:36 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

emerge info (emerge-info.txt,3.83 KB, text/plain)
2007-05-02 18:10 UTC, Aleksey Lazar
xorg.conf (xorg.conf,4.21 KB, text/plain)
2007-05-02 18:11 UTC, Aleksey Lazar
Xorg.0.log (Xorg.0.log,34.32 KB, text/plain)
2007-05-02 18:12 UTC, Aleksey Lazar
lspci (lspci.txt,1.83 KB, text/plain)
2007-05-02 18:14 UTC, Aleksey Lazar

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksey Lazar 2007-05-02 18:09:19 UTC
After upgrading to xorg-server- my 3DLabs Permedia II 2D+3D card using xf86-video-glint driver stopped loading. The error messages I get in xorg.log are:


(WW) GLINT: No matching Device section for instance (BusID PCI:5:14:0) found
(--) Chipset pm2v found


(EE) Screen 2 deleted because of no matching config section.

I tried this with an older kernel -- same problem.

Reproducible: Always
Comment 1 Aleksey Lazar 2007-05-02 18:10:29 UTC
Created attachment 117975 [details]
emerge info
Comment 2 Aleksey Lazar 2007-05-02 18:11:32 UTC
Created attachment 117977 [details]
Comment 3 Aleksey Lazar 2007-05-02 18:12:52 UTC
Created attachment 117979 [details]
Comment 4 Aleksey Lazar 2007-05-02 18:14:09 UTC
Created attachment 117981 [details]
Comment 5 Aleksey Lazar 2007-05-02 18:17:04 UTC
P.S. This exact configuration worked prior to this latest xorg server update. At the same time as the xorg update I also updated the kernel, so that's why I mention it above.
Comment 6 Alan Hourihane 2007-08-07 11:19:15 UTC
Can you try removing the RightOf / LeftOf from your screen section, and putting..

Option "LeftOf"


Option "RightOf"

in your Monitor sections instead ???
Comment 7 Aleksey Lazar 2007-08-07 15:13:14 UTC
I replaced this card with an nvidia. I might give it a try on a different box though.
Comment 8 Karl 2007-09-15 02:38:32 UTC
Had the same problem with and glint driver. Error shown was missing symbol RamDacCreateInfoRec. 
Found probably the same problem shown in this bug:
New xorg-server source doesn't have external ramdac symbols any more.
Their patch fixes that. It's here:
This worked. Glint driver now loads with xorg-server- 
Comment 9 Aleksey Lazar 2008-03-30 18:46:03 UTC
Is this patch now available in gentoo xorg ebuild?
Comment 10 Donnie Berkholz (RETIRED) gentoo-dev 2008-03-31 06:11:16 UTC
Please try glint 1.2, should be available in your next sync.
Comment 11 Donnie Berkholz (RETIRED) gentoo-dev 2008-05-09 08:37:50 UTC
Please reopen if it doesn't work, assuming fixed.
Comment 12 Aleksey Lazar 2008-05-11 05:36:52 UTC
I no longer require this driver, not can I test. If anyone else has a problem with it, please reopen. Thanks. Closing.