Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 176077 - net-www/netscape-flash, www-client/opera and youtube videos
Summary: net-www/netscape-flash, www-client/opera and youtube videos
Status: RESOLVED DUPLICATE of bug 127200
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Thomas Matthijs (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-26 08:03 UTC by Ivan Yarych
Modified: 2007-04-26 14:39 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Yarych 2007-04-26 08:03:53 UTC
It appears that video support for Opera 9.20 (I think all the 9.x versions too) doesn't work correctly with default gentoo's netscape-flash (versions 7.x and 9.x).
There is a simple solution for this problem which needs to modify netcape-flash ebuild (or opera ebuild?).
Here are some URLs on this problem:
http://my.opera.com/community/forums/topic.dml?id=186198
http://groups.google.com/group/opera.linux/browse_thread/thread/7480dd1e44e7cf05/07e17b2bb64b796d#07e17b2bb64b796d
In short, the soultion is to:
1. Make a symlink from /opt/opera/lib/opera/plugins/libflashplayer.so to /opt/netscape/plugins/libflashplayer.so
2. Show a notice after merging netscape-flash about need to edit ~/.opera/pluginpath.ini file and set /opt/netscape/plugins=2 . Opera should not be running when performing this.
After this changes Youtube videos work great (just as any (?) other Flash videos).
I think netscape-flash/opera maintainers will find the best way to acheive the desired effect.
Thanks.
Comment 1 Jeroen Roovers gentoo-dev 2007-04-26 14:39:55 UTC

*** This bug has been marked as a duplicate of bug 127200 ***