Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 176067 - x11-libs/vte-0.14.1 fails to build with grsec (libnvidia-tls.so.1: cannot make segment writable for relocation: Permission denied)
Summary: x11-libs/vte-0.14.1 fails to build with grsec (libnvidia-tls.so.1: cannot mak...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High trivial (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 176069 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-04-26 05:12 UTC by vyp08
Modified: 2007-05-03 23:21 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vyp08 2007-04-26 05:12:52 UTC
# ebuild /usr/local/src/portage/x11-libs/vte/vte-0.14.1.ebuild compile

[...]

checking for freetype-config... /usr/bin/freetype-config
checking for FreeType - version >= 6.1.0... no
*** The FreeType test program failed to run.  If your system uses
*** shared libraries and they are installed outside the normal
*** system library path, make sure the variable LD_LIBRARY_PATH                                           *** (or whatever is appropiate for your system) is correctly set.                                         configure: error: You must have freetype 2.0.2 or later to build vte.

"configure" compiled conftest.c succesfully, but can't run it.
With non-hardened kernel all ok.
For hardened kernel I make this patch :)

--- configure.orig      2006-10-03 00:48:02.000000000 +0400
+++ configure   2007-04-26 09:02:09.000000000 +0400
@@ -25008,7 +25008,7 @@
   (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
   { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
   (eval $ac_try) 2>&5
-  ac_status=$?
+  ac_status=0
   echo "$as_me:$LINENO: \$? = $ac_status" >&5
   (exit $ac_status); }; }; then
   :


Reproducible: Always

Steps to Reproduce:
Comment 1 Daniel Gryniewicz (RETIRED) gentoo-dev 2007-04-26 16:25:10 UTC
No good.  We can't ignore the running of the program.  Presumably freetype needs to be fixed on hardened.
Comment 2 solar (RETIRED) gentoo-dev 2007-04-26 16:37:41 UTC
(In reply to comment #1)
> No good.  We can't ignore the running of the program.  Presumably freetype
> needs to be fixed on hardened.

Whats wrong with freetype on hardened? We have been using it for years w/o problems. x11-libs/vte-0.14.1 also compiles for me just fine on hardened amd64 and x86.

http://tinderbox.dev.gentoo.org/html/hardened/x86/vte-0.14.1.html
http://tinderbox.dev.gentoo.org/html/hardened/amd64/multilib/vte-0.14.1.html

hardened / # /usr/bin/freetype-config --ftversion
2.1.10
hardened / # /usr/bin/freetype-config --libs     
-lfreetype -lz
hardened / # /usr/bin/freetype-config --libtool
/usr/lib/libfreetype.la
hardened / # qlist -SUv freetype
media-libs/freetype-2.1.10-r3 2 (bindist zlib)
Comment 3 Daniel Gryniewicz (RETIRED) gentoo-dev 2007-04-26 16:44:57 UTC
I don't know, I don't use hardened.  But he said it succeeded when booted into a non-hardened kernel, and the error said something about non-standard paths.  It's the freetype test that failed.
Comment 4 Kevin F. Quinn (RETIRED) gentoo-dev 2007-04-26 19:03:28 UTC
Post `emerge info`, and the (last part of the) output of dmesg with the hardened kernel immediately after the failure.
Comment 5 vyp08 2007-04-27 06:42:47 UTC
Problem is in nvidia-drivers:

# ebuild /usr/local/src/portage/x11-libs/vte/vte-0.14.1.ebuild compile
[...]
checking for FreeType - version >= 6.1.0... ./conftest: error while loading shared libraries: //usr//lib/opengl/nvidia/lib/libnvidia-tls.so.1: cannot make segment writable for relocation: Permission denied
no
*** The FreeType test program failed to run.  If your system uses
*** shared libraries and they are installed outside the normal
*** system library path, make sure the variable LD_LIBRARY_PATH
*** (or whatever is appropiate for your system) is correctly set.
configure: error: You must have freetype 2.0.2 or later to build vte

FreeType is good :)
Comment 6 solar (RETIRED) gentoo-dev 2007-04-27 16:05:06 UTC
upstream 3rd party binary only nvidia-foo is not supported with hardened and thus 
is and has been p.masked for sometime. Hopefully in the future the "nouveau" driver will suck less and that will be a viable options for hardened users.

gnome team. Suggestion: "Resolve this bug as UPSTREAM" or "CANTFIX"
Comment 7 Rémi Cardona gentoo-dev 2007-04-27 17:21:10 UTC
Vyp08, try using x11 opengl instead of nvidia just during the build. Maybe that'll help.
Comment 8 vyp08 2007-04-28 07:02:23 UTC
Thanks to All!
With x11 GLX dont play Q3 :((.
Comment 9 Daniel Gryniewicz (RETIRED) gentoo-dev 2007-04-30 03:01:46 UTC
You don't need to run with x11, just switch to it long enough to emerge vte, then switch back.  But, it's up to you.
Comment 10 vyp08 2007-05-02 09:35:04 UTC
Ok, thanks.
Comment 11 SpanKY gentoo-dev 2007-05-03 23:21:24 UTC
*** Bug 176069 has been marked as a duplicate of this bug. ***