Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 175546 - request for expat slots
Summary: request for expat slots
Status: RESOLVED DUPLICATE of bug 128069
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-22 10:44 UTC by Michael Siebert
Modified: 2007-04-22 12:04 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Siebert 2007-04-22 10:44:56 UTC
Hi! Binary packages like Acrobat Reader require "libexpat.so.0" (and all of my packages are compiled against it), while some other binary packages require "libexpat.so.1", like the binary version of Maxfighter ( http://bugs.gentoo.org/show_bug.cgi?id=147013 ) . "libexpat.so.0" is provided by "expat-1.95.8" while "libexpat.so.1" is provided by "expat-2.0.0'. I suggest to make two slots out of it, so that both versions can coexist.

Btw.: Is it possible to "relink" single binarys? I mean e.g. if I have a binary linked against libexpat.so.0 and I want it to be linked against libexpat.so.1 that program does it for me.

Reproducible: Always
Comment 1 Jakub Moc 2007-04-22 10:48:11 UTC
It's not slotable, period. See Bug 128069 and the zillions of duplicates there. (Plus acroread works just perfectly fine w/ expat-2 installed).

Comment 2 Samuli Suominen gentoo-dev 2007-04-22 12:04:49 UTC
Nooy.

*** This bug has been marked as a duplicate of bug 128069 ***