Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 175423 - openexr-1.4.0a fails to build
Summary: openexr-1.4.0a fails to build
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 181063
  Show dependency tree
 
Reported: 2007-04-21 08:57 UTC by Oikea Nimi
Modified: 2007-07-19 20:50 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (build.log,97.82 KB, text/plain)
2007-07-16 19:11 UTC, Raeez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oikea Nimi 2007-04-21 08:57:13 UTC
openexr-1.4.0a fails to build

Heres part of log

ImageViewFragShader.o:ImageViewFragShader.cpp:(.text+0xaff): more undefined references to `glProgramNamedParameter4fNV' follow
collect2: ld returned 1 exit status
make[1]: *** [exrdisplay] Error 1
make: *** [all-recursive] Error 1
!!! ERROR: media-libs/openexr-1.4.0a failed.
Call stack:
ebuild.sh, line 1614: Called dyn_compile
ebuild.sh, line 971: Called qa_call 'src_compile'
environment, line 3553: Called src_compile
openexr-1.4.0a.ebuild, line 48: Called die
!!! make failed
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/media-libs/openexr-1.4.0a/temp/build.log'.

So this causes Cinelerra won't compile because it depends on openexr...

Reproducible: Always

Steps to Reproduce:
1. Try to install Cinelerra or Openexr1.4
2.
3.

Actual Results:  
make fails see above...

Expected Results:  
to be installed =)

Well I used Kuroo to install and havent used Kuroo on command line so not sure is it relevant.
Comment 1 Oikea Nimi 2007-04-21 08:59:36 UTC
I have not used emerge I was meaning to say =)
Comment 2 Alexis Ballier gentoo-dev 2007-06-06 17:49:47 UTC
well.. here it builds fine

Could you please post :

emerge -pv openexr

emerge --info

and attach the full build log
Comment 3 Raeez 2007-07-10 17:49:08 UTC
I have been experiencing this bug, the only odd thing is that I had managed to emerge it fine the first time... Subsequent to this, I changed compilers from gcc 4.2.0 (boostrapped system with) to gcc 4.1.2 (did this because oo.org would not build) and this occurred in my first emerge -e world since changing over to gcc 4.2.0

Info:

emerge -pv openexr
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] media-libs/openexr-1.4.0a  USE="examples opengl -doc" VIDEO_CARDS="-nvidia" 0 kB 

Total: 1 package (1 reinstall), Size of downloads: 0 kB

emerge --info
Portage 2.1.3_rc6 (default-linux/amd64/2007.0, gcc-4.1.2, glibc-2.5-r4, 2.6.21-gentoo-r3 x86_64)
=================================================================
System uname: 2.6.21-gentoo-r3 x86_64 AMD Athlon(tm) 64 FX-60 Dual Core Processor
Gentoo Base System release 1.12.10
Timestamp of tree: Sun, 08 Jul 2007 17:00:01 +0000
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe -msse3"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-march=athlon64 -O2 -pipe -msse3"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans"
GENTOO_MIRRORS="ftp://darkstar.ist.utl.pt/pub/gentoo/"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/layman/xeffects /usr/local/layman/sunrise"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="#applications #base #communication #desktop-environment #development #multimedia (some 3dnow X a52 aac acl acpi aim alsa amarok amd64 amrr apm automount bash-completion berkdb bitmap-fonts bzip2 cairo cdinstall cdr cegui cg cli cracklib crypt cups dbus devil dri dts dvd dvdr dvdread examples ffmpeg fglrx firefox flac fortran freeimage gdbm gif glitz glut gnome gpm gstreamer gtk hal iconv icq ieee1394 ipod ipv6 isdnlog iso jabber java jpeg libg++ lua mad madwifi matroska midi mmx mozilla mp2 mp3 mp4 mpeg mpeg2 mplayer msn mudflap ncurses nls nptl nptlonly ogg ois openal openexr opengl openmp overlap) pam pcre pdf perl png pppd python quicktime rar readline reflection samba scanner sdl session spell spl sse sse2 ssl startup-notification svg tcpd theora threads tiff truetype truetype-fonts type1 type1-fonts udf unicode usb vob vorbis wifi wxwindows x264 xcomposite xinerama xml xorg xprint xscreensaver xv xvid zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="mouse keyboard evdev wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="ati fglrx"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


and finally, the full build log:

http://rafb.net/p/xlf07n55.html

I can't complete my emerge -e world because of this, and about half of my computer has been built with gcc 4.1.2 and the rest with gcc 4.2.0 because of this...

Comment 4 Alexis Ballier gentoo-dev 2007-07-10 18:40:23 UTC
hmmm what's the output of : 
strings /usr/lib64/libGL.so | grep glProgramNamedParameter4fNV

this file should contain the function... can you check your opengl settings are correct ? (perhaps doing a "eselect opengl set myopenglimplementation" would help)


and what's the output of "eselect opengl list" ? do you have nvidia-cg-toolkit installed ? could you please attach config.log ? (and afaik, pastebins delete messages after a while so that's probably better to attach it to this bug so that it won't be lost)
Comment 5 Raeez 2007-07-16 19:11:29 UTC
Created attachment 125078 [details]
build log
Comment 6 Raeez 2007-07-16 19:11:55 UTC
strings /usr/lib64/libGL.so | grep glProgramNamedParameter4fNV

returns nothing (Because I am on ati?)

I have already selected ati using eselect (I am using proprietary drivers) and just for good measure I redid it again with no success.

I do have nvidia-cg-toolkit installed


Comment 7 Alexis Ballier gentoo-dev 2007-07-19 20:50:59 UTC
thanks for all the info !
That's what I feared, there was an automagic on nvidia-cg-toolkit, it would try to build nvidia related hardware acceleration code if it was found, which is not wanted on non-nvidia systems. It should be fixed, reaching your rsync mirror in a few hours ;)