Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 17505 - emerge --searchdesc invokes other possibly dangerous emerge actions
Summary: emerge --searchdesc invokes other possibly dangerous emerge actions
Status: RESOLVED DUPLICATE of bug 2365
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Unclassified (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-03-14 08:34 UTC by Denny Rönngren
Modified: 2011-10-30 22:17 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denny Rönngren 2003-03-14 08:34:41 UTC
It seems to be issues with the --searchdesc option regarding searching for 
other regular expressions matching "action" keywords for emerge. For example 
emerge --searchdesc "sync" synchronises the portage tree, when the only 
expected behaviour is to search for "sync" in the portage tree. A safe way to 
reproduce the invalid behaviour without making alterations to portage or the 
rest of the system is emerge --searchdesc "info". 

Needless to say, this bug limits the use of --searchdesc, since it does not 
allow all searchterms to be used. Furthermore it may impose some sequrity 
problems since emerge does not behave as expected and may alter the 
configuration of a system.

Reproducible: Always
Steps to Reproduce:
1. emerge --searchdesc "depclean"
Actual Results:  
kafka root # emerge --searchdesc "depclean"

*** WARNING *** : DEPCLEAN CAN  SERIOUSLY  IMPAIR YOUR SYSTEM. USE CAUTION.
*** WARNING *** : (Cancel: CONTROL-C) -- ALWAYS VERIFY ALL PACKAGES IN THE
*** WARNING *** : CANDIDATE LIST FOR  SANITY  BEFORE  ALLOWING DEPCLEAN TO
*** WARNING *** : UNMERGE ANY PACKAGES.
*** WARNING *** :
*** WARNING *** : USE FLAGS MAY HAVE AN EXTREME EFFECT ON THE OUTPUT.
*** WARNING *** : SOME LIBRARIES MAY BE USED BY PACKAGES BUT ARE NOT
*** WARNING *** : CONSIDERED TO BE A DEPEND DUE TO USE FLAG SETTINGS.
*** WARNING *** :
*** WARNING *** : Packages  in the list  that are  desired  may be added
*** WARNING *** : directly to the world file to cause them to be ignored
*** WARNING *** : by declean and maintained in the future. BREAKAGES DUE
*** WARNING *** : TO UNMERGING AN  IN-USE  LIBRARIES  MAY BE REPAIRED BY
*** WARNING *** : MERGING  *** THE PACKAGE THAT COMPLAINS ***  ABOUT THE
*** WARNING *** : MISSING LIBRARY.

>>> Waiting 10 seconds before starting...
>>> (Control-C to abort)...
>>> Depclean in: 10 9 8 7 6 5 4 Killed


Expected Results:  
Search for a package witch contains depclean in its package name of package 
description.

kafka:~> emerge info
Portage 2.0.47-r8 (default-x86-1.4, gcc-3.2.2, glibc-2.3.1-r2)
=================================================================
System uname: 2.4.20-gentoo-r1 i686 Celeron (Mendocino)
GENTOO_MIRRORS="http://gentoo.oregonstate.edu/ 
http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
CONFIG_PROTECT="/etc /var/qmail/control /usr/share/config /usr/kde/2/share/conf
ig /usr/kde/3/share/config"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
PORTDIR="/usr/portage"
DISTDIR="/usr/portage/distfiles"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR_OVERLAY=""
USE="x86 oss 3dnow apm arts avi crypt cups encode gif gpm java jpeg kde gnome 
libg++ libwww mikmod mmx mpeg ncurses nls pdflib png qt quicktime sdl spell 
svga truetype xml2 xmms xv zlib gdbm berkdb slang readline mysql X tcpd pam 
ssl perl python esd imlib oggvorbis gtk motif opengl cdr"
COMPILER="gcc3"
CHOST="i686-pc-linux-gnu"
CFLAGS="-O2 -mcpu=i686 -pipe"
CXXFLAGS="-O2 -mcpu=i686 -pipe"
ACCEPT_KEYWORDS="x86"
MAKEOPTS="-j2"
AUTOCLEAN="yes"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
FEATURES="sandbox ccache"
Comment 1 Martin Holzer (RETIRED) gentoo-dev 2003-03-14 08:43:24 UTC

*** This bug has been marked as a duplicate of 2365 ***