Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 17426 - Compiling of pwlibs fails
Summary: Compiling of pwlibs fails
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Patrick Kursawe (RETIRED)
Depends on:
Reported: 2003-03-13 06:01 UTC by Tony Murray
Modified: 2005-01-24 10:46 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Tony Murray 2003-03-13 06:01:59 UTC
I have never emerged pwlib before, just to set things straight.

I cannot compile pwlib, I have tried with and without the ssl use flag.
I hava openssl 0.9.6i on both my laptop and desktop.
It compiled on my laptop, but not on my desktop.
The main differnece is desktop uses ~x86, the laptop is just x86.

Reproducible: Always
Steps to Reproduce:
1. emerge pwlib
Actual Results:  
Here is the error:

gcc -march=pentium3 -O3 -pipe -fomit-frame-pointer -DPTRACING=1 -Wall -DP_LINUX
-I/usr/include/include -I/usr/include/crypto -DP_EXPAT -DP_PTHREADS
-I/var/tmp/portage/pwlib-1.4.7/work/pwlib/include -c ../common/ -o
-DP_SSL -I/usr/include/include -I/usr/include/crypto -DP_EXPAT -DP_PTHREADS
-I/var/tmp/portage/pwlib-1.4.7/work/pwlib/include -DNDEBUG -march=pentium3 -O3
-pipe -fomit-frame-pointer -DPTRACING=1 -c ../../ptclib/pxml.cxx -o
In file included from ../../ptclib/pxml.cxx:64:
/usr/include/expat.h:657: use of enum `XML_Status' without previous declaration
/usr/include/expat.h:735: multiple definition of `enum XML_Status'
/usr/include/expat.h:657: previous definition here
make[2]: ***
[/var/tmp/portage/pwlib-1.4.7/work/pwlib/lib/obj_linux_x86_r/pxml.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/pwlib-1.4.7/work/pwlib/src/ptlib/unix'
make[1]: *** [opt] Error 2
make[1]: Leaving directory `/var/tmp/portage/pwlib-1.4.7/work/pwlib'
make: *** [optshared] Error 2

!!! ERROR: dev-libs/pwlib-1.4.7 failed.
!!! Function src_compile, Line 54, Exitcode 2
!!! (no error message)

Portage 2.0.47-r8 (default-x86-1.4, gcc-3.2.2, glibc-2.3.2-r0)
System uname: 2.4.20-gentoo-r1 i686 Celeron (Coppermine)
CONFIG_PROTECT="/etc /var/qmail/control /usr/kde/2/share/config
/usr/kde/3/share/config /usr/X11R6/lib/X11/xkb /usr/kde/3.1/share/config
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
USE="x86 oss apm avi crypt cups encode gif jpeg libg++ mikmod mmx mpeg ncurses
nls pdflib png quicktime spell truetype xml2 xv zlib gtkhtml gdbm berkdb slang
readline arts bonobo svga ggi tcltk java guile X sdl gpm tcpd pam libwww ssl
perl python imlib oggvorbis gnome gtk qt kde motif opengl mysql sse evo lcms dvd
xmms maildir mozilla samba alsa cdr fbcon directfb imap -3dnow aalib -gtk2 -xfs
-esd apache2"
CFLAGS="-march=pentium3 -O3 -pipe -fomit-frame-pointer"
CXXFLAGS="-march=pentium3 -O3 -pipe -fomit-frame-pointer"
FEATURES="sandbox ccache"
Comment 1 Patrick Kursawe (RETIRED) gentoo-dev 2003-03-14 09:34:12 UTC
Just tried compiling it on a glibc-2.3.1-r2 system and ran into a different error:
/var/tmp/portage/pwlib-1.4.7/work/pwlib/lib/obj_linux_x86_r/asner.o: file not re
cognized: File truncated
collect2: ld returned 1 exit status

With glibc-2.3.2 it compiled fine. Retrying pwlib .10 on both systems.
Stay tuned.
Comment 2 Patrick Kursawe (RETIRED) gentoo-dev 2003-03-14 09:51:51 UTC
Version 1.4.10 compiles on both systems. Could you please try?
Comment 3 Alexander Minges 2003-03-15 10:04:43 UTC
It seems as if this bug has something to do with expat 1.95.6.
I wasn't able to compile pwlib 1.4.7 and 1.4.10 until I downgraded from expat 1.95.6 to 1.95.5-r1. That fixed it for me. Perhaps you could give it a try?
Comment 4 Tony Murray 2003-03-15 23:51:46 UTC
Downgrading to expat-1.95.5-r1 solved it.
By the way it compiled on both glib-2.3.2 and glib-2.3.1-r1...
I guess it is an expat bug.
Comment 5 Patrick Kursawe (RETIRED) gentoo-dev 2003-03-17 03:03:05 UTC
Yes, it's an expat problem and I didn't have it because I used the stable version. 
Patch is on the way into portage. Please try 1.95.6-r1 as soon as available. 
Comment 6 Patrick Kursawe (RETIRED) gentoo-dev 2003-06-11 23:35:31 UTC
No complaints, closing this...
Comment 7 Patrick Kursawe (RETIRED) gentoo-dev 2003-06-11 23:47:42 UTC
reopening for fixing
Comment 8 Patrick Kursawe (RETIRED) gentoo-dev 2003-06-11 23:47:52 UTC
Comment 9 Tony Murray 2005-01-24 10:46:37 UTC
Closing old bugs.