Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 174019 - emerge evolution 2.8.2.1 fails with libdb-4.2* missing
Summary: emerge evolution 2.8.2.1 fails with libdb-4.2* missing
Status: VERIFIED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-10 10:52 UTC by vyzivus
Modified: 2007-04-11 11:34 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge log (build.log,967.17 KB, text/plain)
2007-04-10 10:54 UTC, vyzivus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vyzivus 2007-04-10 10:52:23 UTC
Evolution 2.8.2.1 failed to run when db-4.2 was removed from the system (it got removed by executing emerge -auvDNt world && emerge -a --depclean; evolution complained about missing libdb-4.2.so) and it failed to compile until I manually emerged sys-libs/db-4.2.52_p4-r2. Seems that the evolution ebuild is missing a dependency.

Reproducible: Always

Steps to Reproduce:
1. unmerge sys-libs/db-4.2*
2. emerge evolution-2.8.2.1


Actual Results:  
Compilation failed.

Expected Results:  
It should poll sys-libs/db-4.2 as compile-time dependency prior compilation.

 Build log:
...
/usr/lib/libgnomevfs-2.so /usr/lib/libdbus-glib-1.so -lnsl /usr/lib/libdbus-1.so -lssl -lcrypto /usr/lib/libavahi-glib.so /usr/lib/libavahi-common.so /usr/lib/libavahi-client.so -lresolv -lutil /usr/lib/libedataserver-1.2.so -lplc4 -lplds4 -lnspr4 -ldb /usr/lib/libxml2.so -lz /usr/lib/libgconf-2.so /usr/lib/libpopt.so /usr/lib/libbonobo-2.so /usr/lib/libbonobo-activation.so /usr/lib/libORBitCosNaming-2.so /usr/lib/libORBit-2.so /usr/lib/libgobject-2.0.so -lm /usr/lib/libgmodule-2.0.so -ldl /usr/lib/libgthread-2.0.so -lpthread -lrt /usr/lib/libglib-2.0.so -Wl,--rpath -Wl,/usr/lib/evolution/2.8
/usr/lib/gcc/i686-pc-linux-gnu/4.1.1/../../../../i686-pc-linux-gnu/bin/ld: warning: libdb-4.2.so, needed by /usr/lib/libedataserver-1.2.so, not found (try using -rpath or -rpath-link)
/usr/lib/libedataserver-1.2.so: undefined reference to `db_create_4002'
collect2: ld returned 1 exit status
make[3]: *** [test-calendar] Error 1
make[3]: *** Waiting for unfinished jobs....
i686-pc-linux-gnu-gcc -shared  .libs/e-filter-bar.o  -Wl,--rpath -Wl,/var/tmp/portage/mail-client/evolution-2.8.2.1/work/evolution-2.8.2.1/widgets/misc/.libs -Wl,--rpath -Wl,/usr/lib/evolution/2.8 ./.libs/libemiscwidgets.so 
...
Comment 1 vyzivus 2007-04-10 10:54:00 UTC
Created attachment 115889 [details]
emerge log
Comment 2 vyzivus 2007-04-10 10:54:43 UTC
# emerge --info
Portage 2.1.2.2 (default-linux/x86/2006.1, gcc-4.1.1, glibc-2.5-r0, 2.6.18-suspend2-r1 i686)
=================================================================
System uname: 2.6.18-suspend2-r1 i686 Intel(R) Pentium(R) 4 CPU 3.00GHz
Gentoo Base System release 1.12.9
Timestamp of tree: Tue, 10 Apr 2007 07:20:01 +0000
dev-java/java-config: 1.3.7, 2.0.31
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.inode.at http://gentoo.ynet.sk/pub/"
LC_ALL="en_US.UTF-8"
LINGUAS="en sk"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://gentoo.ynet.sk/gentoo-portage"
USE="X a52 aac acpi aiglx alsa amr anthy apm audiofile avahi avi bash-completion berkdb bitmap-fonts bluetooth branding bzip2 cairo cddb cdparanoia cdr cjk cli cracklib crypt cups curl dbus djvu dmi dri dts dvd dvdr dvdread encode evo exif ffmpeg firefox flac gdbm glitz glut gnome gpm gtk gtk2 guile hal hddtemp iconv icq idn imagemagick immqt-bc ipv6 isdnlog java jpeg kerberos krb4 lcms libcaca libg++ libnotify libwww logrotate lzo mad matroska midi mikmod mmx mng mp3 mp4 mpeg musepack musicbrainz ncurses network nls nptl nptlonly nsplugin nxclient offensive ogg oggvorbis opengl pam pcre pdf perl pmu png ppds pppd python readline reflection rtc samba session speex spell spl sse sse2 ssl svg tcpd theora tiff timidity totem truetype truetype-fonts type1-fonts unicode usb v4l v4l2 vim vorbis win32codecs x264 x86 xine xinerama xml xml2 xorg xpm xv xvid zeroconf zlib" ALSA_CARDS="via82xx usb-audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en sk" USERLAND="GNU" VIDEO_CARDS="fglrx radeon"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 3 Gilles Dartiguelongue gentoo-dev 2007-04-10 11:38:00 UTC
indeed, db is linked in evolution. But it not restricted to 4.2. Here it is linked to 4.5

Probably deserves a drop in DEPEND
Comment 4 Carsten Lohrke (RETIRED) gentoo-dev 2007-04-10 11:53:10 UTC
I assume you didn't run `revdep-rebuild`. Portage has no reverse dependency support, yet. If this isn't the case, feel free to reopen.
Comment 5 vyzivus 2007-04-10 13:44:24 UTC
revdep-rebuild simply reemerges broken packages. I tried to reemerge evolution multiple times and it failed every time, until I installed db-4.2. So I'm reopening the bug. I think that the dependency on db-4.2* should be added to evolution ebuild.
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2007-04-10 17:23:07 UTC
(In reply to comment #5)
> revdep-rebuild simply reemerges broken packages. I tried to reemerge evolution
> multiple times and it failed every time

You've misunderstood how revdep-rebuild works and what's the problem here. Reopen if you cannot compile this after you've completed revdep-rebuild.
Comment 7 Mart Raudsepp gentoo-dev 2007-04-11 10:14:50 UTC
It fails because libedataserver-1.2.so comes from evolution-data-server, not evolution. So just re-emerging evolution won't help anything if you don't use revdep-rebuild to find what has to be rebuilt out of all the dependencies as well (in this case it would have found evolution-data-server and not unlikely other things).

As shown in the error paste:

warning: libdb-4.2.so, needed by /usr/lib/libedataserver-1.2.so, not found (try
using -rpath or -rpath-link)
                       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

/usr/lib/libedataserver-1.2.so: undefined reference to `db_create_4002'


Closing the bug based on this investigation of the error message.
Vyzivus, thanks for the concern and effort though
Comment 8 vyzivus 2007-04-11 11:34:43 UTC
You're right, I forgot to recompile evolution-data-server. Or use revdep-rebuild :) Now the evolution builds cleanly against db-4.3*