Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 173803 - Building binutils might require texinfo and flex
Summary: Building binutils might require texinfo and flex
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: Prefix Support (show other bugs)
Hardware: x86 Other
: High normal (vote)
Assignee: Gentoo non-Linux Team
Depends on:
Reported: 2007-04-08 21:02 UTC by Rabbe Fogelholm
Modified: 2008-01-28 07:31 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Rabbe Fogelholm 2007-04-08 21:02:07 UTC
This comment refers to the February 4, 2007 version of the document referred by the URL.

The step

    emerge --oneshot --nodeps sys-devel/binutils

did not succeed right away for me. After doing

    emerge --oneshot --nodeps sys-apps/texinfo
    emerge --oneshot --nodeps sys-devel/flex

the emerge of 'binutils' succeeded.

Reproducible: Always
Comment 1 Rabbe Fogelholm 2007-04-09 19:32:45 UTC
I am following the "Gentoo Prefixed Portage Bootstrap Process for Solaris" paper a second time, after messing up on my first attempt.

This time I am building the Gentoo software as an unprivileged user. I can confirm that sys-devel/flex must be emerged before binutils this time as well.

As for texinfo there is no new information this time, since I have preinstalled Gnu texinfo from a binary package prior to the entire prefixed portage bootstrap exercise.
Comment 2 Fabian Groffen gentoo-dev 2007-04-20 16:22:37 UTC
I changed the bootstrap to install binutils-2.16.1 initially, because that one doesn't need texinfo.

I added flex to the instructions before binutils.

Comment 3 Rabbe Fogelholm 2007-06-10 11:17:38 UTC
I think maybe there can be robustness problems with specifying a particular version such as binutils-2.16.

I haven't made any in-depth investigation, but I would like to contribute this observation: Some weeks ago my "prefix portage" installation became broken; all of a sudden I could no longer emerge new versions of anything. It appeared to be a Python-related problem and I could not find an easy way to fix it. So I decided to run through the entire bootstrapping sequence again.

At step 1.8 (of the May 7, 2007 version of the guide) it says to emerge binutils-2.16*. This did not succeed, it terminated with a low-level error that I did not capture unfortunately. I then tried to just do 'emerge --oneshot --nodeps sys-devel/binutils', which successfully gave me a 2.17 version.

There is of course the risk that my system is somehow different from a clean Solaris10 system since I have already bootstrapped the "prefix gentoo" once. It would be good to try and repeat the bootstrap procedure on a clean system and see if the binutils-2.16 problem is really an issue. I don't have the resources to do that right now though.
Comment 4 Fabian Groffen gentoo-dev 2007-07-22 13:19:18 UTC
I'll rebootstrap on Solaris 10/x86 using the manual and see what happens.
Comment 5 Fabian Groffen gentoo-dev 2008-01-26 10:40:56 UTC
flex is emerged before binutils

texinfo is emerged between two binutils emerges.  Last time this worked for me.
Comment 6 Rabbe Fogelholm 2008-01-28 07:31:23 UTC
Good to hear. Myself I can't test, I don't have access to Solaris machines anymore.