Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 17328 - After building gentoo-sources-2.4.20 and booting it, I have smudged fonts
Summary: After building gentoo-sources-2.4.20 and booting it, I have smudged fonts
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: (DEPRECATED)
Depends on:
Reported: 2003-03-11 18:27 UTC by wiono
Modified: 2003-09-26 01:37 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description wiono 2003-03-11 18:27:41 UTC
I've build gentoo-sources-2.4.20 as soon as they appeared. I tried to get back and use gentoo-sources-2.4.19 but with the same result.
I use kernel-headers 2.4.19, my Grafic Card is ALSA GLADIAC MX based on Nvidia's GeForce 2 MX which is pluged into 4X AGP - chipset VIA KT133, processor AMD Athlon 850Mhz ...

Reproducible: Always
Steps to Reproduce:
emege gentoo-sources
1.use kernel configuration from above URL
2.make kernel and boot it

Actual Results:  
fonts are unreadable

Expected Results:  
fonts should be readable

my emerge info:
Portage 2.0.46-r12 (default-x86-1.4, gcc-3.2.2, glibc-2.3.2_pre1-r0)
System uname: 2.4.20-gentoo-r1 i686 AMD Athlon(tm) Processor
USE="x86 oss 3dnow apm avi crypt cups encode gif jpeg libg++ mikmod mmx mpeg ncurses nls pdflib png qtmt quicktime spell truetype xml2 xmms xv zlib gdbm berkdb slang readline arts tcltk java X sdl gpm tcpd pam libwww ssl python imlib oggvorbis gtk qt kde motif opengl aalib acpi alsa apache2 cdr dga esd flash gd -gnome innodb jikes maildir mozilla mysql nocardbus oav perl samba sasl slp -svga tetex tiff usb wmf xface zeo"
CFLAGS="-mcpu=athlon-tbird -O2 -pipe"
CXXFLAGS="-mcpu=athlon-tbird -O2 -pipe"
Comment 1 Martin Holzer (RETIRED) gentoo-dev 2003-03-11 18:33:12 UTC
did you recompile the nvidia kernel module and the nvidia glx ?
Comment 2 SpanKY gentoo-dev 2003-03-11 18:52:10 UTC
where are the fonts smudged ? in console ?
Comment 3 wiono 2003-03-12 10:47:06 UTC
Fonts are smudged in console. Besides I've recompiled nvidia-kernel and nvidia-glx
Comment 4 Jay Pfeifer (RETIRED) gentoo-dev 2003-03-12 13:56:20 UTC
suggest to enable VESA FB support in kernel and pass vga= to your kernel. 
so, in .config 
see this forum thread for suggested modes you can send to your monitor: 
Comment 5 Jay Pfeifer (RETIRED) gentoo-dev 2003-04-15 19:10:47 UTC
well, without more information, we cannot fix. please reopen if you have more info. 
Comment 6 Martin Holzer (RETIRED) gentoo-dev 2003-09-25 14:21:46 UTC
db fix
Comment 7 wiono 2003-09-26 01:37:23 UTC
I enabled VESA framebuffer, added "vga=791" and now problem is solved