Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 171648 - mail-client/evolution > 2.6.2. lacks of imap4rev1 functionality
Summary: mail-client/evolution > 2.6.2. lacks of imap4rev1 functionality
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-21 07:11 UTC by Maik-Oliver Rutz
Modified: 2007-03-21 11:05 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maik-Oliver Rutz 2007-03-21 07:11:26 UTC
mail-client/evolution > 2.6.2. lacks of imap4rev1 functionality 

Reproducible: Always

Steps to Reproduce:
1. emerge mail-client/evolution > 2.6.2
2. try to find imap4rev1 in the email account settings 
3.

Actual Results:  
imap4rev1 is not in the combobox

Expected Results:  
imap4rev1 should be in the combobox for full connectivity to imap4rev1 servers

mail-client/evolution-2.8.2.1  
USE="crypt dbus hal ipv6 ldap mono nntp pda spell ssl -bogofilter -debug -doc -kerberos -krb4 -profile"
Comment 1 Gilles Dartiguelongue gentoo-dev 2007-03-21 09:07:51 UTC
AFAIK, this is not a bug.

IMAP4rev1 is only a rewrite of the IMAP camel store but it was not finished and unlikely to be developped further on the short term so upstream decided to disable it by default.
Comment 2 Mart Raudsepp gentoo-dev 2007-03-21 10:48:51 UTC
IMAP protocol that IS in the combobox is fully capable of talking to imap4rev1 servers  and making use of features new there.

The imap4rev1 protocol backend that was in evolution was a rewrite to support the namespace feature of IMAP - however while it supported namespaces, it was extremely unstable, data hostile and was not ever supposed to be enabled as an available mail provider compiled in by default. Yet it was during the GNOME 2.14 cycle. This has been remedied in GNOME 2.16 and as the upgrade guide <http://www.gentoo.org/proj/en/desktop/gnome/howtos/gnome-2.16-upgrade.xml> to 2.16 states as well - simply use the IMAP provider of evolution.
Comment 3 Maik-Oliver Rutz 2007-03-21 11:05:47 UTC
thank you. then it's more like a feature...