Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 171277 - app-misc/screen vertical split patch
Summary: app-misc/screen vertical split patch
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement with 2 votes (vote)
Assignee: Sven Wegener
URL:
Whiteboard:
Keywords:
: 234687 255223 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-03-17 20:09 UTC by pavel sanda
Modified: 2014-10-30 01:18 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
screen-4.0.3.ebuild (screen-4.0.3.ebuild,4.51 KB, text/plain)
2009-12-23 08:37 UTC, gtlinuxman
Details
metadata.xml (metadata.xml,1.71 KB, text/plain)
2009-12-23 08:38 UTC, gtlinuxman
Details
wrp_vertical_split_0.3_4.0.2.patch (wrp_vertical_split_0.3_4.0.2.patch,38.59 KB, text/plain)
2009-12-23 08:39 UTC, gtlinuxman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pavel sanda 2007-03-17 20:09:03 UTC
Hello, 
would it be possible to make use flag for the app-misc/screen ebuild, which
would make vertical splitting of windows possible ?
The patch can be found here : http://fungi.yuggoth.org/vsp4s/
thanks

Reproducible: Always

Steps to Reproduce:
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-03-17 21:14:36 UTC
Feature requests belong upstream, not to Gentoo.
Comment 2 Sven Wegener gentoo-dev 2007-04-08 21:29:11 UTC
Upstream already has proper vertical split support in their CVS.
Comment 3 Sven Wegener gentoo-dev 2007-08-07 20:00:37 UTC
I commited a CVS snapshot ebuild. It's dated 20070403, but there are no changes since that time. It contains vertical split support among other goodies.
Comment 4 pavel sanda 2007-08-11 21:03:55 UTC
it works for me. thanks.
Comment 5 Sven Wegener gentoo-dev 2008-08-13 23:09:14 UTC
*** Bug 234687 has been marked as a duplicate of this bug. ***
Comment 6 Sven Wegener gentoo-dev 2009-01-17 10:12:01 UTC
*** Bug 255223 has been marked as a duplicate of this bug. ***
Comment 7 gtlinuxman 2009-12-23 08:37:18 UTC
Created attachment 213904 [details]
screen-4.0.3.ebuild

If somebody want it
Comment 8 gtlinuxman 2009-12-23 08:38:18 UTC
Created attachment 213905 [details]
metadata.xml
Comment 9 gtlinuxman 2009-12-23 08:39:23 UTC
Created attachment 213906 [details]
wrp_vertical_split_0.3_4.0.2.patch
Comment 10 pavel sanda 2009-12-28 19:41:24 UTC
this patch doesnt work here.

why can't we have working 20070403 ebuild in tree which have been the case no so long ago?
Comment 11 Kaleb Elwert (belak) 2010-02-01 23:53:59 UTC
Well, I've got this in my overlay (belak) but the use flag is called vs, not vsplit.
Comment 12 Pacho Ramos gentoo-dev 2012-12-15 13:25:22 UTC
Is this still needed now with latest screen in the tree?
Comment 13 pavel sanda 2012-12-15 13:59:03 UTC
Latest? :)
screen upstream didn't release anything last 4 years and there seems to be no indication of change. Other distros are running their own patchsets to overcome this.
Comment 14 pavel sanda 2014-06-09 06:28:10 UTC
should be fixed with 4.2.1 in the tree. for some reason not keyworded yet.
Comment 15 Jeroen Roovers gentoo-dev 2014-10-30 01:18:07 UTC
Fixed upstream since >4.2.