Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 171268 - error compiling subversion-1.4.3 (and -1.3.2-r3)
Summary: error compiling subversion-1.4.3 (and -1.3.2-r3)
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-17 16:56 UTC by Matthias F. Brandstetter
Modified: 2007-03-17 17:54 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge.txt,8.43 KB, text/plain)
2007-03-17 16:57 UTC, Matthias F. Brandstetter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias F. Brandstetter gentoo-dev 2007-03-17 16:56:15 UTC
Hi all,

when emerging subversion I get the following error during compilation:

...
cd subversion/libsvn_fs_fs && /bin/sh /var/tmp/portage/dev-util/subversion-1.4.3/work/subversion-1.4.3/libtool --tag=CC --silent --mode=link i686-pc-linux-gnu-gcc -L/var/tmp/portage/dev-util/subversion-1.4.3/image//usr/lib -O2 -march=pentium4 -pipe -fomit-frame-pointer -DLINUX=2 -D_REENTRANT -D_GNU_SOURCE   -pthread  -D_LARGEFILE64_SOURCE -DNE_LFS  -L/usr/lib  -rpath /usr/lib -o libsvn_fs_fs-1.la  dag.lo err.lo fs.lo fs_fs.lo id.lo key-gen.lo lock.lo revs-txns.lo tree.lo ../../subversion/libsvn_delta/libsvn_delta-1.la ../../subversion/libsvn_subr/libsvn_subr-1.la /usr/lib/libaprutil-0.la -lgdbm -lexpat /usr/lib/libapr-0.la -lrt -lm -lcrypt -lnsl  -lpthread -ldl -lz
cd subversion/libsvn_ra_svn && /bin/sh /var/tmp/portage/dev-util/subversion-1.4.3/work/subversion-1.4.3/libtool --tag=CC --silent --mode=link i686-pc-linux-gnu-gcc -L/var/tmp/portage/dev-util/subversion-1.4.3/image//usr/lib -O2 -march=pentium4 -pipe -fomit-frame-pointer -DLINUX=2 -D_REENTRANT -D_GNU_SOURCE   -pthread  -D_LARGEFILE64_SOURCE -DNE_LFS  -L/usr/lib  -rpath /usr/lib -o libsvn_ra_svn-1.la  client.lo cram.lo editor.lo editorp.lo marshal.lo version.lo ../../subversion/libsvn_delta/libsvn_delta-1.la ../../subversion/libsvn_subr/libsvn_subr-1.la /usr/lib/libaprutil-0.la -lgdbm -lexpat /usr/lib/libapr-0.la -lrt -lm -lcrypt -lnsl  -lpthread -ldl -lz
/usr/lib/libapr-0.so: undefined reference to `_cprintf'
/usr/lib/libapr-0.so: undefined reference to `_cscanf'
collect2: ld returned 1 exit status
make: *** [subversion/tests/libsvn_subr/target-test] Error 1
make: *** Waiting for unfinished jobs....

!!! ERROR: dev-util/subversion-1.4.3 failed.
Call stack:
  ebuild.sh, line 1614:   Called dyn_compile
  ebuild.sh, line 971:   Called qa_call 'src_compile'
  environment, line 5774:   Called src_compile
  subversion-1.4.3.ebuild, line 127:   Called die

!!! make of subversion failed
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/dev-util/subversion-1.4.3/temp/build.log'.

!!! When you file a bug report, please include the following information:
GENTOO_VM=  CLASSPATH="." JAVA_HOME="/opt/blackdown-jdk-1.4.2.02"
JAVACFLAGS="" COMPILER=""
Comment 1 Matthias F. Brandstetter gentoo-dev 2007-03-17 16:57:13 UTC
Created attachment 113583 [details]
emerge --info
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2007-03-17 17:03:32 UTC
Your APR is obviously broken; run emerge -av1 =dev-libs/apr{,-util}-{0,1}* and re-emerge it.

On a side note:

> sys-devel/libtool:   1.4.1-r10, 1.5.22

You definitely shouldn't have two libtool versions installed; emerge -C =libtool-1.4*; emerge -1 libtool

Your toolchain is outdated, upgrade your linux-headers, glibc and gcc to latest stable version before reporting compile issues.

http://www.gentoo.org/doc/en/gcc-upgrading.xml
Comment 3 Matthias F. Brandstetter gentoo-dev 2007-03-17 17:49:14 UTC
Hi, after

emerge -av1 =dev-libs/apr{,-util}-{0,1}*
emerge -C =libtool-1.4*

I still get the same error.
Is the upgrade to gcc-4 a must?
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-03-17 17:54:33 UTC
Yeah, upgrade your toolchain following the guide mentioned above; cannot reproduce this at all.