Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 171111 - xfce-base/xfdesktop-4.4.0-r3 ebuild missing a dependency (libwww)
Summary: xfce-base/xfdesktop-4.4.0-r3 ebuild missing a dependency (libwww)
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
: 220207 (view as bug list)
Depends on:
Reported: 2007-03-16 01:25 UTC by jorges
Modified: 2008-05-04 11:11 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description jorges 2007-03-16 01:25:07 UTC
For some reason libwww was removed from my system after a clean-up in world. That's how I realized xfdesktop depends on libwww. More specifically, compilation fails when it does not find

Reproducible: Always

Steps to Reproduce:
1.Remove libwww from th system
2.Emerge xfdesktop

Actual Results:  
Emerge fails, complaining that couldn't find /usr/lib64/
(Sorry, I didn't do a copy of the actual output)

Expected Results:  
Emerge process to finish ok
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-03-16 01:30:12 UTC
Well sorry, but I don't have libwww installed at all and xfdesktop compiles perfectly fine. 

# emerge -pv xfdesktop libwww

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] xfce-base/xfdesktop-4.4.0-r3  USE="dbus -debug -doc -minimal" LINGUAS="-ca cs -da -de -el -es -et -eu -fi -fr -he -hu -ja -ko -nl -pl -pt_BR -ro -ru -sk -sv -uk -vi -zh_CN -zh_TW" 0 kB 
[ebuild  N    ] net-libs/libwww-5.4.0-r7  USE="-mysql ssl" 1,118 kB 

Total: 2 packages (1 new, 1 reinstall), Size of downloads: 1,118 kB

Post the compile output and emerge --info here.
Comment 2 jorges 2007-03-16 02:00:04 UTC
(In reply to comment #1)
I realize now after I submitted this bug (and because you asked for the emerge --info output) that I didn't mention I used paludis to install this package. I don't know if this (i.e. using paludis) invalidates the bug report. If that's the case I apologize. I was able to reproduce the problem by removing libwww and trying again to install xfdesktop (to get the ouput requested). After the compile output I pasted what I thought would be relevant from paludis --info output.
Again, the complain comes from not finding, which equery reports as belonging to libwww.

Here's a (partial) output of the compile:
/usr/lib/ccache/bin/gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../common -I../src -I/usr/include/exo-0.3 -I/usr/include/gtk-2.0 -I/usr/include/xfce4 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/xfce4 -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/cairo -I/usr/include/atk-1.0 -DEXO_API_SUBJECT_TO_CHANGE -DLOCALEDIR=\"/usr/share/locale\" -DDATADIR=\"/usr/share\" -DBINDIR=\"/usr/bin\" -O2 -pipe -march=athlon64 -msse3 -MT backdrop_settings_la-behavior-settings.lo -MD -MP -MF .deps/backdrop_settings_la-behavior-settings.Tpo -c behavior-settings.c  -fPIC -DPIC -o .libs/backdrop_settings_la-behavior-settings.o
 /usr/lib/ccache/bin/gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../common -I../src -I/usr/include/exo-0.3 -I/usr/include/gtk-2.0 -I/usr/include/xfce4 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/xfce4 -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/cairo -I/usr/include/atk-1.0 -DEXO_API_SUBJECT_TO_CHANGE -DLOCALEDIR=\"/usr/share/locale\" -DDATADIR=\"/usr/share\" -DBINDIR=\"/usr/bin\" -O2 -pipe -march=athlon64 -msse3 -MT backdrop_settings_la-settings-common.lo -MD -MP -MF .deps/backdrop_settings_la-settings-common.Tpo -c settings-common.c  -fPIC -DPIC -o .libs/backdrop_settings_la-settings-common.o
 /usr/lib/ccache/bin/gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../common -I../src -I/usr/include/exo-0.3 -I/usr/include/gtk-2.0 -I/usr/include/xfce4 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/xfce4 -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/cairo -I/usr/include/atk-1.0 -DEXO_API_SUBJECT_TO_CHANGE -DLOCALEDIR=\"/usr/share/locale\" -DDATADIR=\"/usr/share\" -DBINDIR=\"/usr/bin\" -O2 -pipe -march=athlon64 -msse3 -MT backdrop_settings_la-settings-common.lo -MD -MP -MF .deps/backdrop_settings_la-settings-common.Tpo -c settings-common.c -o backdrop_settings_la-settings-common.o >/dev/null 2>&1
 /usr/lib/ccache/bin/gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../common -I../src -I/usr/include/exo-0.3 -I/usr/include/gtk-2.0 -I/usr/include/xfce4 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/xfce4 -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/cairo -I/usr/include/atk-1.0 -DEXO_API_SUBJECT_TO_CHANGE -DLOCALEDIR=\"/usr/share/locale\" -DDATADIR=\"/usr/share\" -DBINDIR=\"/usr/bin\" -O2 -pipe -march=athlon64 -msse3 -MT backdrop_settings_la-behavior-settings.lo -MD -MP -MF .deps/backdrop_settings_la-behavior-settings.Tpo -c behavior-settings.c -o backdrop_settings_la-behavior-settings.o >/dev/null 2>&1
LC_ALL=C ../intltool-merge -d -u -c ../po/.intltool-merge-cache ../po xfce-backdrop-settings.desktop
/bin/sh ../libtool --mode=link --tag=CC /usr/lib/ccache/bin/gcc  -O2 -pipe -march=athlon64 -msse3   -o -rpath /usr/lib64/xfce4/mcs-plugins -avoid-version -module  backdrop_settings_la-appearance-settings.lo backdrop_settings_la-backdrop-list-manager.lo backdrop_settings_la-settings-common.lo backdrop_settings_la-behavior-settings.lo ../common/ -lexo-0.3 -lgtk-x11-2.0 -lxfce4util -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0    
Found cached translation database
Merging translations into xfce-backdrop-settings.desktop.
grep: /usr/lib64/ No such file or directory
/bin/sed: can't read /usr/lib64/ No such file or directory
libtool: link: `/usr/lib64/' is not a valid libtool archive
make[2]: *** [] Error 1
make[2]: Leaving directory `/var/tmp/paludis/xfce-base/xfdesktop-4.4.0-r3/work/xfdesktop-4.4.0/settings'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/paludis/xfce-base/xfdesktop-4.4.0-r3/work/xfdesktop-4.4.0'
make: *** [all] Error 2

!!! ERROR in xfce-base/xfdesktop-4.4.0-r3:
!!! In xfce44_src_compile at line 132
!!! (no message provided)

!!! Call stack:
!!!    * xfce44_src_compile (/usr/portage/eclass/xfce44.eclass:132)
!!!    * src_compile (/usr/libexec/paludis/eclass_functions.bash:35)
!!!    * ebuild_f_compile (/usr/libexec/paludis/src_compile.bash:49)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:346)

And here part of paludis --info output
    Package information:
        app-admin/eselect-compiler: (none)
        dev-java/java-config:  1.3.7, 2.0.31
        dev-lang/python:       2.4.3-r4
        dev-python/pycrypto:   2.0.1-r5
        dev-util/ccache:       2.4-r6
        dev-util/confcache:    (none)
        sys-apps/sandbox:      1.2.17
        sys-devel/autoconf:    2.13, 2.61
        sys-devel/automake:    1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
        sys-devel/binutils:    2.16.1-r3
        sys-devel/gcc-config:  1.3.14
        sys-devel/libtool:     1.5.22
        virtual/os-headers:    2.6.17-r2

    Variable information:
        CBUILD:                x86_64-pc-linux-gnu
        CFLAGS:                -O2 -pipe -march=athlon64 -msse3
        CHOST:                 x86_64-pc-linux-gnu
        CXXFLAGS:              -O2 -pipe -march=athlon64 -msse3
        DISTDIR:               /usr/portage/distfiles
        MAKEOPTS:              -j2
        PORTAGE_TMPDIR:        /var/tmp/paludis
        PORTDIR:               /usr/portage

Comment 3 Jakub Moc (RETIRED) gentoo-dev 2007-03-16 02:57:32 UTC
Erm, you have some stray .la cruft referencing this; run revdep-rebuild (and grep for this in /usr/lib64 if it still doesn't work). There's no reference to libwww anywhere in xfdesktop.
Comment 4 jorges 2007-03-16 09:03:18 UTC
(In reply to comment #3)
> Erm, you have some stray .la cruft referencing this; run revdep-rebuild (and
> grep for this in /usr/lib64 if it still doesn't work). There's no reference to
> libwww anywhere in xfdesktop.

I apologize once again, revdep-rebuild solved the dependency on as you suggested.
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2007-03-16 09:09:00 UTC
Cool; if you find out what was the real problem (i.e. what wanted to link against libwww) then file a new bug please.
Comment 6 Samuli Suominen (RETIRED) gentoo-dev 2008-05-04 10:06:00 UTC
*** Bug 220207 has been marked as a duplicate of this bug. ***
Comment 7 Samuli Suominen (RETIRED) gentoo-dev 2008-05-04 10:08:39 UTC
I'd like to advice anyone hitting this problem reading:

And thus start using LDFLAGS="-Wl,--as-needed" in make.conf which would have prevented the issue.
Comment 8 Philippe Coulonges 2008-05-04 11:00:07 UTC
(In reply to comment #6)
> *** Bug 220207 has been marked as a duplicate of this bug. ***

I filled the bug, sorry I hadn't seen the original has I searched.

I would like to understand what happens. So here is a copy of my info. I don't see anathyng that could explain why libwww is needed.

I have revdep-rebuilded and nothing's wrong for that part, too. libwww was present before (I think that's why I had no problem), but was removed recently by a depclean.

Any hint appreciated

Portage (default-linux/x86/2006.1, gcc-4.1.2, glibc-2.6.1-r0, 2.6.18-gentoo-r6 i686)
System uname: 2.6.18-gentoo-r6 i686 Celeron (Mendocino)
Timestamp of tree: Fri, 02 May 2008 12:19:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.4
dev-lang/python:     2.4.4-r9
dev-python/pycrypto: 2.0.1-r6
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
CFLAGS="-march=pentium2 -O3 -pipe"
CONFIG_PROTECT="/etc /etc/cups/printers.conf /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config /var/games/xgalaga /var/lib/games/gnomine.Custom.scores /var/lib/games/gnomine.Large.scores /var/lib/games/gnomine.Medium.scores /var/lib/games/gnomine.Small.scores /var/lib/games/same-gnome.scores /var/spool/uptimed/bootid /var/spool/uptimed/records"
CONFIG_PROTECT_MASK="/etc/X11/app-defaults /etc/X11/de/app-defaults /etc/X11/de_DE.UTF-8/app-defaults /etc/X11/fr/app-defaults /etc/X11/gdm/Init /etc/X11/gdm/PostSession /etc/X11/gdm/PreSession /etc/X11/it/app-defaults /etc/X11/starthere /etc/X11/xdm /etc/bash_completion.d /etc/env.d /etc/env.d/java/ /etc/fonts /etc/fonts/fonts.conf /etc/foomatic /etc/gconf /etc/gnome-vfs-2.0 /etc/gpm /etc/gtk-2.0 /etc/hotplug /etc/init.d /etc/init_d.old /etc/openldap /etc/pam.d /etc/postfix/sample /etc/rc.d/init.d /etc/revdep-rebuild /etc/sound/events /etc/ssmtp /etc/terminfo /etc/udev /etc/udev/rules.d /etc/vim /usr/X11R6/lib/X11/xkb/geometry /usr/X11R6/lib/X11/xkb/symbols/pc /usr/X11R6/lib/X11/xkb/types /usr/kde/3.5/share/config /usr/share/X11 /usr/share/texmf"
CXXFLAGS="-march=pentium2 -O3 -pipe"
FEATURES="distcc distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
LINGUAS="fr fr_FR"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X aalib acpi alsa apm arts bash-completion berkdb cddb cdparanoia cli cracklib crypt cups dbus depth32 devfs26 device-mapper divx dri dv dvb dvbplayer dvd dvdread encode f77 fbcon fortran fr gaim gdbm gif gimp gimpprint gkrellm glib gnome gpm gtk gtk2 hal iconv imagemagick imap ipv6 isdnlog java jpeg jpeg2k kde kerberos lm_sensors logrotate logwatch mailbox maildir mbox midi mikmod mime mmap mmx mozcalendar mozdom mozilla moznoirc moznomail mozsvg mp3 mp4 mp4live mpeg mpeg2 mplayer msn mudflap nas ncurses net network networking new-login nls no-old-linux no-seamonkey nodrm nptl nptlonly nsplugin offensive ogg oggvorbis opengl openmp pam pcmcia pcre pdf perl png postfix povray ppds pppd ps python qt3support qt4 quicktime readline realmedia reflection rtc ruby sasl sdl session sox spl ssl svg svga tcl tcltk tcpd tga threads tiff tk truetype unicode v4l v4l2 vim-syntax vim-with-x vorbis wifi win32codecs x86 xface xinerama xml xorg xscreensaver zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr fr_FR" USERLAND="GNU" VIDEO_CARDS="neomagic vga none vmware"

Comment 9 Philippe Coulonges 2008-05-04 11:01:19 UTC
(In reply to comment #7)
> I'd like to advice anyone hitting this problem reading:
> And thus start using LDFLAGS="-Wl,--as-needed" in make.conf which would have
> prevented the issue.


Warning: At the time of writing, there are many packages failing in funny ways because of --as-needed as they weren't designed to be used with it. While there shouldn't be (note the conditional) problems such as crashes, this flag is not considered safe for production use and not supported in any way by Gentoo.

Will I avoid one problem to get tens of ?
Comment 10 Philippe Coulonges 2008-05-04 11:11:43 UTC
> Will I avoid one problem to get tens of ?

Well, I finally tried and it doesn't work. Still complaining about

Here is the output

mv -f .deps/backdrop_settings_la-behavior-settings.Tpo .deps/backdrop_settings_la-behavior-settings.Plo
/bin/sh ../libtool --tag=CC   --mode=link i686-pc-linux-gnu-gcc -I.. -I../common -I../src -I/usr/include/exo-0.3 -I/usr/include/gtk-2.0 -I/usr/include/xfce4 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/libpng12   -I/usr/include/xfce4 -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/cairo -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/atk-1.0   -DEXO_API_SUBJECT_TO_CHANGE -DLOCALEDIR=\"/usr/share/locale\" -DDATADIR=\"/usr/share\" -DBINDIR=\"/usr/bin\" -march=pentium2 -O3 -pipe -avoid-version -module  -Wl,--as-needed -o -rpath /usr/lib/xfce4/mcs-plugins backdrop_settings_la-appearance-settings.lo backdrop_settings_la-backdrop-list-manager.lo backdrop_settings_la-settings-common.lo backdrop_settings_la-behavior-settings.lo ../common/ -lexo-0.3 -lgtk-x11-2.0 -lxfce4util -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0    
grep: /usr/lib/ No such file or directory
/bin/sed: can't read /usr/lib/ No such file or directory
libtool: link: `/usr/lib/' is not a valid libtool archive
make[2]: *** [] Erreur 1
make[2]: quittant le répertoire « /home/public/tmp/portage/xfce-base/xfdesktop-4.4.2-r2/work/xfdesktop-4.4.2/settings »
make[1]: *** [all-recursive] Erreur 1
make[1]: quittant le répertoire « /home/public/tmp/portage/xfce-base/xfdesktop-4.4.2-r2/work/xfdesktop-4.4.2 »
make: *** [all] Erreur 2