Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 170876 - x11-libs/wxGTK--2.6.3.3 - gtk_container_remove assert fail when deleting page from wxNotebook
Summary: x11-libs/wxGTK--2.6.3.3 - gtk_container_remove assert fail when deleting page...
Status: RESOLVED DUPLICATE of bug 151528
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo wxWidgets Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-14 14:00 UTC by Frank Szczerba
Modified: 2007-04-05 10:05 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Backport fix from wxWidgets-2.8.0 (wxGTK-2.6.3.3-notebook.patch,716 bytes, patch)
2007-03-14 14:01 UTC, Frank Szczerba
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Szczerba 2007-03-14 14:00:31 UTC
Every page removed from a wxNotebook causes the following assertion:

Gtk-CRITICAL **: gtk_container_remove: assertion `GTK_IS_TOOLBAR (container) || widget->parent == GTK_WIDGET (container)' failed


Reproducible: Always

Steps to Reproduce:
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-03-14 14:01:51 UTC
What's wxNotebook? We don't support this stuff that's not in the tree at all.
Comment 2 Frank Szczerba 2007-03-14 14:01:51 UTC
Created attachment 113256 [details, diff]
Backport fix from wxWidgets-2.8.0
Comment 3 Frank Szczerba 2007-03-14 14:03:05 UTC
Did you read the summary? It's a component of wxGTK-2.6.3.3 that is in the tree.

The fix is attached.
Comment 4 Mart Raudsepp gentoo-dev 2007-04-05 09:59:26 UTC
This fix is in the upcoming 2.6.4.0 bump, which I unfortunately can't get in before next week, as I'll be offline shortly until evening of Sunday, 8th April.
Comment 5 Mart Raudsepp gentoo-dev 2007-04-05 10:05:01 UTC
Marking as duplicate against the bug that covers a crash case in amule, that's caused from the lack of this very same patch.

*** This bug has been marked as a duplicate of bug 151528 ***