Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 170704 - app-shells/tcsh causes dev-util/kdevelop-3.4.1 to fail: unable to find plugins, run kbuildsycoca
Summary: app-shells/tcsh causes dev-util/kdevelop-3.4.1 to fail: unable to find plugin...
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Fabian Groffen
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-13 09:08 UTC by Jon Sporring
Modified: 2007-09-23 21:10 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jon Sporring 2007-03-13 09:08:55 UTC
I'm using an up-to-date Gentoo stable system with KDE, and I can only with difficulty use Kdevelop, since there seems to be a problem with mime types.  I get the following error:

Unable to find plugins, KDevelop will not work properly!
Please make sure that KDevelop is installed in your KDE directory, otherwise you have to add KDevelop's installation path to the environment variable KDEDIRS and run kbuildsycoca. Restart KDevelop afterwards.
Example for BASH users:
export KDEDIRS=/path/to/kdevelop:$KDEDIRS && kbuildsycoca

I have tried many things, the above as a starter, although I think that my KDEDIRS is set properly:

% echo $KDEDIRS
/usr/kde/3.5:/usr:/usr/local

I've also removed as many of the kde caches and tmps, I could find, and rebuild as many KDE related packages I could find.  Rebuild and cache/tmp removals had no effect.  The only effective action has everytime been kbuildsycoca, and the result has always been, that kbuildsycoca completes after an error

  ERROR: No database available! 

followed by a huge number of warnings of undefined mimetype/servicetype.  Nevertheless, then I'm able to start KDevelop.  However, after a reboot I have to repeat kbuildsycoca.  After having done this a number of times, something finally broke, and I had to reconfigure KDE on my account. 

I've search KDE and Gentoo bugs and forums, and it seems to be a Gentoo related error, but I've not been able to come any closer to a solution.  Any help would be much appreciated.

Reproducible: Always

Steps to Reproduce:
1. kdevelop myproject.kdevelop
2. kbuildsycoca
3. reboot
Comment 1 Wulf Krueger (RETIRED) gentoo-dev 2007-06-16 23:52:10 UTC
Please add your "emerge --info". I can't reproduce this.
Comment 2 Jon Sporring 2007-06-18 10:13:46 UTC
I'm still having this error.  Here follows my emerge --info.  Thanks for taking your time.

-----------------

Portage 2.1.2.7 (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.5-r3, 2.6.19-gentoo-r5 i686)
=================================================================
System uname: 2.6.19-gentoo-r5 i686 Intel(R) Pentium(R) M processor 1.80GHz
Gentoo Base System release 1.12.9
Timestamp of tree: Sat, 16 Jun 2007 23:30:02 +0000
ccache version 2.4 [enabled]
dev-java/java-config: 1.3.7, 2.0.32
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r7
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-mtune=pentium-m -march=pentium-m -O2 -pipe -ftracer -fweb -fomit-frame-pointer -funit-at-a-time"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-mtune=pentium-m -march=pentium-m -O2 -pipe -ftracer -fweb -fomit-frame-pointer -funit-at-a-time"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="ftp://ftp.gentoo.diku.dk/"
LANG="en_US.UTF-8"
LINGUAS="en_US da"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.diku.dk/gentoo-portage/"
USE="X Xaw3d acl acpi alsa apache2 arts berkdb bitmap-fonts bzlib cairo cdr cli cracklib crypt cups dbus dga divx4linux doc dri dvd dvdr dvdread eds emacs emboss encode esd evo fam fftw firefox fortran gdbm gif gimpprint gpm gstreamer gtk hal iconv imagemagick isdnlog jpeg kde kerberos ldap libg++ lzw-tiff mad maildir midi mikmod mmap mmx mng mozilla mp3 mpeg mudflap ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcre pda pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection sdl session spell spl sse sse2 ssl stl svg tcpd tetex tiff truetype truetype-fonts type1-fonts unicode vorbis win32codecs x86 xine xinerama xml xorg xv xvid zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US da" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 3 Lutz Schildt 2007-07-08 00:14:59 UTC
I had exactly the same problem, kbuildsycoca didnt help either. The faq over at kdevelop.org here
http://www.kdevelop.org/mediawiki/index.php/FAQ#I_get_an_error_message_.22couldn.27t_create_a_language_plugin.22._What_is_wrong.3F

says that kdevelop missed some dependecies. I tested that tip on my version, it had the same problem just that in my case it was libdb-4.2.so that was missing. emerge -1 kdevelop fixed it. Of course this doesnt resolve the bug (if it is one) in the first place but it fixes the installation.
Comment 4 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2007-07-08 03:46:43 UTC
I've just installed kdevelop to test this bug. It launches without errors here.
Try running "revdep-rebuild -X -p" on your system to check for broken libs.

user@host ~/ $ qlist -IUv kdevelop
dev-util/kdevelop-3.4.1 (fortran perl python)

user@host ~/ $ emerge --info
Portage 2.1.3_rc6 (default-linux/amd64/2007.0, gcc-4.1.2, glibc-2.5-r3, 2.6.21-gentoo-r2 x86_64)
=================================================================
System uname: 2.6.21-gentoo-r2 x86_64 AMD Athlon(tm) 64 Processor 3500+
Gentoo Base System release 1.12.10
Timestamp of tree: Mon, 02 Jul 2007 20:20:01 +0000
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=athlon64 -momit-leaf-frame-pointer -ftracer -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=athlon64 -momit-leaf-frame-pointer -ftracer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans"
GENTOO_MIRRORS="http://trumpetti.tut.atm.fi/gentoo http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ ftp://mirrors1.netvisao.pt/gentoo/"
LC_ALL="pt_PT.utf8"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/xeffects /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow X acpi alsa amd64 avi berkdb bitmap-fonts cdr cli cracklib crypt cups dbus dri dvd encode fortran gdbm gpm hal iconv ipv6 isdnlog jpeg kde libg++ midi mmx mpeg mudflap ncurses nls nptl nptlonly opengl openmp pam pcre perl png pppd python qt3 readline reflection samba session spl sse sse2 ssl tcpd truetype truetype-fonts type1-fonts unicode xorg zlib" ALSA_CARDS="usb-audio intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia vesa fbdev"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 5 Jon Sporring 2007-07-11 20:27:28 UTC
Hi,

I'm still having this error, and revdep-rebuild -X -p, did not find any broken packages.  Regarding the hint on the kdevelop.org site, I'm not sure that I understand it correctly, but the only libkdevcatalog.so I could find were:

(rose:~/3dotproject/linux_build) sporring% locate libkdevcatalog.so
/usr/lib/libkdevcatalog.so.0.0.0
/usr/lib/libkdevcatalog.so.0
/usr/lib/libkdevcatalog.so

and the last one appears to be in order:

(rose:~/3dotproject/linux_build) sporring% ldd /usr/lib/libkdevcatalog.so
        linux-gate.so.1 =>  (0xffffe000)
        libdb-4.3.so => /usr/lib/libdb-4.3.so (0xb7e06000)
        libkdecore.so.4 => /usr/kde/3.5/lib/libkdecore.so.4 (0xb7bb7000)
        libDCOP.so.4 => /usr/kde/3.5/lib/libDCOP.so.4 (0xb7b83000)
        libresolv.so.2 => /lib/libresolv.so.2 (0xb7b55000)
        libutil.so.1 => /lib/libutil.so.1 (0xb7b50000)
        libart_lgpl_2.so.2 => /usr/lib/libart_lgpl_2.so.2 (0xb7b39000)
        libidn.so.11 => /usr/lib/libidn.so.11 (0xb7b09000)
        libkdefx.so.4 => /usr/kde/3.5/lib/libkdefx.so.4 (0xb7adc000)
        libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xb7ad7000)
        libxml2.so.2 => /usr/lib/libxml2.so.2 (0xb79b4000)
        libqt-mt.so.3 => /usr/qt/3/lib/libqt-mt.so.3 (0xb72d4000)
        libmng.so.1 => /usr/lib/libmng.so.1 (0xb7272000)
        libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0xb7251000)
        libXi.so.6 => /usr/lib/libXi.so.6 (0xb7248000)
        libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb723f000)
        libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xb7238000)
        libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xb722e000)
        libXft.so.2 => /usr/lib/libXft.so.2 (0xb721b000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb719a000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb716e000)
        libpng12.so.0 => /usr/lib/libpng12.so.0 (0xb714a000)
        libz.so.1 => /lib/libz.so.1 (0xb7138000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0xb7128000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0xb7032000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0xb702f000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb702a000)
        libdl.so.2 => /lib/libdl.so.2 (0xb7026000)
        libSM.so.6 => /usr/lib/libSM.so.6 (0xb701d000)
        libICE.so.6 => /usr/lib/libICE.so.6 (0xb7005000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xb6fee000)
        libstdc++.so.6 => /usr/lib/gcc/i686-pc-linux-gnu/4.1.2/libstdc++.so.6 (0xb6f0a000)
        libm.so.6 => /lib/libm.so.6 (0xb6ee5000)
        libc.so.6 => /lib/libc.so.6 (0xb6dbd000)
        libgcc_s.so.1 => /usr/lib/gcc/i686-pc-linux-gnu/4.1.2/libgcc_s.so.1 (0xb6db2000)
        /lib/ld-linux.so.2 (0x80000000)

Sorry, I have not had a chance to perform a detail comparison of the posted emerge --info's, but it would appear that the Jorge's is using some unstable packages (libtool at least).  I don't have the time to check this before August, since vacation is approaching, and I will be away (from my computer, sigh).  Good summer.
Comment 6 Wulf Krueger (RETIRED) gentoo-dev 2007-09-02 00:55:46 UTC
 (In reply to comment #5)
> I don't have the time to check this before August,
> since vacation is approaching, and I will be away (from my computer, sigh).

Any news on this?
Comment 7 Jon Sporring 2007-09-03 11:41:48 UTC
Well, I just tested, and with current Gentoo stable, I still have the same problem.  I also did a visual comparison of the two "emerge --info" lists.  The major differences is that Jorge uses amd64 and ~amd64, while I use x86.  This results, I guess, in that Jorge has several newer tools and libraries installed.  There are also a number of use-flags that differ, but not any that I find serious with my meager knowledge of Gentoo subsystems.

I'm not sure, whether I do have a valid Berkeley DB installed.  I do have:

(rose:~) sporring% ldd /usr/lib/libkdevcatalog.so | grep libdb
        libdb-4.3.so => /usr/lib/libdb-4.3.so (0xb7e9c000)
(rose:~) sporring% equery belongs /usr/lib/libdb-4.3.so
[ Searching for file(s) /usr/lib/libdb-4.3.so in *... ]
sys-libs/db-4.3.29-r2 (/usr/lib/libdb-4.3.so)

But I don't know which files that constitute a valid Berkeley DB installation, since there is only one that I can find, which seem mildly related:

(rose:~) sporring% emerge --search berkeley
Searching...
[ Results for search key : berkeley ]
[ Applications found : 1 ]

*  dev-perl/BerkeleyDB
      Latest version available: 0.31
      Latest version installed: [ Not Installed ]
      Size of files: 157 kB
      Homepage:      http://search.cpan.org/~pmqs/BerkeleyDB
      Description:   This module provides Berkeley DB interface for Perl.
      License:       GPL-2

But this package does not ask for further packages, when I "emerge -a BerkeleyDB".

Best, Jon
Comment 8 Jon Sporring 2007-09-06 08:17:09 UTC
I think I found the solution: https://bugs.gentoo.org/show_bug.cgi?id=167948.  After switching my login shell from tcsh to bash in /etc/passwd, this problem appears to have been solved.  I'm not too fond of bash though...

Thanks for your time everyone.
Comment 9 Wulf Krueger (RETIRED) gentoo-dev 2007-09-06 08:26:52 UTC
Which obscure shell are you using? :-)

If it's app-shells/tcsh, please try using 6.15-r2 (cf. bug 190949) and report back.
Comment 10 Jon Sporring 2007-09-06 08:44:02 UTC
Yes, I admit, tcsh is an old habit that I have a hard time getting rid of... Anyway, I just got tcsh-6.15-r12 in my update:

sporring@rose ~ $ equery list tcsh
[ Searching for package 'tcsh' in all categories among: ]
 * installed packages
[I--] [  ] app-shells/tcsh-6.15-r2 (0)

But going back to tcsh as my login shell made the error reappear.  I didn't run kbuildsycoca though, because going back again to bash made the error go away.

It appears that this case is closed with respect to kdevelop.  The only thing I've not tried yet is a reboot, I'll post a notice in a couple of days, if the problem resurfaces for some reason, I cannot predict.

Thanks, Jon
Comment 11 Wulf Krueger (RETIRED) gentoo-dev 2007-09-06 09:37:35 UTC
Fabian, looks like bug 167948 rears its ugly head again even with the newly stabilised app-shells/tcsh-6.15-r2. :)

Maybe you could take a look at this? I don't think anyone in the kde herd uses such obscure shells - we have more common vices. ;-)
Comment 12 Fabian Groffen gentoo-dev 2007-09-06 09:45:35 UTC
Can somebody help me and tell if kde installs some files in /etc/profile.d?

If it's an environment issue, I need to be able to find the difference.  It looks like some missing env, but knowing which one would be cool.  strace on the tool in question might reveal which/what it is.
Comment 13 Wulf Krueger (RETIRED) gentoo-dev 2007-09-06 21:22:40 UTC
(In reply to comment #12)
> Can somebody help me and tell if kde installs some files in /etc/profile.d?

It doesn't. 

Jon, can you attach the strace output Fabian needs?
Comment 14 Jon Sporring 2007-09-07 13:45:16 UTC
I'm sorry to say, that I can't, since I no longer can reproduce the error.  I see two differences:

I've rebooted, not just restarted my kde session.
I've run kbuildsycoca with my login shell set to bash.

It seems that the tcsh error is fixed, or that the data problems have been corrected.

I do have (monster) output files from strace in various ways to start kdevelop, but I guess they are uninteresting, so I won't post them.

Thanks, Jon
Comment 15 Fabian Groffen gentoo-dev 2007-09-07 13:50:25 UTC
pardon my uber n00bness, but what does kbuildsycoca do?  Is it some sort of "indexing/preparation" program, or more like a communcation daemon running in the background every time you start KDE?

In the former case, it can be the case that still something is wrong, reading from your comment, because then it will index wrongly with tcsh as login shell.
Comment 16 Wulf Krueger (RETIRED) gentoo-dev 2007-09-08 12:31:46 UTC
KDE uses the "System Configuration Cache" (sycoca) database for looking up static system configuration information. kbuildsycoca creates/updates this database and can be run manually to compensate for such problems as described here.

More detailed informationen can be found here: http://developer.kde.org/documentation/library/kdeqt/kde3arch/ksycoca.html

Personally, I don't think this is really fixed and even if it's currently not happening anymore for Jon, it's rather likely to occur for other tcsh users as well.
Comment 17 Fabian Groffen gentoo-dev 2007-09-10 08:30:46 UTC
I vote for reopening this bug once it can be reproduced again...
Comment 18 Wulf Krueger (RETIRED) gentoo-dev 2007-09-23 21:10:43 UTC
Yes, resolving with NEEDINFO. If someone else experiences this, please re-open - if you're willing to go through with testing it...