Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 169709 - Grub refuses to compile with gcc-4.1.2
Summary: Grub refuses to compile with gcc-4.1.2
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2007-03-07 05:34 UTC by Ahmad Okda
Modified: 2007-03-08 09:46 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

error log output (config.log,9.58 KB, text/plain)
2007-03-07 17:03 UTC, Ahmad Okda

Note You need to log in before you can comment on or make changes to this bug.
Description Ahmad Okda 2007-03-07 05:34:39 UTC
i am trying to install Gentoo 64bit on my system using the guide in the link below, so i am using the keywords ~x86 and ~amd64
Grub refuses to compile with the error u can see in the thread i linked above

Reproducible: Always

Steps to Reproduce:
1.emerge grub

Actual Results:  
[code]checking for x86_64-pc-linux-gnu-gcc... (cached) x86_64-pc-linux-gnu-gcc
checking for C compiler default output file name...
configure: error: C compiler cannot create executables
See `config.log' for more details.

!!! Please attach the following file when filing a report to
!!! /var/tmp/portage/sys-boot/grub-0.97-r3/work/grub-0.97/config.log

!!! ERROR: sys-boot/grub-0.97-r3 failed.
Call stack:, line 1614:   Called dyn_compile, line 971:   Called qa_call 'src_compile'
  environment, line 3749:   Called src_compile
  grub-0.97-r3.ebuild, line 85:   Called econf '--libdir=/lib' '--datadir=/usr/lib/grub' '--exec-prefix=/' '--disable-auto-linux-mem-opt', line 577:   Called die

!!! econf failed
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/log/portage/sys-boot:grub-0.97-r3:20070306-123507.log'. [/code]

Please check the thread on the forum for the full info
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-03-07 09:08:26 UTC
> !!! Please attach the following file when filing a report to
> !!! /var/tmp/portage/sys-boot/grub-0.97-r3/work/grub-0.97/config.log

Also emerge --info missing. And no, you shouldn't have ~x86 in ACCEPT_KEYWORDS.
Comment 2 Ahmad Okda 2007-03-07 17:03:05 UTC
Created attachment 112440 [details]
error log output
Comment 3 Ahmad Okda 2007-03-07 17:05:05 UTC
i tried few hours ago reinstalling the whole system using the keywords x86 and amd64 just to use the satble gcc-4.1.1 instead of the marked unstable gcc-4.1.2

and the same error while emerging grub appeared

i attached the file as u wanted, but for any more info u may want, u will find it in the thread i pasted its link above and will paste it again below
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-03-07 17:17:06 UTC
Also post emerge --info please.
Comment 5 Ahmad Okda 2007-03-08 05:59:50 UTC
livecd / # emerge --info
Portage 2.1.2-r9 (default-linux/x86/2006.1, gcc-4.1.1, glibc-2.5-r0, 2.6.17-gentoo-r7 x86_64)
System uname: 2.6.17-gentoo-r7 x86_64 Dual Core AMD Opteron(tm) Processor 165
Gentoo Base System release 1.12.9
Timestamp of tree: Wed, 07 Mar 2007 05:50:01 +0000
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.61
sys-devel/automake:  1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
CFLAGS="-O2 -march=opteron -pipe -ftracer -ftree-vectorize -floop-optimize2"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/terminfo"
CXXFLAGS="-O2 -march=opteron -pipe -ftracer -ftree-vectorize -floop-optimize2"
FEATURES="autoconfig candy distlocks metadata-transfer parallel-fetch sandbox sfperms strict userpriv usersandbox"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--warn-once"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="bash-completion bitmap-fonts cli cracklib crypt cups dri fortran gdbm gpm iconv ipv6 isdnlog libg++ logrotate midi mmx ncurses nls nptl nptl-only nptlonly openntpd pam pcre perl png ppds pppd python readline reflection session spl sse sse2 ssl truetype truetype-fonts type1-fonts unicode userlocales x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="apm ark ati chips cirrus cyrix dummy fbdev glint i128 i740 i810 imstt mga neomagic nsc nv rendition s3 s3virge savage siliconmotion sis sisusb tdfx tga trident tseng v4l vesa vga via vmware voodoo"
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2007-03-08 09:37:28 UTC
Kindly remove amd64 from ACCEPT_KEYWORDS, your CHOST is completely wrong as well for x86 profile. You've got a pretty screwed system, re-install from scratch.
Comment 7 Ahmad Okda 2007-03-08 09:41:49 UTC
if i remove amd64 , how will i get a 64bit system ?

AFAIk my chost = x86_64-pc-linux-gnu is the correct one for a 64bit system

am i wrong ?

for ur info i just reemerged m whole toolchain using only keywords amd64, i removed the x86
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2007-03-08 09:45:59 UTC
(In reply to comment #7)
> if i remove amd64 , how will i get a 64bit system ?

You don't get any 64bit system on x86 profile (default-linux/x86/2006.1); go read the handbook.

INVALID, don't touch this bug please.