Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 168930 - media-sound/amarok-1.4.5 cannot find sound engine
Summary: media-sound/amarok-1.4.5 cannot find sound engine
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Diego Elio Pettenò (RETIRED)
Depends on:
Reported: 2007-03-01 20:30 UTC by Rob Munsch
Modified: 2007-06-07 16:21 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Rob Munsch 2007-03-01 20:30:55 UTC
had 1.4.4 and was working perfectly.  emerge world gave me 1.4.5 and it can't seem to find the sound engine, void is the only option.  Sound works from websites, youtube and google,, etc., so the sound engine itself is fine.

Reproducible: Always

Steps to Reproduce:
1. Had amarok 1.4.4
2. emerge -av world
3. amarok 1.4.5 fails to find a sound engine.

Actual Results:  
Seems to load and start fine; my collection is there etc.  however, when i click play, i get "Error: no engine loaded, cannot start playback."   In the settings -> conf amarok -> Engine dialog, the only option in the dropdown is <no engine>.

Expected Results:  
I performed a revdep-rebuild after emerging world, and nothing about alsa or any sound components were reported amiss.  Not sure how it "lost" the engine like this.
Comment 1 Rob Munsch 2007-03-01 20:31:52 UTC
root@randomaccess ~ # emerge --info
Portage 2.1.2-r9 (default-linux/x86/2006.0, gcc-4.1.1, glibc-2.5-r0, 2.6.17-gentoo-r8 i686)
System uname: 2.6.17-gentoo-r8 i686 Intel(R) Pentium(R) 4 CPU 2.80GHz
Gentoo Base System release 1.12.9
Timestamp of tree: Thu, 01 Mar 2007 16:01:02 +0000
dev-lang/python:     2.3.5-r3, 2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
CFLAGS="-O2 -march=pentium4 -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=pentium4 -fomit-frame-pointer"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="3dnow X aac acl aim alsa apache2 apm avi berkdb bitmap-fonts bzip2 cdr cli cracklib crypt cups dbus divx4linux dri dv dvd dvdr dvdread eds emboss encode esd evo flac foomaticdb fortran ftp gd gdbm gif glut gnome gphoto2 gpm gstreamer gtk gtk2 gtkhtml hal iconv icq imagemagick imap imlib innodb ipv6 isdnlog jabber javascript jpeg kde ldap libg++ libwww mad midi mikmod motif mozilla mp3 mpeg msn mysql ncurses nls nocd nptl ogg opengl oscar oss pam pcre pdflib perl php png posix pppd python qt qt3 qt4 quicktime readline reflection samba sdl session sharedext skey sockets spell spl ssl svg symlink tcpd threads tiff truetype truetype-fonts type1-fonts usb vcd vhosts videos vorbis win32codecs wxwindows x86 xine xml xorg xv xvid yahoo zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US" USERLAND="GNU" VIDEO_CARDS="nvidia vesa"


root@randomaccess ~ # equery u amarok
[ Searching for packages matching amarok... ]
[ Colour Code : set unset ]
[ Legend        : Left column  (U) - USE flags from make.conf                     ]
[                  : Right column (I) - USE flags packages was installed with ]
[ Found these USE variables for media-sound/amarok-1.4.5-r1 ]
 U I
 + + aac             : Enables support for MPEG-4 AAC Audio
 - - arts            : Adds support for aRts: the KDE sound daemon
 - - daap            : Enable support for DAAP Music Sharing
 - - debug           : Enable extra debug codepaths, like asserts and extra output. If you want to get meaningful backtraces see .
 - - elibc_FreeBSD   : <unknown>
 - - ifp             : Enable support for iRiver devices access through libifp
 - - ipod            : Enable support for iPod device access
 + + kde             : Adds support for kde-base/kde (K Desktop Enviroment)
 - - linguas_af      : <unknown>
 - - linguas_ar      : <unknown>
 - - linguas_az      : <unknown>
 - - linguas_bg      : <unknown>
 - - linguas_br      : <unknown>
 - - linguas_ca      : <unknown>
 - - linguas_cs      : <unknown>
 - - linguas_cy      : <unknown>
 - - linguas_da      : <unknown>
 - - linguas_de      : <unknown>
 - - linguas_el      : <unknown>
 - - linguas_en_GB   : <unknown>
 - - linguas_es      : <unknown>
 - - linguas_et      : <unknown>
 - - linguas_fa      : <unknown>
 - - linguas_fi      : <unknown>
 - - linguas_fr      : <unknown>
 - - linguas_ga      : <unknown>
 - - linguas_gl      : <unknown>
 - - linguas_he      : <unknown>
 - - linguas_hi      : <unknown>
 - - linguas_hu      : <unknown>
 - - linguas_is      : <unknown>
 - - linguas_it      : <unknown>
 - - linguas_ja      : <unknown>
 - - linguas_ka      : <unknown>
 - - linguas_km      : <unknown>
 - - linguas_ko      : <unknown>
 - - linguas_lt      : <unknown>
 - - linguas_ms      : <unknown>
 - - linguas_nb      : <unknown>
 - - linguas_nl      : <unknown>
 - - linguas_nn      : <unknown>
 - - linguas_pa      : <unknown>
 - - linguas_pl      : <unknown>
 - - linguas_pt      : <unknown>
 - - linguas_pt_BR   : <unknown>
 - - linguas_ro      : <unknown>
 - - linguas_ru      : <unknown>
 - - linguas_rw      : <unknown>
 - - linguas_se      : <unknown>
 - - linguas_sk      : <unknown>
 - - linguas_sl      : <unknown>
 - - linguas_sq      : <unknown>
 - - linguas_sr      : <unknown>
 - - linguas_sr@Latn : <unknown>
 - - linguas_sv      : <unknown>
 - - linguas_ta      : <unknown>
 - - linguas_tg      : <unknown>
 - - linguas_th      : <unknown>
 - - linguas_tr      : <unknown>
 - - linguas_uk      : <unknown>
 - - linguas_uz      : <unknown>
 - - linguas_zh_CN   : <unknown>
 - - linguas_zh_TW   : <unknown>
 - - mtp             : Enable support for libMTP (Plays4Sure) devices access through libmtp
 - - musicbrainz     : Lookup audio metadata using MusicBrainz community service (
 + + mysql           : Adds mySQL Database support
 - - njb             : Enable support for NJB (Creative) devices access through libnjb
 - - noamazon        : Disable support for downloading covers from
 + + opengl          : Adds support for OpenGL (3D graphics)
 - - postgres        : Adds support for the postgresql database
 - - real            : Build with real/helix player support
 + + visualization   : Support visualization plugins through media-libs/libvisual
 - - xinerama        : Add support for the xinerama X11 extension, which allows you to stretch your display across multiple monitors
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2007-03-02 02:26:11 UTC

*** This bug has been marked as a duplicate of bug 130052 ***
Comment 3 Rob Munsch 2007-03-02 15:15:49 UTC
I fail to see how this is a duplicate.  The bug you marked this a dup of is 1.4.4, which worked perfectly for me!  Upgrading to 1.4.5 via emerge is what broke amarok.  Moreover, none of the fixes, assumptions or details mentioned in the bug you made this a dup of, show any results at all.  None.
Comment 4 Rob Munsch 2007-03-02 15:19:12 UTC
To be explicit, from the previous bug:

"After emerging amarok, I got the "couldn't find configuration, please compile
with --prefix=`kde-config --prefix` etc"-error message when I tried to run

This did not happen with me.  nothing of he sort.

"Sounds like the problem are stray .la files in /usr/kde/<kdever> most likely."

There are none.  find /usr/kde/3.5 -name '*amarok*.la'  returns nothing.

"I resolved the issue by removing *every* trace of kde-3.4-stuff in the portage
tree and in the file system and recompiling amarok."

There are no traces of KDE 3.4 left on my system that i can find.

Therefore none of the solutions mentioned in the previous bug from 6 months ago from a previous version are applicable to this current problem.
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2007-03-02 15:27:44 UTC
Here's a cool idea then - kindly post some *errors* when filing bugs.
Comment 6 Rob Munsch 2007-03-02 16:22:32 UTC
Fair enough.  Recompiling with bug use flag.  More soon.
Comment 7 Rob Munsch 2007-03-02 16:41:56 UTC
So when i start amarok now, i get this:

rmunsch@randomaccess ~/perl $ amarokapp
amarok: BEGIN: App::App()
amarok: BEGIN: void App::fixHyperThreading()
amarok:     SMP system detected. Enabling WORKAROUND.
amarok: END__: void App::fixHyperThreading() - Took 0.00064s
amarok: END__: App::App() - Took 0.0049s
amarok: BEGIN: void App::continueInit()
amarok: BEGIN: EngineBase* EngineController::loadEngine(const QString&)
amarok:     [PluginManager] Plugin trader constraint: [X-KDE-Amarok-framework-version] == 28 and [X-KDE-Amarok-plugintype] == 'engine' and [X-KDE-Amarok-name] != 'void-engine' and [X-KDE-Amarok-rank] > 0
amarok:     [PluginManager] Plugin trader constraint: [X-KDE-Amarok-framework-version] == 28 and [X-KDE-Amarok-plugintype] == 'engine' and [X-KDE-Amarok-name] == 'void-engine' and [X-KDE-Amarok-rank] > 0
amarok:     [PluginManager] Trying to load: libamarok_void-engine_plugin
amarok:     PluginManager Service Info:
amarok:     ---------------------------
amarok:     name                          : <no engine>
amarok:     library                       : libamarok_void-engine_plugin
amarok:     desktopEntryPath              : amarok_void-engine_plugin.desktop
amarok:     X-KDE-Amarok-plugintype       : engine
amarok:     X-KDE-Amarok-name             : void-engine
amarok:     X-KDE-Amarok-authors          : (Max Howell,Mark Kretschmann)
amarok:     X-KDE-Amarok-rank             : 1
amarok:     X-KDE-Amarok-version          : 1
amarok:     X-KDE-Amarok-framework-version: 28
amarok: END__: EngineBase* EngineController::loadEngine(const QString&) - Took 0.023s

Note the lack of a usable engine.  Where should i look for additional info?  What would be helpful?
Comment 8 Rob Munsch 2007-03-02 16:47:05 UTC
On first run after original upgrade, i got a brief "Hey! There's no engine!" message and it defaulted to void.  Ever since, void is my only choice in the drop-down, as originally stated.

The program *runs* okay... it just insists that there is no engine but Void, and Void is the One True Engine.  I'm not sure how to go about usefully debugging amarok becoming a nihilist.  How can i get it to check for "new" engines?  Reemerge alsa?
Comment 9 Rob Munsch 2007-03-02 20:02:25 UTC
of note, i also reemerged xine-libs; no effect.
Comment 10 Rob Munsch 2007-03-05 21:31:38 UTC
I uninstalled the Amarok ebuild, and got the 1.4.5 source.
Built from source with 
./configure --prefix=`kde-config --prefix` --enable-mysql

Works fine.  Xine listed as a sound engine choice and works.  All sys go when installing from sources.

The ebuild cannot find xine for some reason but i still can't figure out what's different.
Comment 11 Dan 2007-03-16 23:04:53 UTC
Can you try building from the ebuild again and posting the output from amarok if you run with amarok --engine xine? also can you see if /usr/kde/3.5/lib/kde3/ exists when building from the ebuild?
Comment 12 Diego Elio Pettenò (RETIRED) gentoo-dev 2007-06-07 16:21:54 UTC
uninstall amarok in *every* way you installed it, find /usr -name '*amarok*' should report nothing. Then install amarok, all should be fine.