Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 168780 - dev-java/gnu-classpath-0.93 fails to compile nsplugin
Summary: dev-java/gnu-classpath-0.93 fails to compile nsplugin
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC64 Linux
: High normal (vote)
Assignee: Java team
Depends on:
Blocks: 168736
  Show dependency tree
Reported: 2007-02-28 20:13 UTC by Markus Rothe (RETIRED)
Modified: 2007-03-02 20:00 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

gnu-classpath-0.93-output.txt (gnu-classpath-0.93-output.txt,15.02 KB, text/plain)
2007-02-28 20:13 UTC, Markus Rothe (RETIRED)

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Rothe (RETIRED) gentoo-dev 2007-02-28 20:13:14 UTC
I've just tried to compile dev-java/gnu-classpath-0.93, but it failed.

# emerge --info
Portage 2.1.2-r9 (default-linux/ppc/ppc64/2007.0/64bit-userland/desktop/970/pmac, gcc-4.1.1, glibc-2.5-r0, ppc64)
System uname: ppc64 PPC970FX, altivec supported
Gentoo Base System release 1.12.9
Timestamp of tree: Wed, 28 Feb 2007 19:30:01 +0000
ccache version 2.4 [disabled]
dev-java/java-config: 1.3.7, 2.0.31
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
CFLAGS="-O2 -pipe -mtune=970 -mcpu=970 -mabi=altivec"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -mtune=970 -mcpu=970 -mabi=altivec"
FEATURES="autoaddcvs autoconfig cvs distlocks metadata-transfer sandbox sfperms strict"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac aiglx alsa altivec amr apache2 asf avahi bash-completion berkdb bitmap-fonts boost bzip2 cairo ccache cdinstall cdparanoia cdr cli cracklib crypt cups curl cvs daap dbus dedicated djvu dri dts dv dvd dvdr dvdread dvi emboss enca encode escreen exif exo fam ffmpeg firefox flac foomaticdb fortran fping gcj gd gdbm ggi gif gimp gimpprint glib glitz gmp gnokii gnome gnutls gphoto2 gpm graphviz gs gstreamer gtk hal hfs highlight iconv idle ieee1394 imagemagick imap imlib ipod ipv6 isdnlog jpeg kdeenablefinal lame latex ldap libnotify mad matroska mdnsresponder-compat midi mikmod mjpeg motif mozbranding mp3 mp4 mpeg mplayer mtp multiuser musicbrainz mysql ncurses network nls no-old-linux nptl nptlonly nsplugin objc objc++ offensive ogg onaccess openal opengl pam panel-plugin pcre pdf perl php plotutils png ppc64 ppds pppd python qt3 qt4 quicktime rdesktop readline reflection ruby samba savedconfig scanner screen sdl session skins slp smp snmp spell spl ssl startup-notification stream subtitles subversion svg tcltk tcpd teamarena tetex theora threads thumbnail thunar-vfs tiff trash-panel-plugin trayicon truetype truetype-fonts type1-fonts unicode upnp usb utempter vcd videos vim-pager vorbis wxwindows x264 xcb xcomposite xine xml xorg xpm xscreensaver xv xvid xvmc zeroconf zlib" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="radeon"
Comment 1 Markus Rothe (RETIRED) gentoo-dev 2007-02-28 20:13:33 UTC
Created attachment 111619 [details]
Comment 2 Petteri Räty (RETIRED) gentoo-dev 2007-02-28 20:39:15 UTC
What does `pkg-config --cflags firefox-plugin` say?

betelgeuse@pena /var/tmp/portage/dev-java/gnu-classpath-0.93/work/classpath-0.93 $ pkg-config --cflags firefox-plugin
-I/usr/lib/mozilla-firefox/include/java -I/usr/lib/mozilla-firefox/include/plugin -I/usr/lib/mozilla-firefox/include -I/usr/lib/mozilla-firefox/include/xpcom -I/usr/lib/mozilla-firefox/include/string -I/usr/include/nspr
Comment 3 Lars Wendler (Polynomial-C) (RETIRED) gentoo-dev 2007-02-28 23:38:37 UTC
same error with seamonkey (1.1.1)

# pkg-config --cflags seamonkey-plugin
-I/usr/lib/seamonkey/include/java -I/usr/lib/seamonkey/include/plugin -I/usr/include/nspr
Comment 4 Markus Rothe (RETIRED) gentoo-dev 2007-03-01 19:58:00 UTC
$ pkg-config --cflags firefox-plugin
-I/usr/lib64/mozilla-firefox/include/java -I/usr/lib64/mozilla-firefox/include/plugin -I/usr/include/nspr
Comment 5 Petteri Räty (RETIRED) gentoo-dev 2007-03-01 20:14:01 UTC
(In reply to comment #4)
> $ pkg-config --cflags firefox-plugin
> -I/usr/lib64/mozilla-firefox/include/java
> -I/usr/lib64/mozilla-firefox/include/plugin -I/usr/include/nspr

This is our problem here. This does not have the needed directories.

betelgeuse@pena ~/patches $ pkg-config --cflags seamonkey-plugin
-I/usr/lib/seamonkey/include/java -I/usr/lib/seamonkey/include/plugin -I/usr/lib/seamonkey/include -I/usr/lib/seamonkey/include/xpcom -I/usr/lib/seamonkey/include/string -I/usr/include/nspr
betelgeuse@pena ~/patches $ pkg-config --cflags firefox-plugin
-I/usr/lib/mozilla-firefox/include/java -I/usr/lib/mozilla-firefox/include/plugin -I/usr/lib/mozilla-firefox/include -I/usr/lib/mozilla-firefox/include/xpcom -I/usr/lib/mozilla-firefox/include/string -I/usr/include/nspr

mozilla herd: Any thoughts?
Comment 6 Vlastimil Babka (Caster) (RETIRED) gentoo-dev 2007-03-01 20:50:52 UTC
seamonkey 1.0.7: USE="crypt ipv6 java mozcalendar mozdevelop moznoirc"
# pkg-config --cflags seamonkey-plugin
-I/usr/lib/seamonkey/include/java -I/usr/lib/seamonkey/include/plugin -I/usr/lib/seamonkey/include -I/usr/lib/seamonkey/include/xpcom -I/usr/lib/seamonkey/include/string -I/usr/include/nspr

firefox USE="filepicker ipv6 java mozbranding mozdevelop xforms"
# pkg-config --cflags firefox-plugin
-I/usr/lib/mozilla-firefox/include/java -I/usr/lib/mozilla-firefox/include/plugin -I/usr/include/nspr

What firefox version and flags do you have, Petteri?
The missing header should be in xpcom dir.
Comment 7 Petteri Räty (RETIRED) gentoo-dev 2007-03-01 20:52:09 UTC
This is a problem in the newest versions of firefox and seamonkey where they changed the pkg-config handling.
Comment 8 Petteri Räty (RETIRED) gentoo-dev 2007-03-02 20:00:49 UTC
Committed a patch fixing this to CVS. Sync in an hour or two and it should be fixed. Thanks for reporting.