Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 168503 - funambol ebuild request
Summary: funambol ebuild request
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement with 9 votes (vote)
Assignee: Default Assignee for New Packages
URL: http://www.funambol.com/opensource/do...
Whiteboard:
Keywords:
Depends on:
Blocks: 313907
  Show dependency tree
 
Reported: 2007-02-26 20:44 UTC by Stefan Markovic
Modified: 2012-01-10 11:36 UTC (History)
31 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ebuild for net-misc/funambol-8.7.0 (funambol-8.7.0.ebuild,1.51 KB, text/plain)
2010-08-13 07:50 UTC, Florian Knodt
Details
init-script net-misc/funambol-8.7.0 (Funambol.init,526 bytes, text/plain)
2010-08-13 07:51 UTC, Florian Knodt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Markovic 2007-02-26 20:44:19 UTC
Funambol provides push email, PIM synchronization, and device management for mobile devices, with all the advantages of open source software.

Reproducible: Always
Comment 1 Jan Schubert 2007-07-31 20:23:39 UTC
Urgent vote for this!
Comment 2 grassu 2007-08-15 16:18:29 UTC
One more vote!
Comment 3 Berk Birand 2007-08-19 15:59:06 UTC
Here's another vote! I don't see why there hasn't been any work done on this. Is it really that hard to do?
Comment 4 Kliakhandler Kosta 2007-09-11 23:38:51 UTC
I vote for it as well...

If it is not that hard to do, why not do it yourself?

I would do it if I wasn't swamped at the moment - I might sometime in the future.
Comment 5 M. R. 2008-09-08 08:22:20 UTC
actually funambol  doesn't work for issues with tomcat and java on gentoo. Installer runs fine, but server doesn't start
Comment 6 Robert Krig 2008-09-16 03:14:12 UTC
The current version of Funambol seems to work on Gentoo.
I just followed the instructions and started the bin file manually. I can even open the funambol DS server status page in firefox. (localhost:8080/funambol)

However, since I run a 64-bit server, I cant seem to get the funamboladmin tool to run. It seems to want a 32-bit java environment, regardless of what my JAVA_HOME environment variable is set to.
Comment 7 Vytautas Jakutis 2009-06-12 20:35:25 UTC
To have a nice ebuild, we need the source package. But it is only available to certain users on their SCM. However, they may give these read permissions to a certain user. Maybe Gentoo Foundation (or a Gentoo developer) could ask for it?

Here's an excerpt from their licensing terms:
Funambol has two versions of its software: the open source Community Edition and the commercial Carrier Edition. The editions share a body of source code. This dual-license strategy is now common with commercial open source companies.

Funambol Community Edition is conveyed under the terms of the GNU Affero General Public License v3 (AGPLv3) open source license. The AGPLv3 open source license allows you to use Community Edition at no charge under the condition that if you use Funambol code in an application that you distribute, the complete source code for your application must be available and freely redistributable, too. When you distribute an application that uses Funambol Community Edition in any way (or you deploy an application or service that uses Funambol Community Edition in any way, on a network that is publicly accessible i.e. that is accessible to the "outside world", such as the Internet), to comply with Section 7(b) of AGPLv3, the Appropriate Legal Notices (as described by the AGPLv3) of your application or service must retain the display of the "Powered by Funambol" logo.
Comment 8 Silvio 2009-11-14 08:58:19 UTC
We use Funambol on gentoo, now we are trying to make an ebuild.
If we'll get it I will post here, hoping it will be approved.

bye

Comment 9 saft 2010-04-24 09:09:31 UTC
would like to revive this request :)
thx for your hard work!
Comment 10 snIP3r 2010-05-07 21:12:21 UTC
i am also interested in an ebuild for funambol - voted for this with 10 ;)
Comment 11 Karl-Heinz Schneider 2010-05-16 10:38:21 UTC
Also interested.
Comment 12 Johannes Ruthmair 2010-06-01 14:03:10 UTC
vote ++ !! I am very interested too!
Comment 13 Martin Samek 2010-07-15 09:03:54 UTC
+1
Comment 14 Florian Knodt 2010-08-13 07:50:45 UTC
Created attachment 242729 [details]
ebuild for net-misc/funambol-8.7.0

This ebuild is a port of ngoonee's arch linux PKGBUILD (http://aur.archlinux.org/packages.php?ID=35631). Should handle x86 (untested) and x86_64. Files go to /opt/funambol, it creates a symlink for funamboladmin in /usr/bin and installs a simple init-script. Also note, that it uses the java-vm set by the system instead of the bundeled one (in my case icedtea6-bin).
Comment 15 Florian Knodt 2010-08-13 07:51:11 UTC
Created attachment 242731 [details]
init-script net-misc/funambol-8.7.0
Comment 16 Florian Knodt 2010-08-13 07:51:28 UTC
Attach
Comment 17 Thomas Capricelli 2010-12-13 20:52:20 UTC
Hi. I've tried the funambol-8.7.0.ebuild today. The funamboladmin tool can only be started by root and it will create/fill directories /usr/bin/{var,config,modules}. This frightens me enough that i've removed the whole stuff.
Is this really mandatory ?
Comment 18 Leho Kraav (:macmaN @lkraav) 2010-12-13 20:55:31 UTC
(In reply to comment #17)
> Hi. I've tried the funambol-8.7.0.ebuild today. The funamboladmin tool can only
> be started by root and it will create/fill directories
> /usr/bin/{var,config,modules}. This frightens me enough that i've removed the
> whole stuff.

holy schmokes, didn't notice that at all! +1 for the "what's up with that" question.
Comment 19 Stefan Markovic 2010-12-13 21:52:21 UTC
(In reply to comment #17)
> Hi. I've tried the funambol-8.7.0.ebuild today. The funamboladmin tool can only
> be started by root and it will create/fill directories
> /usr/bin/{var,config,modules}. This frightens me enough that i've removed the
> whole stuff.
> Is this really mandatory ?
> 

It has been like 3 years since I open this... You can put it in won't fix category.
We all have androids by now, right? :)
Comment 20 Thomas Capricelli 2010-12-13 23:39:13 UTC
I do have an android, that's precisely the reason i'd like to have funambol working..
Comment 21 James Le Cuirot gentoo-dev 2011-04-26 00:13:44 UTC
I got my first Android the other day and that has also led me to Funambol. It's been a long time so it's worth a fresh look. Maybe they've made it less scary now. I'm an experienced ebuild writer so I'll see what I can do.
Comment 22 Stefan Wimmer 2012-01-10 11:21:45 UTC
(In reply to comment #21)
> I got my first Android the other day and that has also led me to Funambol. It's
> been a long time so it's worth a fresh look. Maybe they've made it less scary
> now. I'm an experienced ebuild writer so I'll see what I can do.

James, did you ever succeed in writing the ebuild? I'd be quite interested as well ... ;-)
Comment 23 James Le Cuirot gentoo-dev 2012-01-10 11:36:03 UTC
I got a little way into it but I didn't even start to unbundle it or build it from source. I was basing it around Gentoo's Tomcat setup but Tomcat isn't well maintained on Gentoo either. :( It did start but didn't work properly because it needed a populated database. I was in the process of working out the best way to populate the database without running the rest of the setup script. In the end, it was more work than I was willing to put it. I recently gave in and just used Google Contacts instead. Sorry!