Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 168349 - x11-misc/xchm doesn't run when IPP Server (???) is off
Summary: x11-misc/xchm doesn't run when IPP Server (???) is off
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Desktop Misc. Team
Depends on:
Reported: 2007-02-25 16:57 UTC by Fausto
Modified: 2010-09-13 17:02 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Fausto 2007-02-25 16:57:53 UTC
The Xchm program wont run if the printing Server (IPP) is off.. and it crashed.. it stay in a endless loop.

Reproducible: Always

Actual Results:  
** (xchm:15053): WARNING **: IPP request failed with status 1280

** (xchm:15053): WARNING **: IPP request failed with status 1280
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-02-25 17:03:35 UTC
Which version is this about? How about emerge --info? And WTH is IPP Server? It definitely doesn't loop anywhere here.

Comment 2 Fausto 2007-02-25 22:17:22 UTC
Internet Printing Protocol or "IPP", defines a standard protocol for printing as well as managing print jobs. 

The version in question here is Xchm 1.10, but it happends with all the versions i've tried. 

Portage 2.1.2-r10 (default-linux/x86/2006.1, gcc-4.1.2, glibc-2.5-r0, 2.6.20-gentoo i686)
System uname: 2.6.20-gentoo i686 Intel(R) Pentium(R) 4 CPU 1.80GHz
Gentoo Base System version 1.12.9
Timestamp of tree: Sat, 24 Feb 2007 01:00:01 +0000
dev-java/java-config: 1.3.7, 2.0.31-r3
dev-lang/python:     2.4.4
dev-python/pycrypto: 2.0.1-r5
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.20
CFLAGS="-O2 -march=pentium4 -mtune=pentium4 -fomit-frame-pointer -ftracer -pipe"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=pentium4 -mtune=pentium4 -fomit-frame-pointer -ftracer -pipe"
FEATURES="autoconfig candy ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
LINGUAS="en es"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="3dfx 3dnow alsa berkdb bitmap-fonts bluetooth cairo cdr cdrw cli cracklib crypt cups dri fortran gdbm gif gnome gpm gtk iconv isdnlog jpeg libg++ midi mp3 mpg mplayer ncurses nls nptl nptlonly ntpl ntplonly ogg pam pcre perl png ppds pppd python readline reflection session spl ssl svg tcpd truetype-fonts type1-fonts unicode vorbis win32codecs x86 xorg xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en es" USERLAND="GNU" VIDEO_CARDS="vesa i810"
Comment 3 Ryan Hill (RETIRED) gentoo-dev 2007-03-10 05:10:55 UTC
what version(s) of wxGTK do you have installed?  this sounds like an old bug where apps using wxHtmlEasyPrinting would hang when they tried to create a wxPrintData object when the IPP server was unavailable. 
Comment 4 Fausto 2007-03-11 14:46:10 UTC
I have installed version wxGTK
Comment 5 Ryan Hill (RETIRED) gentoo-dev 2007-03-24 02:56:57 UTC
leio, any ideas?
Comment 6 Mart Raudsepp gentoo-dev 2007-03-24 16:08:20 UTC
Well, the warnings are meaningless to me - this is a standard warning spam from cups or gnomeprint stuff and don't meaning anything other than that certain cups services or features aren't running.
I doubt the reason xchm isn't running is caused of that (I see the warning too for all wxPrint* class users with no ill effects), but something else for which I don't have the information from this bug. How about a backtrace or something like that?
Comment 7 Mart Raudsepp gentoo-dev 2007-05-07 01:18:48 UTC
Does this still happen with xchm-1.13 for those where the problem existed?

If it does, then we'll need the information requested in the previous comment. If it's an infinite loop you can try hitting it inside gdb, stopping the program, getting a backtrace, saving it and continue'ing and try a couple times if the stacktrace is always similar.
Comment 8 Arnaud Vallette d'Osia 2010-09-12 20:00:55 UTC
Workaround is described here:
which like said by a Debian user, doesn't fix the bug,
I would not say it's resolved since I encounter it also...
ready to help
Comment 9 Arnaud Vallette d'Osia 2010-09-13 17:02:23 UTC
And that info goes further:

Darjeeling citation:

<<the page setup defaults to letter format which isn't popular in Europe.
[...]to make this change permanent by creating a "normal.awt" template in /usr/share/abiword-2.6/templates. Just copy the existing "A4.awt" to "normal.awt">> 

I've checked in the source : A4.awt templates exists,
but it doesn't exist in my /usr/share/abiword-2.6/templates directory...
I've created it back, and it should be ported back in gentoo ebuild, no ?
I'd like to reopen the bug...

With kind regards