Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 167694 - media-gfx/blender-2.43 released
Summary: media-gfx/blender-2.43 released
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Luca Barbato
: 168042 168477 168904 169065 170045 (view as bug list)
Depends on:
Blocks: 168907
  Show dependency tree
Reported: 2007-02-19 22:34 UTC by aslvrstn
Modified: 2007-05-14 12:24 UTC (History)
19 users (show)

See Also:
Package list:
Runtime testing required: ---

enhanced build for blender-2.43 (blender-2.43.ebuild,3.83 KB, text/plain)
2007-03-03 12:32 UTC, Mario Kicherer
enhanced ebuild that will compile on 64 bit systems (blender-2.43.ebuild,4.10 KB, text/plain)
2007-03-07 13:14 UTC, Matthew Clark
put this in the files dir. (,31 bytes, text/plain)
2007-03-07 13:15 UTC, Matthew Clark
media-gfx/blender-2.43.ebuild new (blender-2.43.ebuild,3.52 KB, text/plain)
2007-03-11 23:53 UTC, Cornelius Weig
sorry, there were typos in the above version. (blender-2.43.ebuild,3.32 KB, text/plain)
2007-03-12 00:08 UTC, Cornelius Weig

Note You need to log in before you can comment on or make changes to this bug.
Description aslvrstn 2007-02-19 22:34:59 UTC
I copied the 2.42a-r1 ebuild to 2.43, which failed with "cannot find liconv". Compiling with USE="-iconv" worked for me, but I believe iconv may be on by default and it looks like a touchy USE flag in portage.

Reproducible: Always

Steps to Reproduce:
Comment 1 Stefan de Konink 2007-02-20 18:53:47 UTC
To prevent further disappointment:

skinkie@localhost ~ $ blender   
64 bits compiles will give incorrectly saved .blend files. Do not use it. For testing purposes please remove this line from creator.c
Comment 2 Luca Barbato gentoo-dev 2007-02-20 19:33:52 UTC
I'd wait for a fix release...
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2007-02-22 21:41:23 UTC
*** Bug 168042 has been marked as a duplicate of this bug. ***
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-02-26 17:16:43 UTC
*** Bug 168477 has been marked as a duplicate of this bug. ***
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2007-03-01 16:45:07 UTC
*** Bug 168904 has been marked as a duplicate of this bug. ***
Comment 6 Daniel Black (RETIRED) gentoo-dev 2007-03-02 10:51:07 UTC
(In reply to comment #1)
> To prevent further disappointment:
> skinkie@localhost ~ $ blender   
> 64 bits compiles will give incorrectly saved .blend files. Do not use it. For
> testing purposes please remove this line from creator.c

Stefan I can't see this in the upstream blender gforge. Care to add it?
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2007-03-03 05:49:40 UTC
*** Bug 169065 has been marked as a duplicate of this bug. ***
Comment 8 Mario Kicherer 2007-03-03 12:31:48 UTC

I've enhanced the build in some ways.
It takes care of every possible use flag I found, 
so it might be worth a look.

I had to built it without quicktime and iconv, too.

It's the first ebuild I've made, so I hope it works
for you. :)

Comment 9 Mario Kicherer 2007-03-03 12:32:50 UTC
Created attachment 111905 [details]
enhanced build for blender-2.43
Comment 10 Mario Kicherer 2007-03-03 13:02:22 UTC
Comment on attachment 111905 [details]
enhanced build for blender-2.43

><HTML><HEAD/><BODY><PRE># Copyright 1999-2007 Gentoo Foundation
># Distributed under the terms of the GNU General Public License v2
># $Header: $
>inherit multilib flag-o-matic eutils python
>IUSE="openal sdl openexr jpeg png nls iconv blender-game 
>	ffmpeg yafray tiff fmod zlib ode quicktime mesa
>	blender-player bullet plugins scripts verse"
>DESCRIPTION="3D Creation/Animation/Publishing System"
>LICENSE="|| ( GPL-2 BL )"
>KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
>	jpeg? ( &gt;=media-libs/jpeg-6b )
>	png? ( &gt;=media-libs/libpng-1.0.14 )
>	media-libs/tiff
>	nls? ( &gt;=media-libs/freetype-2.0
>			virtual/libintl )
>	iconv? ( virtual/libiconv )
>	openal? ( media-libs/openal
>			  media-libs/freealut )
>	sdl? ( &gt;=media-libs/libsdl-1.2 )
>	ffmpeg? ( media-video/ffmpeg )
>	&gt;=dev-libs/openssl-0.9.6
>	nls? ( &gt;=media-libs/ftgl-2.1 )
>	openexr? ( media-libs/openexr )
>	virtual/opengl
>	yafray? ( &gt;=media-gfx/yafray-0.0.7 )
>	fmod? ( media-libs/fmod )
>	zlib? ( sys-libs/zlib )
>	ode? ( dev-games/ode )
>	quicktime? ( virtual/quicktime )
>	mesa? ( &gt;=media-libs/mesa-3.4.2 )
>	&gt;=dev-lang/python-2.2
>	"
>	|| ( x11-libs/libXt virtual/x11 )
>blend_with() {
>local UWORD="$2"
>	if [ -z "${UWORD}" ]; then
>		UWORD="$1"
>	fi
>	if use $1; then
>		echo "WITH_BF_${UWORD}=1" | tr '[:lower:]' '[:upper:]'
>	else
>		echo "WITH_BF_${UWORD}=0" | tr '[:lower:]' '[:upper:]'
>	fi
>return 0
>src_unpack() {
>	unpack ${A}
>	if use "plugins"; then
>		mkdir -p ${WORKDIR}/install/linux2/plugins/
>		cd ${WORKDIR}/install/linux2/plugins/
>		cp -pPR ${S}/source/blender/blenpluginapi include
>	fi
>src_compile() {
>	local myconf=""
>	myconf="${myconf} $(blend_with openal)"
>	myconf="${myconf} $(blend_with sdl)"
>	myconf="${myconf} $(blend_with openexr)"
>	myconf="${myconf} $(blend_with jpeg)"
>	myconf="${myconf} $(blend_with ffmpeg)"
>	myconf="${myconf} $(blend_with png)"
>	myconf="${myconf} $(blend_with nls international)"
>	myconf="${myconf} $(blend_with iconv)"
>	myconf="${myconf} $(blend_with blender-game gameengine)"
>	myconf="${myconf} $(blend_with yafray)"
>	myconf="${myconf} $(blend_with fmod)"
>	myconf="${myconf} $(blend_with zlib)"
>	myconf="${myconf} $(blend_with ode)"
>	myconf="${myconf} $(blend_with bullet)"
>	myconf="${myconf} $(blend_with quicktime)"
>	myconf="${myconf} $(blend_with blender-player player)"
>	myconf="${myconf} $(blend_with mesa staticopengl)"
>	myconf="${myconf} $(blend_with verse)"
>	if use "quicktime"; then
>		elog ""
>		elog ""
>		elog "NOTICE: quicktime is known to cause problems on some systems."
>		elog ""
>		elog ""
>		sleep 3
>	fi
>	scons ${MAKEOPTS} ${myconf} || die
>	if use "plugins"; then
>		cd ${WORKDIR}/install/linux2/plugins/
>		chmod 755 bmake
>		emake || die
>	fi
>src_install() {
>	exeinto /usr/bin/
>	doexe ${WORKDIR}/install/linux2/blender
>	if use "blender-player"; then
>		doexe ${WORKDIR}/install/linux2/blenderplayer
>	fi
>	if use "plugins"; then
>		exeinto /usr/$(get_libdir)/${PN}/textures
>		doexe ${WORKDIR}/install/linux2/plugins/texture/*.so
>		exeinto /usr/$(get_libdir)/${PN}/sequences
>		doexe ${WORKDIR}/install/linux2/plugins/sequence/*.so
>		insinto /usr/include/${PN}/
>		doins ${WORKDIR}/install/linux2/plugins/include/*.h
>	fi
>	dodir /usr/share/${PN}
>	cp -pPR ${WORKDIR}/install/linux2/.blender/.bfont.ttf \
>		${D}/usr/share/${PN}
>	cp -pPR ${WORKDIR}/install/linux2/.blender/.Blanguages \
>		${D}/usr/share/${PN}
>	if use "nls"; then
>		cp -pPR ${WORKDIR}/install/linux2/.blender/locale \
>			${D}/usr/share/
>	fi
>	if use "scripts"; then
>		cp -pPR ${WORKDIR}/install/linux2/.blender/scripts \
>			${D}/usr/share/${PN}
>	fi
>	insinto /usr/share/pixmaps
>	doins release/freedesktop/icons/32x32/${PN}.png
        insinto /usr/share/applications
        doins ${FILESDIR}/${PN}.desktop
>pkg_postinst() {
>	if use "scripts"; then
>		elog
>		elog "Some builtin scripts were installed in /usr/share/${PN}/scripts/"
>		elog
>	fi
Comment 11 Mathy Vanvoorden 2007-03-03 19:42:33 UTC
This version compiles and runs for me on x86 by just copying the 2.42a-r1 ebuild. I encountered some problems though:
* ffmpeg: I had ffmpeg installed from svn, this didn't compile because blender uses a deprecated function img_convert. I installed 0.4.9_p20070129 and it worked. I also changed the version number in the blender ebuild.
* use flag iconv: The use-flag iconv is enabled by default. This would however result in the compile failing because it can't find the libiconv library on my system. It isn't there and as far as I can tell glibc should provide it. I just disabled the use-flag because I have no need for it anyway.
Comment 12 Matthew Clark 2007-03-07 13:14:31 UTC
Created attachment 112404 [details]
enhanced ebuild that will compile on 64 bit systems

make your overlay, copy the file in to the files directory and then use this ebuild if you have a 64 bit system and don't care if it messes up your blend files.for details read here:
Comment 13 Matthew Clark 2007-03-07 13:15:19 UTC
Created attachment 112405 [details]
put this in the files dir.

see ebuild note
Comment 14 Jakub Moc (RETIRED) gentoo-dev 2007-03-09 00:36:22 UTC
*** Bug 170045 has been marked as a duplicate of this bug. ***
Comment 15 Cornelius Weig 2007-03-11 23:53:33 UTC
Created attachment 113028 [details]
media-gfx/blender-2.43.ebuild new

This ebuild builds upon blender-2.42a-r1. The following changes have been made:
+ USE=yafray enables yafray rendering engine
+ USE=ode enables support for Open Dynamics Engine
+ USE=sdl enables support for Simple DirectMedia Layer
- USE=iconv  non-critical feature, blender can do that alone, but a lot of people report issues with that

other changes:
+ the blend_with function in the ebuild has been changed to take advantage of the possible user-config file. This allowed also to
+ pass the CFLAGS of the user to the build system. This is maybe the most substantial change
Comment 16 Cornelius Weig 2007-03-12 00:08:51 UTC
Created attachment 113029 [details]
sorry, there were typos in the above version.

see comments in my previous post

+ scons does not understand the -l option for make. One has to remove this otherwise it does not compile, but scons will exit with 0 indicating no error.
Comment 17 Luca Barbato gentoo-dev 2007-03-13 10:50:28 UTC
scons or cmake?
Comment 18 Cornelius Weig 2007-03-14 17:03:14 UTC
(In reply to comment #17)
> scons or cmake?

I think it is scons, as I don't have cmake installed. Look at the following example:
 $ if scons -l 4 ; then echo "no error"; fi
Warning:  the -l option is not yet implemented
no error

as you can see, scons exits without an error and without doing anything. That's why it has to be removed from MAKEOPTS
Comment 19 Robert Krig 2007-03-28 18:22:10 UTC
Hi guys, is there any word on when we can expect this to hit the official portage tree?
Comment 20 Luca Barbato gentoo-dev 2007-04-10 06:32:18 UTC
I pushed a masked ebuild, please test and report back
Comment 21 karpi 2007-04-10 07:55:12 UTC
(In reply to comment #20)
> I pushed a masked ebuild, please test and report back

USE="blender-game jpeg nls openexr png sdl -ffmpeg -openal"

equery s blender
* size of media-gfx/blender-2.43
           Total files : 246
           Total size  : 15073.46 KiB

Compiled fine, thanks :) 
Comment 22 Wiebe Cazemier 2007-04-10 09:35:26 UTC
In light of bug 150279 (it doesn't install the scripts without nls), shouldn't the nls useflag be non-optional, or at least give a warning when you have it disabled? 
Comment 23 Luca Barbato gentoo-dev 2007-04-10 09:45:33 UTC
I forgot that issue too...

I'm starting to hate blender glitches...
Comment 24 onip 2007-04-11 14:42:26 UTC
(In reply to comment #20)
> I pushed a masked ebuild, please test and report back

synced today and emerged it fine.

Hal9000 ~ # emerge --info
Portage (default-linux/x86/2006.1/desktop, gcc-4.1.1, glibc-2.5-r0, 2.6.19-gentoo-r5 i686)
System uname: 2.6.19-gentoo-r5 i686 Intel(R) Pentium(R) 4 CPU 2.50GHz
Gentoo Base System release 1.12.9
Timestamp of tree: Wed, 11 Apr 2007 11:20:02 +0000
dev-java/java-config: 1.3.7, 2.0.31
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
CFLAGS="-O2 -march=i686 -mmmx -msse -msse2 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/php/apache1-php4/ext-active/ /etc/php/apache2-php4/ext-active/ /etc/php/cgi-php4/ext-active/ /etc/php/cli-php4/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O2 -march=i686 -mmmx -msse -msse2 -pipe -fomit-frame-pointer"
FEATURES="buildpkg distlocks fixpackages parallel-fetch sandbox sfperms strict"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTDIR_OVERLAY="/usr/local/portage /usr/portage/local/layman/science /usr/portage/local/layman/sunrise /usr/portage/local/layman/gechi /usr/portage/local/layman/pro-audio /usr/portage/local/layman/gentopia"
USE="X a52 aac alsa apache2 audiofile berkdb bitmap-fonts branding bzip2 cairo cdparanoia cdr cli cracklib crypt cups dbus directfb dri dvb dvd dvdr dvdread eds emboss encode exif fam fbcon ffmpeg firefox flac fortran ftp gdbm gif gnome gpm gstreamer gtk gtk2 gtkhtml hal iconv imagemagick isdnlog java jikes jpeg jpeg2k lcms ldap libg++ mad midi mikmod mmx mng mp3 mpeg ncurses nls nptl nptlonly offensive ogg openal opengl pam pcre perl png ppds pppd python quicktime readline reflection samba sdl session spell spl sse sse2 ssl svg svga tcpd theora threads tiff truetype truetype-fonts type1-fonts unicode usb v4l vorbis win32codecs x264 x86 xine xml xorg xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" CAMERAS="canon ptp2" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" USERLAND="GNU" VIDEO_CARDS="nv nvidia vesa"
Comment 25 Nicolas Schlumberger 2007-04-12 07:08:29 UTC
(In reply to comment #20)
> I pushed a masked ebuild, please test and report back

Built it yesterday, seams to work... 
Portage (default-linux/x86/2006.1/desktop, gcc-4.1.1, glibc-2.5-r0, 2.6.19-beyond41 i686)

one annoyance while compiling:
cc1: warning: command line option "-fvisibility-inlines-hidden" is valid for C++/ObjC++ but not for C

-fwisibility-inlines-hidden is set, but only as CXXFLAGS

Comment 26 Jakub Moc (RETIRED) gentoo-dev 2007-05-14 12:24:58 UTC
(In reply to comment #25)
> -fwisibility-inlines-hidden is set, but only as CXXFLAGS

Well, then stop ricing and everything will work. Closing this bug.