Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 167318 - circular dependencies error when emerging kopete,nmap...
Summary: circular dependencies error when emerging kopete,nmap...
Status: RESOLVED DUPLICATE of bug 152405
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-02-17 11:30 UTC by Nehuen Boffa
Modified: 2007-02-17 11:43 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nehuen Boffa 2007-02-17 11:30:00 UTC
when I try to do emerge kopete, nmap, amarok, libglade, even world, I get a circular dependencies error. 
I tried changing my SYNC address on /etc/make.conf to: rsync.gentoo.org/gentoo-portage, rsync2.d.e.gentoo.org/gentoo-portage, rsync1.fr.gentoo.org/gentoo-portage, rsync.europe.gentoo.org/gentoo-portage  (I'm not sure if those where the exactly addresses), but nothing...

Reproducible: Always

Steps to Reproduce:
1.emerge --sync
2.emerge nmap


Actual Results:  
Calculating dependencies  ..... .... done!
!!! Error: circular dependencies:

('ebuild', '/', 'net-print/foomatic-filters-ppds-20060720', 'merge') depends on
   ('ebuild', '/', 'net-print/foomatic-filters-3.0.20060720', 'merge') (medium)
('ebuild', '/', 'x11-libs/gtk+-2.10.6', 'merge') depends on
   ('ebuild', '/', 'x11-libs/cairo-1.2.4', 'merge') (hard)
   ('ebuild', '/', 'x11-libs/pango-1.14.9', 'merge') (hard)
('ebuild', '/', 'app-text/ghostscript-gpl-8.54', 'merge') depends on
   ('ebuild', '/', 'x11-libs/gtk+-2.10.6', 'merge') (hard)
('ebuild', '/', 'dev-libs/DirectFB-0.9.25.1', 'merge') depends on
   ('ebuild', '/', 'media-libs/libsdl-1.2.11', 'merge') (hard)
('ebuild', '/', 'media-libs/alsa-lib-1.0.14_rc1', 'merge') depends on
   ('ebuild', '/', 'app-doc/doxygen-1.4.7', 'merge') (hard)
('ebuild', '/', 'x11-libs/cairo-1.2.4', 'merge') depends on
   ('ebuild', '/', 'dev-libs/DirectFB-0.9.25.1', 'merge') (hard)
('ebuild', '/', 'media-libs/libsdl-1.2.11', 'merge') depends on
   ('ebuild', '/', 'dev-libs/DirectFB-0.9.25.1', 'merge') (hard)
   ('ebuild', '/', 'media-libs/libcaca-0.99_beta11', 'merge') (hard)
   ('ebuild', '/', 'media-libs/alsa-lib-1.0.14_rc1', 'merge') (hard)
('ebuild', '/', 'net-analyzer/nmap-4.11', 'merge') depends on
   ('ebuild', '/', 'x11-libs/gtk+-2.10.6', 'merge') (hard)
('ebuild', '/', 'virtual/jdk-1.5.0', 'merge') depends on
   ('ebuild', '/', 'dev-java/sun-jdk-1.5.0.10', 'merge') (medium)
('ebuild', '/', 'media-libs/libcaca-0.99_beta11', 'merge') depends on
   ('ebuild', '/', 'app-doc/doxygen-1.4.7', 'merge') (hard)
('ebuild', '/', 'dev-lang/swig-1.3.31', 'merge') depends on
   ('ebuild', '/', 'dev-java/sun-jdk-1.5.0.10', 'merge') (hard)
   ('ebuild', '/', 'virtual/jdk-1.5.0', 'merge') (hard)
('ebuild', '/', 'app-doc/doxygen-1.4.7', 'merge') depends on
   ('ebuild', '/', 'media-gfx/graphviz-2.8-r2', 'merge') (hard)
   ('ebuild', '/', 'app-text/ghostscript-gpl-8.54', 'merge') (hard)
   ('ebuild', '/', 'virtual/ghostscript-0', 'merge') (hard)
('ebuild', '/', 'dev-java/sun-jdk-1.5.0.10', 'merge') depends on
   ('ebuild', '/', 'media-libs/alsa-lib-1.0.14_rc1', 'merge') (medium)
('ebuild', '/', 'net-print/foomatic-filters-3.0.20060720', 'merge') depends on
   ('ebuild', '/', 'app-text/ghostscript-gpl-8.54', 'merge') (hard)
   ('ebuild', '/', 'virtual/ghostscript-0', 'merge') (hard)
('ebuild', '/', 'media-gfx/graphviz-2.8-r2', 'merge') depends on
   ('ebuild', '/', 'dev-java/sun-jdk-1.5.0.10', 'merge') (hard)
   ('ebuild', '/', 'virtual/jdk-1.5.0', 'merge') (hard)
   ('ebuild', '/', 'dev-lang/swig-1.3.31', 'merge') (hard)
('ebuild', '/', 'x11-libs/pango-1.14.9', 'merge') depends on
   ('ebuild', '/', 'x11-libs/cairo-1.2.4', 'merge') (hard)
('ebuild', '/', 'virtual/ghostscript-0', 'merge') depends on
   ('ebuild', '/', 'app-text/ghostscript-gpl-8.54', 'merge') (medium)


Portage 2.1.2-r9 (default-linux/amd64/2006.1, gcc-4.1.1, glibc-2.4-r3, 2.6.19-gentoo-r5 x86_64)
=================================================================
System uname: 2.6.19-gentoo-r5 x86_64 AMD Athlon(tm) 64 Processor 3200+
Gentoo Base System version 1.12.1
Timestamp of tree: Sat, 17 Feb 2007 10:00:01 +0000
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -ftracer -funswitch-loops -fomit-frame-pointer -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/terminfo"
CXXFLAGS="-march=athlon64 -O2 -ftracer -funswitch-loops -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://linuv.uv.es/mirror/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aalib acpi alsa amd64 apm audiofile avi berkdb bitmap-fonts bzlib cdr cli cracklib crypt cups dga directfb dlloader doc dri dvd dvdr dvdread emul-linux-x86 encode fbcon flash fortran gdbm gif gphoto2 gpm gtk gtk2 iconv ipv6 isdnlog java jpeg libcaca libg++ lm_sensors midi mp3 mpeg msn nas ncurses nls nptl nptlonly nvidia oggvorbis opengl oss pam pcre pdflib perl png ppds pppd python qt quicktime readline reflection sdl session sockets spell spl ssl tcpd theora threads tiff truetype truetype-fonts type1-fonts unicode usb v4l videos xorg xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="apm ark ati chips cirrus cyrix dummy fbdev glint i128 i810 mga neomagic nv rendition s3 s3virge savage siliconmotion sis sisusb tdfx tga trident tseng v4l vesa vga via vmware voodoo"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Petteri Räty (RETIRED) gentoo-dev 2007-02-17 11:36:25 UTC
Developer Relations:   	Maintainer of communication guidelines between fellow developers and users
Bugs related to ebuilds belong in 'Gentoo Linux'

How do you suggest we improve this description to prevent people from filing bugs to this Product because a lot of people don't seem to get it?
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2007-02-17 11:43:20 UTC
See Bug 152405, plus reduce your use flags for graphviz temporarily. Nothing we could fix in ebuilds.


*** This bug has been marked as a duplicate of bug 152405 ***