Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 167167 - dev-util/mono-tools-1.2.1 fails: gconf-sharp-2.0 not found
Summary: dev-util/mono-tools-1.2.1 fails: gconf-sharp-2.0 not found
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2007-02-16 09:01 UTC by Greisberger Christophe
Modified: 2007-02-16 14:54 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

config.log (config.log,10.43 KB, text/plain)
2007-02-16 09:06 UTC, Greisberger Christophe
config.log of 2nd machine (config.log,6.57 KB, text/plain)
2007-02-16 10:35 UTC, Greisberger Christophe
Output of "ldd -v /usr/lib/apache2/modules/" (ldd.log,7.78 KB, text/plain)
2007-02-16 13:28 UTC, Greisberger Christophe

Note You need to log in before you can comment on or make changes to this bug.
Description Greisberger Christophe 2007-02-16 09:01:51 UTC
When installing this package, the configuration phase fails with the message:
checking for GTK_SHARP... configure: error: Package requirements (gtk-sharp-2.0 glade-sharp-2.0 gconf-sharp-2.0) were not met:
No package 'gconf-sharp-2.0' found

But gconf-sharp is present on the system.

# emerge -p gconf-sharp

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] dev-dotnet/gconf-sharp-2.16.0  0 kB

Reproducible: Always

Steps to Reproduce:
1. emerge mono-tools

Actual Results:  
>>> Emerging (2 of 12) dev-util/mono-tools-1.2.1 to /
 * mono-tools-1.2.1.tar.gz MD5 ;-) ...                                    [ ok ]
 * mono-tools-1.2.1.tar.gz RMD160 ;-) ...                                 [ ok ]
 * mono-tools-1.2.1.tar.gz SHA1 ;-) ...                                   [ ok ]
 * mono-tools-1.2.1.tar.gz SHA256 ;-) ...                                 [ ok ]
 * mono-tools-1.2.1.tar.gz size ;-) ...                                   [ ok ]
 * checking ebuild checksums ;-) ...                                      [ ok ]
 * checking auxfile checksums ;-) ...                                     [ ok ]
 * checking miscfile checksums ;-) ...                                    [ ok ]
 * checking mono-tools-1.2.1.tar.gz ;-) ...                               [ ok ]
>>> Unpacking source...
>>> Unpacking mono-tools-1.2.1.tar.gz to /var/tmp/portage/mono-tools-1.2.1/work
 * Applying mono-tools-1.1.17-html-renderer-fixes.diff ...                [ ok ]
 * Running eautoreconf in '/var/tmp/portage/mono-tools-1.2.1/work/mono-tools-1.2.1' ...
 * Running aclocal ...                                                    [ ok ]
 * Running autoconf ...                                                   [ ok ]
 * Running automake --add-missing --copy ...                              [ ok ]
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/mono-tools-1.2.1/work/mono-tools-1.2.1 ...
QA Notice: USE Flag 'gtktml' not in IUSE for dev-util/mono-tools-1.2.1
 * econf: updating mono-tools-1.2.1/config.guess with /usr/share/gnuconfig/config.guess
 * econf: updating mono-tools-1.2.1/config.sub with /usr/share/gnuconfig/config.sub
./configure --prefix=/usr --host=i586-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --enable-gtkhtml --enable-mozilla --build=i586-pc-linux-gnu
checking build system type... i586-pc-linux-gnu
checking host system type... i586-pc-linux-gnu
checking target system type... i586-pc-linux-gnu
checking for a BSD-compatible install... /bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for a BSD-compatible install... /bin/install -c
checking for mcs... /usr/bin/mcs
checking for gmcs... /usr/bin/gmcs
checking for mono... /usr/bin/mono
checking for resgen... /usr/bin/resgen
checking for i586-pc-linux-gnu-pkg-config... no
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for NUNIT... yes
checking for MONODOC... yes
checking for GTK_SHARP... configure: error: Package requirements (gtk-sharp-2.0 glade-sharp-2.0 gconf-sharp-2.0) were not met:

No package 'gconf-sharp-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GTK_SHARP_CFLAGS
and GTK_SHARP_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

!!! Please attach the following file when filing a report to
!!! /var/tmp/portage/mono-tools-1.2.1/work/mono-tools-1.2.1/config.log

!!! ERROR: dev-util/mono-tools-1.2.1 failed.
Call stack:, line 1546:   Called dyn_compile, line 937:   Called src_compile
  mono-tools-1.2.1.ebuild, line 64:   Called econf '--enable-gtkhtml' '--enable-mozilla', line 540:   Called die

!!! econf failed
!!! If you need support, post the topmost build error, and the call stack if relevant.

I tried on 3 systems (1 amd64 and 2 x86). The problem is the same on all three.
Comment 1 Greisberger Christophe 2007-02-16 09:03:03 UTC
# emerge --info
Portage 2.1.1-r2 (default-linux/x86/2006.0, gcc-4.1.1, glibc-2.4-r4, 2.6.19-gentoo-r5-ZENON i686)
System uname: 2.6.19-gentoo-r5-ZENON i686 Intel(R) Celeron(R) CPU 2.40GHz
Gentoo Base System release 1.12.9
Last Sync: Thu, 15 Feb 2007 10:50:01 +0000
distcc 2.18.3 i586-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [disabled]
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.31
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
CFLAGS="-O2 -march=pentium-mmx -pipe -fforce-addr -fomit-frame-pointer -funroll-loops -frerun-loop-opt -frerun-cse-after-loop -fexpensive-optimizations -falign-functions=4 -mmmx -msse -mfpmath=sse,387"
CONFIG_PROTECT="/etc /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib/fax /usr/share/X11/xkb /usr/share/config /var/bind /var/spool/fax/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O2 -march=pentium-mmx -pipe -fforce-addr -fomit-frame-pointer -funroll-loops -frerun-loop-opt -frerun-cse-after-loop -fexpensive-optimizations -falign-functions=4 -mmmx -msse -mfpmath=sse,387"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
LINGUAS="fr de en es ar ru hu"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
USE="x86 X Xaw3d a52 aac aalib acl acpi adns afs aim alsa alsa_cards_dummy alsa_cards_emu10k1 alsa_pcm_plugins_adpcm alsa_pcm_plugins_alaw alsa_pcm_plugins_asym alsa_pcm_plugins_copy alsa_pcm_plugins_dmix alsa_pcm_plugins_dshare alsa_pcm_plugins_dsnoop alsa_pcm_plugins_empty alsa_pcm_plugins_extplug alsa_pcm_plugins_file alsa_pcm_plugins_hooks alsa_pcm_plugins_iec958 alsa_pcm_plugins_ioplug alsa_pcm_plugins_ladspa alsa_pcm_plugins_lfloat alsa_pcm_plugins_linear alsa_pcm_plugins_meter alsa_pcm_plugins_mulaw alsa_pcm_plugins_multi alsa_pcm_plugins_null alsa_pcm_plugins_plug alsa_pcm_plugins_rate alsa_pcm_plugins_route alsa_pcm_plugins_share alsa_pcm_plugins_shm alsa_pcm_plugins_softvol apache2 apm arts audiofile bash-completion bcmath berkdb bidi bitmap-fonts blas bonobo bzip2 calendar canna caps cdinstall cdparanoia cdr chasen cjk clamav cli cracklib crypt cscope ctype cups curl curlwrappers dba dbm dbus dbx dga dio directfb dlloader doc dri dts dv dvd dvdr dvdread elibc_glibc encode examples exif expat fam fastcgi fbcon fdftk ffmpeg fftw firefox flac flash flatfile foomaticdb fortran freewnn ftp gb gcj gd gdbm geoip ggi gif ginac glut gmp gnome gnutls gphoto2 gpm graphviz gstreamer gtk gtk2 gtkhtml guile hal hardened hardenedphp howl icc iconv icq idn ieee1394 imagemagick imap imlib inifile innodb input_devices_evdev input_devices_keyboard input_devices_mouse input_devices_vmmouse input_devices_void iodbc ipv6 isdnlog jack java javascript jbig jikes jpeg jpeg2k junit kde kdexdeltas kernel_linux ladcca ladspa lapack lcd_devices_bayrad lcd_devices_cfontz lcd_devices_cfontz633 lcd_devices_glk lcd_devices_hd44780 lcd_devices_lb216 lcd_devices_lcdm001 lcd_devices_mtxorb lcd_devices_ncurses lcd_devices_text lcms ldap lesstif libcaca libg++ libgda libwww linguas_ar linguas_de linguas_en linguas_es linguas_fr linguas_hu linguas_ru lirc lm_sensors lua m17n-lib mad maildir matroska mbox mcal memlimit mhash midi mikmod mime ming mmap mmx mng mnogosearch mozilla mp3 mpeg msession msn mysql mysqli nas ncurses neXt netcdf nls nocd nptl nsplugin ocaml odbc offensive ofx ogg openal opengl osc oscar pam pcntl pcre pda pdf perl php pic pie plotutils png portaudio posix ppds pppd prelude profile python qt4 quicktime readline recode reflection ruby samba sasl scanner sdl seamonkey session sharedext sharedmem shorten simplexml skey slang slp sndfile soap sockets socks5 source sox speex spell spl sqlite sqlite3 sse ssl startup-notification svg svga sysvipc szip tcltk tcpd tetex theora threads tidy tiff tokenizer truetype truetype-fonts type1-fonts unicode usb userland_GNU utf8 vcd vhosts video_cards_fbdev video_cards_nvidia video_cards_vesa videos vorbis wddx win32codecs wmf wxwindows xface xine xinerama xinetd xml xorg xosd xpm xprint xsl xv xvid yahoo zlib"
Comment 2 Greisberger Christophe 2007-02-16 09:06:13 UTC
Created attachment 110363 [details]
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2007-02-16 09:54:48 UTC
Do you have /usr/lib/pkgconfig/gconf-sharp-2.0.pc? If not, re-emerge dev-dotnet/gconf-sharp and try again.
Comment 4 Greisberger Christophe 2007-02-16 10:15:01 UTC
Yes, I have it.

# ls -al /usr/lib/pkgconfig/gconf-sharp-2.0.pc
-rw-r--r-- 1 root root 283 Feb 13 18:43 /usr/lib/pkgconfig/gconf-sharp-2.0.pc

But I just tried to reinstall gconf-sharp and this fixed the problem on 1 machine.

On the 2nd one, the compilation of gconf-sharp failed, that could be the cause of the problem (error CS0006: cannot find metadata file `//usr/lib/mono/gtk-sharp-2.0/gnome-sharp.dll'). I'll try to reemerge gtk-sharp and see if it fixes the problem.

And well, on the 3rd one, some *-sharp packages seemed to be empty. I reemerge them all right now.

Comment 5 Greisberger Christophe 2007-02-16 10:35:43 UTC
Created attachment 110367 [details]
config.log of 2nd machine
Comment 6 Greisberger Christophe 2007-02-16 10:36:27 UTC
Comment on attachment 110367 [details]
config.log of 2nd machine

oups, wrong bug
Comment 7 Greisberger Christophe 2007-02-16 11:45:03 UTC
Well, 3rd fixed.
I'll reemerge all sharp package on the remaining system.
Strange problems, really :/
Comment 8 Greisberger Christophe 2007-02-16 12:33:18 UTC
Well, that was is.
I don't understand why revdep-rebuild didn't reemerge them.
Comment 9 Greisberger Christophe 2007-02-16 13:28:06 UTC
Created attachment 110378 [details]
Output of "ldd -v /usr/lib/apache2/modules/"
Comment 10 Greisberger Christophe 2007-02-16 13:29:08 UTC
Comment on attachment 110378 [details]
Output of "ldd -v /usr/lib/apache2/modules/"

Again wrong bug.
I hate this bugtracker :((((
Comment 11 Jakub Moc (RETIRED) gentoo-dev 2007-02-16 14:54:46 UTC
Please stop this noise.