Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 167101 - net-wireless/ipw3945d-1.7.22-r4 doesn't find my hardware
Summary: net-wireless/ipw3945d-1.7.22-r4 doesn't find my hardware
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Mobile Herd (OBSOLETE)
Depends on:
Blocks: ipw3945-tracker 197806
  Show dependency tree
Reported: 2007-02-15 19:44 UTC by Daniel Barkalow
Modified: 2007-12-05 17:03 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---

.config (config-2.6.19-r5,39.40 KB, text/plain)
2007-02-16 04:01 UTC, Daniel Barkalow
strace from sudo /sbin/ipw3945d (ipw3945-current-strace,4.34 KB, text/plain)
2007-02-16 04:02 UTC, Daniel Barkalow

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Barkalow 2007-02-15 19:44:37 UTC
With ipw3945-1.2.0 and kernel 2.6.19-r5 (deprecated sysfs stuff off), I get an error when trying to run /sbin/ipw3945d as root by hand that it can't find my hardware. Oddly, strace shows that it seems to look in the driver directory for a file "cmd" (which isn't there), look in the device directory for this file (which it finds), read some data, and then report that the hardware wasn't found. Oddly, the older ipw3945d, which is not allowed by the DEPEND on ipw3945-1.2.0, seems to work fine (although I've got an unrelated problem with ipw3945-1.2.0).

Reproducible: Always
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-02-15 21:30:19 UTC
Reopen with some logs output and kernel .config, we really can't guess.
Comment 2 Daniel Barkalow 2007-02-16 04:01:50 UTC
Created attachment 110357 [details]
Comment 3 Daniel Barkalow 2007-02-16 04:02:34 UTC
Created attachment 110358 [details]
strace from sudo /sbin/ipw3945d
Comment 4 Daniel Barkalow 2007-02-16 04:04:03 UTC
Added .config and strace
Comment 5 Christian Heim (RETIRED) gentoo-dev 2007-05-20 17:18:24 UTC
Could you please try it w/ ipw3945-1.2.1 and reopen this bug if it still doesn't recognize your hardware ?
Comment 6 Daniel Barkalow 2007-05-21 03:24:33 UTC
Everything seems to be the same with ipw3945-1.2.1; ipw3945d-1.7.22 doesn't work, and ipw3945d-1.7.18 works fine. I might be able to identify what's going wrong if I had an strace of it working or how it expects the sysfs stuff to look.
Comment 7 Daniel Barkalow 2007-11-02 18:32:07 UTC
I've actually now changed to iwlwifi, so this is no longer particularly interesting for me, although I'd still be happy to test things if it would help.
Comment 8 Jan Kundrát (RETIRED) gentoo-dev 2007-12-05 17:03:52 UTC
If this still doesn't work with net-wireless/ipw3945-ucode-1.14.2, net-wireless/ipw3945d-1.7.22-r5 and net-wireless/ipw3945-1.2.2, please report this bug upstream to , but I guess they will ask you to stick with working iwlwifi.

Thanks for your report, but we can't do anything about possible bug in real driver, sorry.