Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 166955 - Corrupted page table while generating UTF-8 locales.
Summary: Corrupted page table while generating UTF-8 locales.
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: High critical (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
Depends on:
Reported: 2007-02-15 03:26 UTC by Robert Gill
Modified: 2007-03-24 18:31 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

emerge --info (,3.13 KB, text/plain)
2007-02-15 03:28 UTC, Robert Gill
lspci (lspci.txt,1.78 KB, text/plain)
2007-02-15 03:29 UTC, Robert Gill
kernel config (.config,28.22 KB, text/plain)
2007-02-15 03:29 UTC, Robert Gill

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Gill 2007-02-15 03:26:58 UTC
Since upgrading to glibc-2.5 my system has been crashing with a Corrupted page table error when trying to generate UTF-8 locales.  This does not occur with other locales.  Sometimes the system recovers, sometimes it locks up completely.  I've tried it with kernels gentoo-sources-2.6.17-r8 and gentoo-sources-2.6.18-r6 with the same results.  I'm going to try rebuild one of those kernels without SMP support.  I'll post the results in another comment.

Reproducible: Always

Steps to Reproduce: locale-gen with any UTF-8 locale specified in /etc/locale.gen

Actual Results:  
locale-gen segfaults or system locks up

Expected Results:  
locales should be generated.

error log:
Feb 14 19:08:27 onyx localedef: Corrupted page table at address 2b63e7a51000
Feb 14 19:08:27 onyx PGD 64a49067 PUD 683ea067 PMD 3fb78067 PTE 800062003f78a067
Feb 14 19:08:27 onyx Bad pagetable: 000f [1] PREEMPT SMP 
Feb 14 19:08:27 onyx CPU 1 
Feb 14 19:08:27 onyx Modules linked in: vmnet parport_pc parport vmmon nvidia
Feb 14 19:08:27 onyx Pid: 5791, comm: localedef Tainted: PF     2.6.17-gentoo-r8 #1
Feb 14 19:08:27 onyx RIP: 0033:[<00002b63e6a4566a>] [<00002b63e6a4566a>]
Feb 14 19:08:27 onyx RSP: 002b:00007fffc41f0f18  EFLAGS: 00010216
Feb 14 19:08:27 onyx RAX: 00002b63e6c0e040 RBX: 0000000000083afe RCX: 000000000000ca0f
Feb 14 19:08:27 onyx RDX: 00000000014137b0 RSI: 0000000000000000 RDI: 00002b63e7a50fc0
Feb 14 19:08:27 onyx RBP: 00002b63e842f040 R08: 0000000000080000 R09: 0000000000000000
Feb 14 19:08:27 onyx R10: 0000000000000022 R11: 0000000000000246 R12: 00000000005496e8
Feb 14 19:08:27 onyx R13: 00000000000019e7 R14: 0000000000041d73 R15: 00002b63e842f040
Feb 14 19:08:27 onyx FS:  00002b63e6c0d6d0(0000) GS:ffff810002f2a4c0(0000) knlGS:00000000f7c6d6b0
Feb 14 19:08:27 onyx CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
Feb 14 19:08:27 onyx CR2: 00002b63e7a51000 CR3: 000000006e473000 CR4: 00000000000006e0
Feb 14 19:08:27 onyx Process localedef (pid: 5791, threadinfo ffff810062c1e000, task ffff81007f475900)
Feb 14 19:08:27 onyx 
Feb 14 19:08:27 onyx RIP [<00002b63e6a4566a>] RSP <00007fffc41f0f18>
Comment 1 Robert Gill 2007-02-15 03:28:05 UTC
Created attachment 110222 [details]
emerge --info
Comment 2 Robert Gill 2007-02-15 03:29:02 UTC
Created attachment 110224 [details]
Comment 3 Robert Gill 2007-02-15 03:29:37 UTC
Created attachment 110225 [details]
kernel config
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-02-15 07:49:00 UTC
Try with 2.6.20 and report back please.
Comment 5 Robert Gill 2007-02-23 06:36:23 UTC
Same issue with 2.6.20.  I think it may be a hardware problem, though I'm not exactly sure what.  Memtest86 and a few hardware stress test utilities come up clean (app-benchmarks/stress and prime95).  I found it doesn't just occur with locale-gen though.  It's also happened while sorting or filtering large newsgroups in pan.
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2007-02-23 08:05:27 UTC
Comment 7 Daniel Drake (RETIRED) gentoo-dev 2007-02-24 17:53:25 UTC
Your kernel is tainted. Please reproduce this without the nvidia and vmware modules loaded (and make sure they weren't loaded then unloaded, it has to be clean) and post a new crash dump.

Also make sure your kernel is compiled with CONFIG_KALLSYMS and that you post the crash from dmesg as opposed to syslog.
Comment 8 Daniel Drake (RETIRED) gentoo-dev 2007-03-10 04:47:19 UTC
see comment #7
Comment 9 Robert Gill 2007-03-24 18:31:20 UTC
Sorry, I was out of town for a while.  Anyways, I replaced my motherboard which solved the problem.