Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 166784 - dev-ruby/rubygems-0.9.0-r2 will not work as root.
Summary: dev-ruby/rubygems-0.9.0-r2 will not work as root.
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Ruby Team
Depends on:
Reported: 2007-02-14 03:46 UTC by Keith Gable
Modified: 2007-04-01 03:33 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Keith Gable 2007-02-14 03:46:14 UTC
I cannot get rubygems 0.9.0-r2 to work as root. It tells me that it cannot find the gem index. I checked gem environment and it looks peachy. Downgrading to 0.8.11-r6 works fine.

If it helps, I tried upgrading to 0.9.0 from 0.8.11-r5

Reproducible: Always

Steps to Reproduce:

keith keith # emerge --info
Portage 2.1.2-r9 (default-linux/x86/2006.0, gcc-4.1.1, glibc-2.5-r0, 2.6.18-gentoo-r3 i686)
System uname: 2.6.18-gentoo-r3 i686 AMD Athlon(tm) 64 Processor 3500+
Gentoo Base System version 1.12.6
Timestamp of tree: Thu, 08 Feb 2007 16:20:01 +0000
ccache version 2.4 [disabled]
dev-java/java-config: 1.3.7, 2.0.31-r3
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
CFLAGS="-O2 -march=athlon-xp -pipe -msse2 -msse3 -fomit-frame-pointer"
CONFIG_PROTECT="/etc /opt/openjms/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O2 -march=athlon-xp -pipe -msse2 -msse3 -fomit-frame-pointer"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
LINGUAS="en en_US en_GB"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/portage/local/layman/xeffects /usr/portage/local/layman/hamsterrific /usr/portage/local/layman/zugaina /usr/portage/local/layman/musicbrainz"
USE="3dnow 3dnowext X aac aiglx akode alsa apache2 apm arts avahi avalon berkdb bitmap-fonts bluetooth bzip2 cairo cdr cli cracklib crypt cups dbus dlloader doc dri dvd dvdr eds emboss encode esd ffmpeg firefox flac foomaticdb fortran fuse gdbm gif glitz gnokii gnome gphoto2 gpm gstreamer gtk gtk2 hal ical iconv ieee1394 imlib irda isdnlog java javamail jbig jikes jingle jpeg jpeg2k kde lame libg++ libnotify libwww lm_sensors logitech-mouse lzo mad midi mikmod mmx mmxext mono motif mp3 mpeg mysql ncurses nls nptl nptlonly nsplugin nvidia ogg openexr opengl oss pam pcre perl png povray pppd python qt3 qt4 quicktime rdesktop readline reflection rle samba sasl scanner sdl session slp sms spell spl sse sse2 ssl startup-notification svg tcpd theora tiff truetype truetype-fonts type1-fonts udev usb vorbis wifi win32codecs x264 x86 xcomposite xine xml xorg xpm xprint xscreensaver xv zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="g15 ncurses graphlcd" LINGUAS="en en_US en_GB" USERLAND="GNU" VIDEO_CARDS="nvidia"
Comment 1 Keith Gable 2007-02-14 03:46:43 UTC
I forgot to mention. It works FINE as my normal user (except that I can't install anything).
Comment 2 Nguyen Thai Ngoc Duy (RETIRED) gentoo-dev 2007-02-15 14:19:57 UTC
I can't reproduce this. What was the actual error messages? (and maybe the gem package you tried to install so that I can mimic your environment)
Does it help if you remove /usr/lib/ruby/gems/1.8/source_cache? It's safe doing so.
Comment 3 Nguyen Thai Ngoc Duy (RETIRED) gentoo-dev 2007-03-31 18:13:50 UTC
so long, no reply
Comment 4 Keith Gable 2007-04-01 03:33:06 UTC
This bug no longer occurs after latest updates (I think maybe it was rake).