Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 166737 - media-video/vlc-0.8.6-r1 fails with error "Missing header file ffmpeg/avcodec.h"
Summary: media-video/vlc-0.8.6-r1 fails with error "Missing header file ffmpeg/avcodec.h"
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-02-13 21:22 UTC by Roger Larsson
Modified: 2007-02-13 23:50 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Make configuration (make.conf,753 bytes, text/plain)
2007-02-13 21:25 UTC, Roger Larsson
Details
Build log (build.log,26.01 KB, text/plain)
2007-02-13 21:27 UTC, Roger Larsson
Details
Configure log (config.log,304.35 KB, text/plain)
2007-02-13 21:31 UTC, Roger Larsson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roger Larsson 2007-02-13 21:22:26 UTC
I have had no problem emerging vlc 0.8.4 but when I tried to emerge 0.8.5 it failed and I get the same error emerging 0.8.6. The build seems to find FFMPEG but not ffmpeg/avcodec.h

Reproducible: Always

Steps to Reproduce:
1. emerge vlc

Actual Results:  
ERROR: media-video/vlc-0.8.6-r1 failed.

Expected Results:  
vlc-0.8.6 installed

The system is an up to date Gentoo 2006, 
emerge --sync
emerge --update --deep --newuse world
Comment 1 Roger Larsson 2007-02-13 21:25:47 UTC
Created attachment 110107 [details]
Make configuration

make.profile -> /usr/portage/profiles/default-linux/x86/2006.1/desktop/
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2007-02-13 21:26:49 UTC
Kindly review http://bugs.gentoo.org/page.cgi?id=fields.html#bug_severity; re-emerge ffmpeg.

If it doesn't work then, post emerge -pv ffmpeg output, emerge --info, the error output you get when compiling vlc and reopen then.
Comment 3 Roger Larsson 2007-02-13 21:27:57 UTC
Created attachment 110114 [details]
Build log
Comment 4 Roger Larsson 2007-02-13 21:31:35 UTC
Created attachment 110115 [details]
Configure log
Comment 5 Roger Larsson 2007-02-13 21:52:19 UTC
roglas etc # emerge -pv ffmpeg

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] media-video/ffmpeg-0.4.9_p20070129  USE="a52 aac doc encode mmx ogg oss sdl threads truetype v4l vorbis xvid zlib (-altivec) -amr -debug -dts -ieee1394 -imlib -network -test -theora -x264" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Comment 6 Roger Larsson 2007-02-13 21:53:42 UTC
emerge --info
Portage 2.1.2-r9 (default-linux/x86/2006.1/desktop, gcc-4.1.1, glibc-2.5-r0, 2.6.18-gentoo-r6 i686)
=================================================================
System uname: 2.6.18-gentoo-r6 i686 Intel(R) Pentium(R) M processor 1.60GHz
Gentoo Base System version 1.12.6
Timestamp of tree: Mon, 12 Feb 2007 20:50:01 +0000
dev-java/java-config: 1.3.7, 2.0.31
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium-m -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=pentium-m -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://ds.thn.htu.se/linux/gentoo "
LANG="sv_SE"
LC_ALL="sv_SE"
LINGUAS="sv us en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acpi alsa arts bash-completion berkdb bindist bitmap-fonts bluetooth bzip2 cairo cdr cli cracklib crypt cups dbus dlloader doc dri dvd dvdr eds emboss encode esd examples fam fbcon ffmpeg firefox flac fortran ftp gdbm gif gnome gpm gstreamer gtk hal iconv idn ipv6 isdnlog java javascript jpeg kde ldap libg++ lirc lm_sensors mad mbox midi mikmod mmx mono mp3 mpeg mplayer msn mysql ncurses nls nptl nptlonly nsplugin nvidia offensive ogg opengl oss pam pcmcia pcre pda pdf perl pmu png ppds pppd profile python qt3 qt4 quicktime readline reflection samba scanner sdl session sharedmem soap source spell spl sse sse2 ssl svga tcpd tiff truetype truetype-fonts type1-fonts unicode usb v4l vcd vorbis wifi win32codecs x86 xml xorg xosd xsl xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="sv us en" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 7 Roger Larsson 2007-02-13 21:58:10 UTC
checking for FFMPEG... yes
checking ffmpeg/avcodec.h usability... no
checking ffmpeg/avcodec.h presence... no
checking for ffmpeg/avcodec.h... no
configure: error: Missing header file ffmpeg/avcodec.h.

!!! Please attach the following file when filing a report to bugs.gentoo.org:
!!! /var/tmp/portage/media-video/vlc-0.8.6-r1/work/vlc-0.8.6/config.log

!!! ERROR: media-video/vlc-0.8.6-r1 failed.
Call stack:
  ebuild.sh, line 1614:   Called dyn_compile
  ebuild.sh, line 971:   Called qa_call 'src_compile'
  environment, line 3983:   Called src_compile
  vlc-0.8.6-r1.ebuild, line 182:   Called econf '--disable-altivec' '--enable-sout' '--enable-httpd' '--enable-gnutls' '--enable-v4l' '--enable-cdda' '--enable-cddax' '--disable-libcddb' '--enable-vcd' '--enable-vcdx' '--disable-dvb' '--disable-pvr' '--enable-ogg' '--enable-mkv' '--enable-flac' '--enable-vorbis' '--enable-theora' '--enable-x11' '--enable-xvideo' '--disable-xinerama' '--enable-glx' '--enable-opengl' '--enable-freetype' '--enable-fribidi' '--enable-dvdread' '--enable-dvdplay' '--enable-dvdnav' '--enable-fb' '--enable-svgalib' '--disable-glide' '--disable-aa' '--disable-caca' '--enable-oss' '--enable-esd' '--enable-arts' '--enable-alsa' '--enable-wxwidgets' '--enable-ncurses' '--enable-xosd' '--enable-lirc' '--enable-mad' '--enable-a52' '--enable-dts' '--enable-libmpeg2' '--disable-ggi' '--disable-glide' '--enable-sdl' '--disable-sdl-image' '--enable-png' '--enable-libxml2' '--enable-smb' '--disable-daap' '--disable-corba' '--disable-mod' '--disable-speex' '--disable-shout' '--disable-rtsp' '--disable-realrtsp' '--enable-loader' '--disable-skins2' '--enable-hal' '--disable-bonjour' '--disable-upnp' '--disable-optimize-memory' '--disable-notify' '--disable-mpc' '--enable-ffmpeg' '--disable-faad' '--disable-jack' '--disable-dv' '--disable-libvc1' '--disable-snapshot' '--disable-growl' '--disable-pth' '--disable-portaudio' '--disable-x264' '--disable-libtar' '--disable-optimizations' '--enable-utf8' '--enable-libtool' '--enable-mozilla' 'XPIDL=/usr/lib/mozilla-firefox' 'MOZILLA_CONFIG=/usr/lib/mozilla-firefox/firefox-config' 'WX_CONFIG=/usr/lib/wx/config/gtk2-unicode-release-2.6' '--enable-live555' '--with-live555-tree=/usr/lib/live'
  ebuild.sh, line 577:   Called die

!!! econf failed
Comment 8 Roger Larsson 2007-02-13 22:05:46 UTC
Performed:

emerge ffmpeg 
emerge --info
emerge --pv ffmpeg
emerge vlc
Comment 9 Alexis Ballier gentoo-dev 2007-02-13 22:13:34 UTC
In file included from conftest.c:226:
/usr/local/include/ffmpeg/avcodec.h:14:20: error: common.h: No such file or directory
/usr/local/include/ffmpeg/avcodec.h:15:22: error: rational.h: No such file or directory
In file included from conftest.c:226:
/usr/local/include/ffmpeg/avcodec.h:1195: error: expected specifier-qualifier-list before 'AVRational'
/usr/local/include/ffmpeg/avcodec.h:1754: error: expected ':', ',', ';', '}' or '__attribute__' before '*' token


seems like you have a part of ffmpeg installed in /usr/local
Comment 10 Alexis Ballier gentoo-dev 2007-02-13 22:19:57 UTC
I meant : please remove it or make sure it's not broken and reopen if it still happens.
Comment 11 Roger Larsson 2007-02-13 22:50:57 UTC
Tnank you! Had header files from two years ago in /usr/local/include which I had forgot about. I did not think about it because 0.8.4 of gentoo-vlc-package built without problem
Comment 12 Alexis Ballier gentoo-dev 2007-02-13 22:56:00 UTC
btw you should really be careful about that, sometimes this will compile perfectly but you will have problems at runtime like :
http://bugs.cinelerra.org/show_bug.cgi?id=381