Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 165989 - xfce-extra/xfce4-battery-0.5.0: No display of temperature or fan status
Summary: xfce-extra/xfce4-battery-0.5.0: No display of temperature or fan status
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: XFCE Team
URL: http://bugzilla.xfce.org/show_bug.cgi...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-02-08 20:49 UTC by Ulrich Müller
Modified: 2010-12-27 16:34 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Proposed bugfix (patch for panel-plugin/libacpi.c) (batt.patch,1.30 KB, patch)
2007-02-08 20:50 UTC, Ulrich Müller
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ulrich Müller gentoo-dev 2007-02-08 20:49:45 UTC
On a HP Compaq nc6120 laptop, the battery plugin does neither display the
temperature nor the fan status.

Attached patch should fix the problem.

Reproducible: Always
Steps to Reproduce:
1. Start battery panel plugin
Actual Results:  
Temperature and fan status are not shown.

Expected Results:  
Temperature and fan status being displayed.

Problem has been reported upstream, see URL.
Comment 1 Ulrich Müller gentoo-dev 2007-02-08 20:50:36 UTC
Created attachment 109584 [details, diff]
Proposed bugfix (patch for panel-plugin/libacpi.c)
Comment 2 Samuli Suominen gentoo-dev 2007-02-08 20:54:17 UTC
Thanks for reporting but likely we will wait what upstream does before applying this patch. If they apply it, we will also. Can you ping on this bug when upstream responses on that bug in case I happen to miss it.
Comment 3 Ulrich Müller gentoo-dev 2007-02-08 21:10:49 UTC
(In reply to comment #2)
> Thanks for reporting but likely we will wait what upstream does before
> applying this patch.

I hope that they will be faster than with my last panel-plugin bug report (which took them half a year :-( ).

Please note that this bug should be present on _any_ (ACPI) hardware: The plugin tries to fopen a file "/proc/acpi/fan/*/state" which cannot work, since fopen of course doesn't expand wildcards. This is a regression from the 0.3.0 version.

> Can you ping on this bug when upstream responses on that bug in case
> I happen to miss it.
Comment 4 Samuli Suominen gentoo-dev 2007-02-09 14:46:15 UTC
> I hope that they will be faster than with my last panel-plugin bug report
> (which took them half a year :-( ).

After short discussion with upstream I've applied this patch in CVS.

Thanks for reporting.
Comment 5 Ulrich Müller gentoo-dev 2010-12-27 16:19:42 UTC
(In reply to comment #3)
> I hope that they will be faster than with my last panel-plugin bug report
> (which took them half a year :-( ).

Yeah, that was way too optimistic. Patch has been applied upstream, after almost 4 years.
Comment 6 Samuli Suominen gentoo-dev 2010-12-27 16:34:10 UTC
(In reply to comment #5)
> (In reply to comment #3)
> > I hope that they will be faster than with my last panel-plugin bug report
> > (which took them half a year :-( ).
> 
> Yeah, that was way too optimistic. Patch has been applied upstream, after
> almost 4 years.
> 

between this time there has been no upstream maintainer. 
the guy who finally applied the patch, is a general xfce goodies maintainer, so battery will be on it's own again...