Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 1658 - gdm takes ownership over sound and nvidia files in /dev
Summary: gdm takes ownership over sound and nvidia files in /dev
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Martin Schlemmer (RETIRED)
Depends on:
Reported: 2002-04-10 16:49 UTC by Artur Brodowski
Modified: 2004-05-08 09:24 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Artur Brodowski 2002-04-10 16:49:07 UTC
could anyone try to reproduce this:
when i log on in gdm as a normal user, /dev/nvidia*, /dev/console and /dev/snd*
are not owned by root anymore, but by this user (first one that logs on). i
tried to chown root manually (back to root), but again, after restarting gdm and
logging on, ownership changes. this is not fixed when i close a gnome-session
kernel 2.4.19-r1, alsa sound drivers, nvidia 1.0-2880
portage version 1.8.19
gdm, gnome-things are also the newest ones
this might be makedev problem, not gnome's, i'm no hacker to figure it out.
Comment 1 Artur Brodowski 2002-04-26 13:16:21 UTC
i guess the real problem with this issue shows up when many users log on the
same machine.first login gives the rights/ownership to the user so for him
desktop works fine. but after his logout rights are not back to normal
(root/audio), so next user cannot use sound (/dev/mixer, /dev/dsp and others
won't open). for single user this is no real bug, unfortunately i share my dektop :(
this rights switch was alos reproduced on mckennedy's box, i talked to him on
#gentoo the other day.
Comment 2 Artur Brodowski 2002-05-10 05:12:15 UTC
solved. the problem was not actually on gdm/gnome-session side, it was a libpam
upgrade that caused it (the rights for 'sound' in /etc/security/console.pref
changed from 660 to 600). i edited the file, everything is back to
Comment 3 AJ Armstrong 2004-05-08 08:59:28 UTC
Is this actually fixed?  I just ran into the problem on a box with sys-libs/pam-0.77 - the permissions for sound in /etc/security/console.perms are still 600.
Comment 4 AJ Armstrong 2004-05-08 09:24:27 UTC
Never mind.  Just ran across bug 31877, which seems to be closer to the actual problem, and is still open.