Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 16556 - "emerge rsync" is ambiguous, differentiate between "net-misc/rsync" and "emerge sync"?
Summary: "emerge rsync" is ambiguous, differentiate between "net-misc/rsync" and "emer...
Status: RESOLVED DUPLICATE of bug 2365
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Documentation (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Nicholas Jones (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-02-28 08:41 UTC by Jonathan Hitchcock
Modified: 2011-10-30 22:32 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Hitchcock 2003-02-28 08:41:57 UTC
In order to install/upgrade the "rsync" package, one needs to fully specify 
the package name:  "emerge net-misc/rsync", because otherwise portage 
synchronises its portage tree with the rsync server (a la "emerge sync").  
Since, as far as I can tell, most people use "emerge sync" when they want to 
do this, and it's more intuitive, and more general (if we switch to CVS, for 
example, and it is what is used in "emerge --help", and in the installation 
manual, would it not be a Good Thing (tm) if we lost the "rsync" alias to 
"sync"?
Comment 1 SpanKY gentoo-dev 2003-02-28 16:18:48 UTC

*** This bug has been marked as a duplicate of 2365 ***