Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 164659 - Add 2.6.19 kernel support to net-wireless/at76c503a
Summary: Add 2.6.19 kernel support to net-wireless/at76c503a
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Mobile Herd (OBSOLETE)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: kernel-2.6.19
  Show dependency tree
 
Reported: 2007-01-31 06:22 UTC by Sonny Lander
Modified: 2007-05-09 19:22 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Version check (at76c503a-0.14-kernel_version_check.patch,1.12 KB, text/plain)
2007-02-10 04:40 UTC, Steev Klimaszewski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sonny Lander 2007-01-31 06:22:45 UTC
The net-wireless/at76c503a module requires linux/config.h from the kernel source that was depreciated and removed.

Reproducible: Always

Steps to Reproduce:
1.emerge at76c503a
Comment 1 Steev Klimaszewski gentoo-dev 2007-02-10 04:40:42 UTC
Created attachment 109700 [details]
Version check

Try this patch, I am not sure if its affected by the work queue changes with 2.6.20 - and I don't have the hardware handy, but I figured I would write the version check patch at least - this patch should apply cleanly to beta1, and also work with kernels 2.6.19 and below (at least)
Comment 2 Sonny Lander 2007-02-15 16:59:56 UTC
I did something similar by hand to make it compile for me, but I am trying out your patch and cant get it to apply...

I tried to use this in the ebuild:

src_unpack() {
        epatch ${FILESDIR}/${P}-version-check.patch
}

I'm sure it is my fault but it is complaining that it can't find the files to patch.
Comment 3 Emmanuel Rosa 2007-02-22 22:17:31 UTC
I also tried to have the ebuild apply the patch and failed. The ebuild seems to completely bypass unpack(), but I don't know how. I wonder if it has anything to do with the linux-mod eclass. But I looked at the eclass code and didn't find anything that seems to override the default behavior of unpack(). I was going to submit the bug upstream, since that's where I think it belongs, but ... I don't have an account at berlios. Yeah, I know. Laziness kicked in.
Comment 4 Sonny Lander 2007-03-16 16:15:31 UTC
ping

The patch easly works when i do it by hand, if someone could add it to the tree it would be nice :)
Comment 5 Emmanuel Rosa 2007-04-01 16:37:57 UTC
I've added a bug report for a CVS ebuild (http://bugs.gentoo.org/show_bug.cgi?id=173034) It compiles and runs with my 2.6.20 kernel. The only thing broken now is Xorg :(

Comment 6 Stefan Schweizer (RETIRED) gentoo-dev 2007-05-09 19:22:14 UTC
thank you patch and cvs ebuild in portage