Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 164586 - sys-libs/pam-0.78-r5 has dependencies in /usr again
Summary: sys-libs/pam-0.78-r5 has dependencies in /usr again
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: PAM Gentoo Team (OBSOLETE)
Depends on: 185203
  Show dependency tree
Reported: 2007-01-30 18:48 UTC by Tim Ryan
Modified: 2007-11-04 15:39 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Tim Ryan 2007-01-30 18:48:00 UTC
I get ERROR: pam_access have dependencies in /usr. This seems to be caused by sys-libs/glibc-2.4-r4 since it installs a /usr/lib/ link. If I remove this link I get:
i686-pc-linux-gnu-gcc -Wall -Wwrite-strings     -Wpointer-arith -Wcast-qual -Wcast-align        -Wstrict-prototypes -Wmissing-prototypes     -Wnested-externs -Winline -Wshadow -Dlinux -I/var/tmp/portage/pam-0.78-r5/work/Linux-PAM-0.78/include -Wl,-L/var/tmp/portage/pam-0.78-r5/work/Linux-PAM-0.78/lib -O2 -march=pentium4 -pipe   -I./include -I/var/tmp/portage/pam-0.78-r5/work/Linux-PAM-0.78/libpam/include -I/var/tmp/portage/pam-0.78-r5/work/Linux-PAM-0.78 -I/var/tmp/portage/pam-0.78-r5/work/Linux-PAM-0.78/libpamc/include  -fPIC -I../pammodutil/include -o pam_tally dynamic/pam_tally_app.o -L/var/tmp/portage/pam-0.78-r5/work/Linux-PAM-0.78/lib  -L../pammodutil -lpammodutil -L../../libpam -lpam
../../libpam/ undefined reference to `dlerror'
../../libpam/ undefined reference to `dlclose'
../../libpam/ undefined reference to `dlopen'
../../libpam/ undefined reference to `dlsym'
collect2: ld returned 1 exit status

isisdvp1 lib # emerge --info
Portage 2.1.1-r2 (default-linux/x86/2006.1/desktop, gcc-4.1.1, glibc-2.4-r4, 2.6.18-gentoo-r4 i686)
System uname: 2.6.18-gentoo-r4 i686 Intel(R) Pentium(R) 4 CPU 3.06GHz
Gentoo Base System version 1.12.6
Last Sync: Tue, 30 Jan 2007 16:59:01 +0000
ccache version 2.4 [enabled]
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.31-r3
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
CFLAGS="-O2 -march=pentium4 -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=pentium4 -pipe"
FEATURES="autoconfig ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
USE="x86 X aim alsa alsa_cards_ali5451 alsa_cards_als4000 alsa_cards_atiixp alsa_cards_atiixp-modem alsa_cards_bt87x alsa_cards_ca0106 alsa_cards_cmipci alsa_cards_emu10k1x alsa_cards_ens1370 alsa_cards_ens1371 alsa_cards_es1938 alsa_cards_es1968 alsa_cards_fm801 alsa_cards_hda-intel alsa_cards_intel8x0 alsa_cards_intel8x0m alsa_cards_maestro3 alsa_cards_trident alsa_cards_usb-audio alsa_cards_via82xx alsa_cards_via82xx-modem alsa_cards_ymfpci alsa_pcm_plugins_adpcm alsa_pcm_plugins_alaw alsa_pcm_plugins_asym alsa_pcm_plugins_copy alsa_pcm_plugins_dmix alsa_pcm_plugins_dshare alsa_pcm_plugins_dsnoop alsa_pcm_plugins_empty alsa_pcm_plugins_extplug alsa_pcm_plugins_file alsa_pcm_plugins_hooks alsa_pcm_plugins_iec958 alsa_pcm_plugins_ioplug alsa_pcm_plugins_ladspa alsa_pcm_plugins_lfloat alsa_pcm_plugins_linear alsa_pcm_plugins_meter alsa_pcm_plugins_mulaw alsa_pcm_plugins_multi alsa_pcm_plugins_null alsa_pcm_plugins_plug alsa_pcm_plugins_rate alsa_pcm_plugins_route alsa_pcm_plugins_share alsa_pcm_plugins_shm alsa_pcm_plugins_softvol arts berkdb bitmap-fonts cairo caps cdr cli cracklib crypt cups dbus divx dlloader dri dvd dvdr elibc_glibc emboss encode esd exif fam ffmpeg firefox font-server fortran gdbm gif gimpprint glitz gmedia gnome gpm gstreamer gtk hal iconv input_devices_keyboard input_devices_mouse isdnlog java javascript jpeg kde kernel_linux kqemu lcd_devices_bayrad lcd_devices_cfontz lcd_devices_cfontz633 lcd_devices_glk lcd_devices_hd44780 lcd_devices_lb216 lcd_devices_lcdm001 lcd_devices_mtxorb lcd_devices_ncurses lcd_devices_text ldap libg++ mad midi mikmod mozbranding mp3 mpeg ncurses nls nptl nptlonly nsplugin nvidia offensive ofx ogg openal opengl oracle oss pam pcre pdf perl png ppds pppd python qt3 quicktime readline real realmedia reflection sdl session socks5 spell spl ssl svg tcpd truetype truetype-fonts type1-fonts udev userland_GNU video_cards_fglrx video_cards_radeon videos vorbis win32codecs wma wmp xml xorg xv zlib"

I have no problem with any other package.
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2007-01-30 19:05:28 UTC
Mike, why a link rather than a ldscript?
Comment 2 SpanKY gentoo-dev 2007-01-31 04:54:58 UTC
that's how glibc has always worked ... it installs symlinks and since it's never been a problem, i've never bothered changing it
Comment 3 Tim Ryan 2007-01-31 12:46:11 UTC
I don't think the problem is that there is a symlink, but that it is in /usr. PAM does not want any dependencies in /usr for some reason, and glibc puts one there.
Comment 4 SpanKY gentoo-dev 2007-02-01 04:36:07 UTC
incorrect ... the pam check is broken
Comment 5 Tim Ryan 2007-02-09 14:21:37 UTC
(In reply to comment #4)
> incorrect ... the pam check is broken

I agree.There must be a reason that that check was done, but I don't know it. I solved the problem by upgrading to pam-, and it installed without a problem and seems to be working fine.
Comment 6 Diego Elio Pettenò (RETIRED) gentoo-dev 2007-11-04 15:39:36 UTC
Linux-PAM 0.78 is no more supported, please all upgrade to 0.99.