Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 16435 - Compilation of xfree aborts due to parse and syntax errors of xf86str.h
Summary: Compilation of xfree aborts due to parse and syntax errors of xf86str.h
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC Linux
: High blocker (vote)
Assignee: PPC Porters
Depends on:
Reported: 2003-02-26 20:15 UTC by Viktor Jesina
Modified: 2006-02-04 06:03 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

compile-output from compilation of xfree (error_xfree.txt.gz,53.78 KB, application/x-gzip)
2003-03-09 09:29 UTC, Viktor Jesina
source with errors (xf86str.h,28.27 KB, text/x-chdr)
2003-03-09 09:30 UTC, Viktor Jesina
source with error (xf86pciBus.c,88.97 KB, text/x-csrc)
2003-03-09 09:33 UTC, Viktor Jesina
source with errors (xf86Bus.c,82.13 KB, text/x-csrc)
2003-03-09 09:34 UTC, Viktor Jesina
source with errors (lnxResource.c,9.58 KB, text/x-csrc)
2003-03-09 09:34 UTC, Viktor Jesina

Note You need to log in before you can comment on or make changes to this bug.
Description Viktor Jesina 2003-02-26 20:15:50 UTC
I tried to install XFree86 with emerge xfree. After 2 hours of compiling, the
compilation aborts. In line 619,620,621 of xf86str.h are parser errors befor `.`
and in Line 659 is a parse error (I found a single letter `c`, which belongs to
nowhere, in line 657). So the file /programs/Xserver/hw/xfree86/common/xf86str.h
seems to be corrupted.

Reproducible: Always
Steps to Reproduce:
1.emerge xfree

Actual Results:  
compilation abort

Expected Results:  
successful compilation
Comment 1 Mark Guertin 2003-02-27 11:27:04 UTC
can you attach that file here please?  Also the output of emerge info would be 
good too :) 
Comment 2 Martin Schlemmer (RETIRED) gentoo-dev 2003-02-27 14:11:33 UTC
Some corruption somewhere ?  Check that you do not have HTREE (also called
dir_index) enabled on ext3 ... I run into some bad luck with it.
Comment 3 Mark Guertin 2003-03-07 14:00:43 UTC
okay, been two weeks on this one

A few more days and I'll close it assuming this is not re-creatable unless we hear different, thanks.
Comment 4 Viktor Jesina 2003-03-09 09:29:25 UTC
Created attachment 9162 [details]
compile-output from compilation of xfree


here is the file and the compile-output. There are errors (parse errors, 
syntax error and strays of `\`) in the following files : 


Sorry, it took that long to post it. 
I deleted the sources and tried it again, but every time the same result.
Comment 5 Viktor Jesina 2003-03-09 09:30:20 UTC
Created attachment 9163 [details]
source with errors
Comment 6 Viktor Jesina 2003-03-09 09:33:34 UTC
Created attachment 9164 [details]
source with error
Comment 7 Viktor Jesina 2003-03-09 09:34:06 UTC
Created attachment 9165 [details]
source with errors
Comment 8 Viktor Jesina 2003-03-09 09:34:37 UTC
Created attachment 9166 [details]
source with errors
Comment 9 Graham Forest 2003-04-22 15:53:47 UTC
This has been sadly neglected. There was somewhat of a reason, as Gerk left, but there isn't really an excuse. Fortunately, there is a whole new version of xfree out. Does this issue still apply?
Comment 10 Graham Forest 2003-04-27 21:53:17 UTC
I don't like closing bugs because they've gone out of date, but we can reopen it if it is still a problem. xfree-4.3.0-r2 is very nice, and -r3 with improved ppc compile times is due out soon.
Comment 11 Luca Barbato gentoo-dev 2004-11-28 23:26:00 UTC