Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 163375 - dev-libs/beecrypt-4.1.2-r2 fails with USE="-doc"
Summary: dev-libs/beecrypt-4.1.2-r2 fails with USE="-doc"
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Sandro Bonazzola (RETIRED)
URL:
Whiteboard:
Keywords:
: 163526 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-01-23 01:00 UTC by Erik Zeek
Modified: 2007-01-24 11:53 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Zeek 2007-01-23 01:00:29 UTC
The last line of the ebuild is not quite right.

use doc && dohtml -r docs/html/. || die "dohtml failed"

If doc is not set, then the die statement is run.  Perhaps the following would work:

use doc && ( dohtml -r docs/html/. || die "dohtml failed" )
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-01-23 01:03:43 UTC
How about

if use doc ; then
        dohtml -r docs/html/. || die "dohtml failed"
fi

;)
Comment 2 Erik Zeek 2007-01-23 01:36:53 UTC
(In reply to comment #1)
> How about
> 
> if use doc ; then
>         dohtml -r docs/html/. || die "dohtml failed"
> fi
> 
> ;)
> 

I imagine that this would fix it too.  

I've tested the first version and it workd just fine with doc set or unset.
Comment 3 Bernard Cafarelli gentoo-dev 2007-01-23 12:09:10 UTC
Multiple same-priority level operators on the same line does not help human-readability ;) 

Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-01-24 01:15:06 UTC
*** Bug 163526 has been marked as a duplicate of this bug. ***
Comment 5 Alec Warner archtester Gentoo Infrastructure gentoo-dev Security 2007-01-24 01:32:46 UTC
fixed in cvs, thanks for reporting.
Comment 6 Sandro Bonazzola (RETIRED) gentoo-dev 2007-01-24 11:53:30 UTC
Verified working, closing; thanks all for reporting, proposing a solution, and fixing in cvs. I've some phone trouble, actually I can't stay online more than 10 seconds per hour due to no carrier signal, maybe I'll be away until monday.