Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 16334 - gentoo-sources kernel compiled for Athlon cannot load modules
Summary: gentoo-sources kernel compiled for Athlon cannot load modules
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: Highest blocker (vote)
Assignee: (DEPRECATED)
Depends on:
Reported: 2003-02-25 00:29 UTC by Ibukun Olumuyiwa
Modified: 2003-11-22 15:42 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Ibukun Olumuyiwa 2003-02-25 00:29:58 UTC
During the process of installing Gentoo Linux 1.4RC2 from the LiveCD, I ran into
the following problem while trying to install the kernel: The kernel image
successfully loaded, but the system was unable to load any modules because they
all had unresolved symbols. Specifically, any module I tried to load came up
with the unresolved symbol "_mmx_memcpy". The kernel was compiled to various
Pentium II-class kernels, particularly the Athlon targets. The issue went away
only when I compiled to a 586/686 target, and the boot loader used is Grub. Even
after repeated cleans, deps and remakes, this issue persisted.

The target system is an Athlon 1.3GHz with 256MB memory (probably extraneous info).
Comment 1 Brandon Low (RETIRED) gentoo-dev 2003-03-01 14:05:42 UTC
Hmm... please send me a .config so I can figure out what is going wrong here, because I have that kernel running on 1 athlon and 2 athlon-xp systems in this room alone...
Comment 2 Jay Pfeifer (RETIRED) gentoo-dev 2003-04-15 18:55:17 UTC
hmm. closing this until we can get more info on this bug as it cannot be reproduced. 
Comment 3 Martin Holzer (RETIRED) gentoo-dev 2003-09-25 14:19:19 UTC
Comment 4 zeist 2003-11-22 15:42:18 UTC
I've the same problem with my gentoo box, it's a dual athlon-Mp 2400 box with Gigabyte MB. it seem that every kernel compiled with gentoo-sources or wolk-sources IF compile for something more than PII (included) wreak havoc on my system, not only lots of modules can't be loaded with the same error, but the system remain highly unstable, freezing very often without leaving any sign in the logs.
This could be anything related with the infamous AMD cpu's bug?

Nicola Ragozzino