Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 1627 - Gentoo 1.1a ISO Install Problems: Portage or binutils?
Summary: Gentoo 1.1a ISO Install Problems: Portage or binutils?
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Daniel Robbins (RETIRED)
Depends on:
Reported: 2002-04-09 17:10 UTC by destruktion
Modified: 2003-02-04 19:42 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description destruktion 2002-04-09 17:10:12 UTC
[posted to the user and dev lists, someone wanted me to
file this bug report]

apparently, i'm not the only one who has this problem.
(see the gentoo-dev mailing list)

i've had the 1.0 prerelease working for several
months and decided to do a fresh install of the
newest 1.1a.

[system: i686 Athlon 1.2 GHz, 1024 MB RAM, using
optimisations: -march i686, etc.]

with the new 1.1a Gentoo ISO install disk,

1) there's no longer the new colorful prompt just
after chrooting in, doing the env-update, and sourcing

2) portage has major difficulty during a compile of
binutils- each time i've tried
to run the script, the compile stops at
random (generally in the middle of a autoconf/make? step
where it checks this or that, etc.).
i've tried this several times varying compiler
options and .isos (1.0, 1.1, 1.1a). where it stops is
different each time. when i control-c, it says that
portage is being killed by SIGINT; exiting, then it
just hangs, i.e. it isn't killed.

any ideas as to how i can get a new system up and running?
is this a portage problem or a binutils problem???

Comment 1 Daniel Robbins (RETIRED) gentoo-dev 2002-04-09 19:46:32 UTC
This sounds like a hardware problem.  Test your memory with memtest86 (see
freshmeat) and then ensure that your CPU is being adequately cooled.  Random
halts during long compiles are generally indicative of either bad memory or very
likely an overheating CPU.
Comment 2 destruktion 2002-04-10 02:17:16 UTC
although minor, the new prompt is/was cool.  is there a better way to kill
portage during the bootstrap process than control-c ?  (it's never killed,
and i usu. have to reboot)

i strongly DOUBT that this is a hardware problem.  as mentioned, i've had 
numerous success fresh installations previous to this one.  the box is very
well-cooled.  there are four 256MB chips of RAM.  i could try to remove three
of them to see if it will work with one.  but i think it's still highly unlikely
that the memory is bad.  (i'll look into this though).  the other person who
reported a similar problem has two machines with the same results as me.  are
we all suffering from faulty hardware?

just a few days ago, compiling, installing large bits of code was not a problem.
it seems odd that when trying a fresh install, these issues arise.  have you
any other suggestions than hardware diagnostics/upgrades?
Comment 3 destruktion 2002-04-10 05:53:31 UTC
ok.  now i'm pretty sure it's not a hardware problem.  the RAM passed two
hours of memtest86, and passed all seven tests on a first pass and the first
several of a second pass.  there were zero errors reported for the entire 
testing session.  second, i have an atx tower with five fans in it, well-placed,
so it should not be a overheating problem.  i'll admit, you got me a bit worried
about having to replace hardware, but  now the problem still persists.  what
do you advise?  thanks in advance.
Comment 4 destruktion 2002-04-10 18:01:38 UTC
i got an idea while scanning the mailing lists... since it's not a hardware
problem, could it be a kernel instability problem?  perhaps a Gentoo 1.1a
install ISO with a stable kernel (they've been stable for me) from the
prerelease ISOs, would solve this problem.  at least it could get me up
and running until i compile a more recent version.

how could i go about doing/testing this?

i don't have access to a linux box since i'm trying to get that running!
but i can burn isos on the mac.
Comment 5 Daniel Robbins (RETIRED) gentoo-dev 2002-04-10 23:32:17 UTC
Try using mem=512m as a kernel boot option.  This should fix it -- it looks like
highmem is broken in our kernels.  Please also reply to this and post your
motherboard/chipset/CPU info here.  Thanks.
Comment 6 Daniel Robbins (RETIRED) gentoo-dev 2002-04-11 13:16:34 UTC
Also, are you installing on XFS?
Comment 7 destruktion 2002-04-11 17:51:09 UTC
yes.  ext3 boot partition, and all the rest are XFS.  anyway, good news.
although the 'bug' may not be 'solved', my problems are resolved.  i'm
writing from my new Gentoo 1.1a system.  (!!!!!)

It seems to be indeed a kernel problem.  just after posting my last suggestion
about this being kernel-related, i found my old Gentoo 1.0 prerelease which
got my last system up, and booted from it, then unzipped the recent 1.1a
stage-1-tbz2 file.  everything went as expected.

because of my experience with the newest kernel, and the constant complaints
on the mailing lists, i'm extremely hesitant to try anything post 2.4.17-r5.

as per the 'bug', it seems that the kernel on the iso doesn't really like
some hardware setups, incl. as you may have known, those with a lot of RAM.
(i'm using a dual 1.2 GHz AMD SMP system with 1024 MB RAM)

i'll leave it to you as to whether or not you wish to close the bug.

thanks for everything!
Comment 8 Daniel Robbins (RETIRED) gentoo-dev 2002-04-12 23:45:14 UTC
ok, will fix next kernel.  This seems to be a problem with our XFS *patch* (that
we added), and you shouldn't blame the Linux kernel in general. :)